Highlighted

Strange temp/duplicate/cache files?

New Here ,
Apr 01, 2018

Copy link to clipboard

Copied

Hi all,

I've tried searching the forums and Google for an answer to this, but haven't come up with any answers. My problem is that Dreamweaver CC 2018 is creating sort of duplicate local files that get pushed to the testing server (e.g., 'editDetails.php', 'editDetails_T0FTN694UO.php', 'editDetails_T1J39694W3.php'). That server then uses these files instead of the "correct" file, so the QA team complains to us that we're not making the fixes when their browser keeps hitting 'editDetails_T1J39694W3.php' while the URL reads 'editDetails.php.'

We've tried turning autopush and synchronize on and off, but it doesn't seem to make any difference. It's like these are some kind of temp file that Dreamweaver just isn't cleaning up. I've tried switching from Live preview to Design, but it still keeps wanting to default to Live preview. Any ideas on what these files are and how to keep them off the test server aside from manually finding and deleting them? Thank you!

Vince

Adobe Community Professional
Correct answer by Nancy OShea | Adobe Community Professional

Go to Edit > Preferences (Ctrl+U) > Real-Time Preview > Options.  Disable Preview using temporary file.

TOPICS
Dreamweaver | Mac OS issues

Views

686

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Strange temp/duplicate/cache files?

New Here ,
Apr 01, 2018

Copy link to clipboard

Copied

Hi all,

I've tried searching the forums and Google for an answer to this, but haven't come up with any answers. My problem is that Dreamweaver CC 2018 is creating sort of duplicate local files that get pushed to the testing server (e.g., 'editDetails.php', 'editDetails_T0FTN694UO.php', 'editDetails_T1J39694W3.php'). That server then uses these files instead of the "correct" file, so the QA team complains to us that we're not making the fixes when their browser keeps hitting 'editDetails_T1J39694W3.php' while the URL reads 'editDetails.php.'

We've tried turning autopush and synchronize on and off, but it doesn't seem to make any difference. It's like these are some kind of temp file that Dreamweaver just isn't cleaning up. I've tried switching from Live preview to Design, but it still keeps wanting to default to Live preview. Any ideas on what these files are and how to keep them off the test server aside from manually finding and deleting them? Thank you!

Vince

Adobe Community Professional
Correct answer by Nancy OShea | Adobe Community Professional

Go to Edit > Preferences (Ctrl+U) > Real-Time Preview > Options.  Disable Preview using temporary file.

TOPICS
Dreamweaver | Mac OS issues

Views

687

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Apr 01, 2018 0
Adobe Community Professional ,
Apr 01, 2018

Copy link to clipboard

Copied

When Dreamweaver crashes, it saves a temporary file with the original name plus a code. When you restart DW, the program asks you if you want to keep the temporary file so that you will not lose your edits. Answering 'no', will delete the file.


Ben

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 01, 2018 1
Boroboy LATEST
New Here ,
Apr 02, 2018

Copy link to clipboard

Copied

Thanks for the quick response. We have run into those files before, but these were happening without it crashing.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 02, 2018 0
Adobe Community Professional ,
Apr 01, 2018

Copy link to clipboard

Copied

Go to Edit > Preferences (Ctrl+U) > Real-Time Preview > Options.  Disable Preview using temporary file.

Nancy O'Shea, ACP
Alt-Web Design & Publishing

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 01, 2018 1
New Here ,
Apr 02, 2018

Copy link to clipboard

Copied

That did the trick - thank you!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 02, 2018 0