Highlighted

Sudden Dreamweaver template problem: Live view not working anymore

New Here ,
Jun 30, 2020

Copy link to clipboard

Copied

I have been working on a new website for several months, without problems. After leaving the project alone for about 2 days I suddenly have a problem with my templates: Live view shows code instead of the live view ... The code is all black, so not coloured like in code view. When I preview the page in a browser it shows perfectly fine. I tried to go several versions back - up to versions of about a month ago - didn't help. Also the DOM panel doesn't work in the template files.

Maybe it is related: I have another problem as well. I seem not to be able to select things in documents based on the templates. I can select them, but the selections are grey instead of blue (in the editable areas).

Any idea what the problem could be?

Views

48

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Sudden Dreamweaver template problem: Live view not working anymore

New Here ,
Jun 30, 2020

Copy link to clipboard

Copied

I have been working on a new website for several months, without problems. After leaving the project alone for about 2 days I suddenly have a problem with my templates: Live view shows code instead of the live view ... The code is all black, so not coloured like in code view. When I preview the page in a browser it shows perfectly fine. I tried to go several versions back - up to versions of about a month ago - didn't help. Also the DOM panel doesn't work in the template files.

Maybe it is related: I have another problem as well. I seem not to be able to select things in documents based on the templates. I can select them, but the selections are grey instead of blue (in the editable areas).

Any idea what the problem could be?

Views

49

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Jun 30, 2020

Copy link to clipboard

Copied

Problem is already solved ... I searched the forum before posting but couldn't find a similar problem. After posting the question related conversation did pop up ... and there I found something i totally forgot about: validating the page. It gave an error: there was a line of text above <!DOCTYPE html>: the keywords I added. Now, interestingly: I added these keywords months ago, through Insert, HTML, Keywords ... I did notice then that they ended up in a very weird place, but it worked just fine. Until this afternoon ... Anyway, problem solved.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jun 30, 2020

Copy link to clipboard

Copied

Well, not entirely solved ... I still cannot edit anything in live view. I get grey boxes instead of blue ones, and the properties panel is greyed out as well. I am working with error free code. I am working with a few templates, and I realize that working in live view with templates can be tricky. However, until now I was able to work in pages based on templates in the editable areas. That all of a sudden stopped. So I still need your help ...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jun 30, 2020

Copy link to clipboard

Copied

It's unclear to me if you're working with a .dwt file or child page. 

Please switch to Design View. See screenshot.

Document ToolbarDocument Toolbar

 

Failing that, we need to see the URL to 1) a Template and 2) a child page spawned from that template. 

 

 

Nancy O'Shea, ACP
Alt-Web.com

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jun 30, 2020

Copy link to clipboard

Copied

It goes for both the template and the child file ( see above). I know how to switch to design view, and there it works. However, it used to work in live view too, a bit on and off when editing the template, and always when working on a child page (in the editable regions only of course). But all of a sudden it doesn't anymore. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...