Highlighted

WebDAV connection refused after latest CC update

Participant ,
Jun 23, 2020

Copy link to clipboard

Copied

Dreamweaver CC, latest version (june update), connecting to WebDAV

 

Hi,

"suddenly" DW refuses to connect to a site via WebDAV.

Maybe it's such a problem which I found by a web search:

https://helpx.adobe.com/dreamweaver/kb/webdav-error-connecting-server-using.html

– but it's for an older version of DW (and the link to an updated version of NetIODav.dll is broken):

 

In Adobe Dreamweaver CS3, when you try to make a WebDAV connection to a server using Basic authentication for the PROPFIND command, the connection fails and the following message is displayed:

"Cannot display the remote folder: An HTTP WebDAV error occurred. Dreamweaver cannot get a listing for the folder you specified. Make sure you have proper authorization on the server, and the server is properly configured. Make sure the remote folder is available or select a different one by clicking Manage Sites. To try again, click the Refresh button in the Files panel."

The WebDAV connection is successful with earlier versions of Dreamweaver.

This problem only occurs when the WebDAV server doesn't require authentication for the OPTION command, but the server does require Basic authentication for the PROPFIND command. Most WebDAV users are not affected by this issue. (Ref. 226989)

 

2020-06-23_shot_001_shot.jpg

 

Does anyone know the solution?

Thanks!

mycc

Adobe Community Professional
Correct answer by Nancy OShea | Adobe Community Professional

Dreamweaver has nothing to do with server configuration.  If your host is doing their job correctly, you should have SSL/TLS certificates installed.  SSL certificates come standard with most reputable hosting plans now.

 

Once the certificates are installed, all HTTP incoming traffic should redirect to the secure HTTPS server.  Linux servers use an .htaccess file while Win IIS servers use a config file.  If unsure, contact your hosting provider for assistance.   It's possible your server's certificates have expired and need to be renewed.  But I don't think DW updates had anything to do with this.  It's probably just coincidental timing.

 

TOPICS
Error, How to, Product issue

Views

177

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

WebDAV connection refused after latest CC update

Participant ,
Jun 23, 2020

Copy link to clipboard

Copied

Dreamweaver CC, latest version (june update), connecting to WebDAV

 

Hi,

"suddenly" DW refuses to connect to a site via WebDAV.

Maybe it's such a problem which I found by a web search:

https://helpx.adobe.com/dreamweaver/kb/webdav-error-connecting-server-using.html

– but it's for an older version of DW (and the link to an updated version of NetIODav.dll is broken):

 

In Adobe Dreamweaver CS3, when you try to make a WebDAV connection to a server using Basic authentication for the PROPFIND command, the connection fails and the following message is displayed:

"Cannot display the remote folder: An HTTP WebDAV error occurred. Dreamweaver cannot get a listing for the folder you specified. Make sure you have proper authorization on the server, and the server is properly configured. Make sure the remote folder is available or select a different one by clicking Manage Sites. To try again, click the Refresh button in the Files panel."

The WebDAV connection is successful with earlier versions of Dreamweaver.

This problem only occurs when the WebDAV server doesn't require authentication for the OPTION command, but the server does require Basic authentication for the PROPFIND command. Most WebDAV users are not affected by this issue. (Ref. 226989)

 

2020-06-23_shot_001_shot.jpg

 

Does anyone know the solution?

Thanks!

mycc

Adobe Community Professional
Correct answer by Nancy OShea | Adobe Community Professional

Dreamweaver has nothing to do with server configuration.  If your host is doing their job correctly, you should have SSL/TLS certificates installed.  SSL certificates come standard with most reputable hosting plans now.

 

Once the certificates are installed, all HTTP incoming traffic should redirect to the secure HTTPS server.  Linux servers use an .htaccess file while Win IIS servers use a config file.  If unsure, contact your hosting provider for assistance.   It's possible your server's certificates have expired and need to be renewed.  But I don't think DW updates had anything to do with this.  It's probably just coincidental timing.

 

TOPICS
Error, How to, Product issue

Views

178

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jun 23, 2020 0
Adobe Community Professional ,
Jun 23, 2020

Copy link to clipboard

Copied

If it worked in 2019,  suggest you create a new site definition and delete the old one.

 

Nancy O'Shea, ACP
Alt-Web Design & Publishing

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 23, 2020 0
Participant ,
Jun 23, 2020

Copy link to clipboard

Copied

No, creating a new site defintion – of course with the same pathes – does not solve the problem – using DW 20.2, 15263.

It worked till the mentioned latest update over years...

 

But I discovered: if I open the server adress http://... with my default browser (Vivaldi) it tries to open https://... -- this fails.

But after clearing the cache the browser opens the path http//... "correctly" without a forwarding

 

Therefore: does such a forwarding happen within Dreamweaver in the background and therefore it can't connect to the site?

Really strange ...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 23, 2020 0
Adobe Community Professional ,
Jun 23, 2020

Copy link to clipboard

Copied

Dreamweaver has nothing to do with server configuration.  If your host is doing their job correctly, you should have SSL/TLS certificates installed.  SSL certificates come standard with most reputable hosting plans now.

 

Once the certificates are installed, all HTTP incoming traffic should redirect to the secure HTTPS server.  Linux servers use an .htaccess file while Win IIS servers use a config file.  If unsure, contact your hosting provider for assistance.   It's possible your server's certificates have expired and need to be renewed.  But I don't think DW updates had anything to do with this.  It's probably just coincidental timing.

 

Nancy O'Shea, ACP
Alt-Web Design & Publishing

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 23, 2020 2
Participant ,
Jul 01, 2020

Copy link to clipboard

Copied

Something has changed in our server configuration. We have to use "our" URL without a port number.

 

Thank you very much for your support!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 01, 2020 0
Adobe Employee ,
Jul 15, 2020

Copy link to clipboard

Copied

Hi mycc,

 

Can you please confirm whether you are still seeing the error you mentioned above, while connecting to webDAV server with Dreamweaver 20.2, so that we can investigate the issue at our end.

Also as you mentioned using your url without a port has fixed the issue, but without using the port in the url is the error not seen with Dreamweaver 20.1 and seen with only 20.2.

 

Thanks

Dreamweaver Team

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 15, 2020 0