Highlighted

Why is my link broken??

Community Beginner ,
Oct 02, 2017

Copy link to clipboard

Copied

I have to make links to pictures "absolute" links for constant contact.
However, if you look down at the bottom of the page to the left, the little page is broken, however, the actual link i have is correct. Thats the link to the folder that every other picture on this email is in, so im confused on why the link is broken for just this specific picture? Screen Shot 2017-10-02 at 1.11.39 PM.png

Adobe Community Professional
Correct answer by Jon Fritz II | Adobe Community Professional

The latest version, with the link from your screenshot, opens fine for me in W7 browsers.

TOPICS
Learn Dreamweaver

Views

332

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Why is my link broken??

Community Beginner ,
Oct 02, 2017

Copy link to clipboard

Copied

I have to make links to pictures "absolute" links for constant contact.
However, if you look down at the bottom of the page to the left, the little page is broken, however, the actual link i have is correct. Thats the link to the folder that every other picture on this email is in, so im confused on why the link is broken for just this specific picture? Screen Shot 2017-10-02 at 1.11.39 PM.png

Adobe Community Professional
Correct answer by Jon Fritz II | Adobe Community Professional

The latest version, with the link from your screenshot, opens fine for me in W7 browsers.

TOPICS
Learn Dreamweaver

Views

333

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 02, 2017 0
Adobe Community Professional ,
Oct 02, 2017

Copy link to clipboard

Copied

Your document contains code errors denoted by the red X in a circle.  Open your Output panel (Shift+F6) for details on what those might be.  Or, run your document through code validation.

CC-BugReport.jpg

Nancy O'Shea, ACP
Alt-Web Design & Publishing

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 02, 2017 0
Adobe Community Professional ,
Oct 02, 2017

Copy link to clipboard

Copied

While Nancy makes a good point, and you should always try to work with valid code, I'm pretty sure DWCC2017 just "does that" with externally referenced files (shows the broken image icon in the Properties window). At least, it does on all of the files I've tested (CC 2017.5 under Windows 7).

As long as the image is showing in Live View, or more importantly, in a browser, the link is fine. I don't think the latest incarnation of DW knows how to handle the image thumbnail that normally appears there when you use local files.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 02, 2017 1
Community Beginner ,
Oct 02, 2017

Copy link to clipboard

Copied

The thing is, when i put the html into constant contact to send out as an email, the photos that do not have a preview of them in the properties section are the ones that come up as missing in the preview of the email.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 02, 2017 0
Adobe Community Professional ,
Oct 02, 2017

Copy link to clipboard

Copied

And you're 100% sure you've uploaded the images to that folder (exact names, down to the case structure too)?

For what it's worth, the link from your screenshot gives me 404 File not found when I enter it in my browser.

EDIT: To build on the above...

When I go to the "images" folder shown in your link code, with a lower case i, I get 404 File not found, which is what I would expect if the folder didn't exist.

When I use an upper case i "Images", I get the "403 Forbidden" error I would expect if directory browsing were turned off on your server.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 02, 2017 2
Community Beginner ,
Oct 02, 2017

Copy link to clipboard

Copied

Yeah, i removed it from my server while i was trying to edit it.

The thing is, when i change the last part of the link name to a different photo name, it pops up and the properties is showing the preview of the photo.
And the second i change it to the name of the bus, it shows the broken one.
And i tripled checked all my other photo links and they are all identical. Its strange and i just dont know what would cause this specific picture to be doing it, no matter where in the html i put it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 02, 2017 0
Community Beginner ,
Oct 02, 2017

Copy link to clipboard

Copied

Screen Shot 2017-10-02 at 4.12.51 PM.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 02, 2017 0
Adobe Community Professional ,
Oct 02, 2017

Copy link to clipboard

Copied

How many of your other images include spaces in their file names?

That's technically invalid under the html spec and can cause problems in certain browsers. Using underscores or hyphens is a better route to go.

Another issue that can come up, with certain browsers, is accidentally saving a .jpg in the CMYK color space.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 02, 2017 0
Community Beginner ,
Oct 02, 2017

Copy link to clipboard

Copied

I will double check to see if it is cmyk or rgb, i have not done that yet.
However, the first screen shot in my question has the image with a name with no spaces or hypens or anything like that. I just keep deleting and resaving it. but i will check the color mode !!! Havent thought of that yet.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 02, 2017 0
Adobe Community Professional ,
Oct 02, 2017

Copy link to clipboard

Copied

The latest version, with the link from your screenshot, opens fine for me in W7 browsers.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 02, 2017 0
Community Beginner ,
Oct 02, 2017

Copy link to clipboard

Copied

does it?
Maybe ill test this one out in constant contact then. THANK YOU

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 02, 2017 0
Community Beginner ,
Oct 02, 2017

Copy link to clipboard

Copied

That seems to have done the trick ! Thanks again. you're a life saver

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 02, 2017 0