• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Creative Cloud Packager issue with 2017

Explorer ,
Nov 16, 2016 Nov 16, 2016

Copy link to clipboard

Copied

Its all been rather frustrating, but I can't get the msi that the creative cloud packager to work. I've made 4 of these - just because I'm not sure if I checked the right boxes on to make it all work.

The PDApp.log - suggests I don't have connectivity - I do... I've even tested the installer on a machine with a public IP... Not using a proxy, but I've turned the option on and off just for fun.

11/16/16 09:09:13:248 | [FATAL] |  | ASU | DeploymentManager | DeploymentManager |  |  | 9052 | Failed to create the Bootstrapper process.Stopping the installation process.

11/16/16 09:09:13:248 | [INFO] |  | ASU | DeploymentManager | Utilities |  |  | 9052 | Folder does not exist

11/16/16 09:09:13:284 | [INFO] |  | ASU | OPM | OPM |  |  | 9052 | Build Version - 10.0.0.13

11/16/16 09:09:13:284 | [INFO] |  | ASU | OPM | OPM |  |  | 9052 | Logging Level verbosity Set  to 4

11/16/16 09:09:13:316 | [WARN] |  | ASU | OPM | OPM |  |  | 9052 | Failed in key1 generation

11/16/16 09:09:13:328 | [WARN] |  | ASU | OPM | OPM |  |  | 9052 | Failed in key1 generation

11/16/16 09:09:13:328 | [WARN] |  | ASU | OPM | CryptEngine |  |  | 9052 | Failed in key1 generation

11/16/16 09:09:13:529 | [WARN] |  | ASU | OPM | OPM |  |  | 9052 | Failed in key3List generation

11/16/16 09:09:13:530 | [ERROR] |  | ASU | OPM | CryptEngine |  |  | 9052 | Failed in key3List generation

11/16/16 09:09:13:534 | [INFO] |  | ASU | OPM | OPM |  |  | 9052 | Schema version and schema compatibility version are same or greater than current

11/16/16 09:09:13:534 | [INFO] |  | ASU | OPM | OPM |  |  | 9052 | _opm_handle_OPDReturnedStatus called with opdStatus as:0

11/16/16 09:09:13:534 | [INFO] |  | ASU | OPM | OPM |  |  | 9052 | No Record found for the input fields in opm_getValueForKey

11/16/16 09:09:13:712 | [INFO] |  | ASU | DeploymentManager | AAMEEUtilities |  |  | 9052 | The output of process received  in execWithOutput :

Microsoft Windows [Version 10.0.10586]

11/16/16 09:09:13:714 | [INFO] |  | ASU | DeploymentManager |  |  |  | 9052 | Event Guid generated is: '85af7384-b71e-435c-8faf-bb8e09a14ea8'

11/16/16 09:09:13:804 | [INFO] |  | ASU | DeploymentManager |  |  | HTTPConnector | 9052 | GetIEProxyInfo - Failed to get proxy for the url, error:12180

11/16/16 09:09:14:395 | [INFO] |  | ASU | DeploymentManager |  |  | HTTPConnector | 12560 | HTTP Request Status code 200.

11/16/16 09:09:14:395 | [INFO] |  | ASU | DeploymentManager |  |  | HTTPConnector | 9052 | The http request returned HTTP_Status:0 HttpCommunicator error:0

11/16/16 09:09:14:408 | [INFO] |  | ASU | DeploymentManager |  |  |  | 9052 | Waiting for the async thread to get the task completed

11/16/16 09:09:14:416 | [INFO] |  | ASU | DeploymentManager |  |  |  | 12020 | Async thread is completed. Now exiting from function.

11/16/16 09:09:14:478 | [INFO] |  | ASU | DeploymentManager | DeploymentManager |  |  | 9052 | The install workflow is terminating.

Views

7.7K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 16, 2016 Nov 16, 2016

Copy link to clipboard

Copied

Freshly imaged Win 7 machine:

11/16/16 10:07:36:265 | [WARN] |  | ASU | DeploymentManager | XMLParser |  |  | 4852 | Caught exception in ... initWithXMLPath. com error:80070005  system error:0

11/16/16 10:07:36:265 | [WARN] |  | ASU | DeploymentManager | DeploymentManager |  |  | 4852 | Failed to initialize from ApplicationInfo.xml (\\psu\sccm\CampusWide-Packages\Adobe Creative Cloud 2017 Primary Apps Device License\Files\ASU\packages\ApplicationInfo.xml)...

11/16/16 10:07:36:265 | [WARN] |  | ASU | DeploymentManager | DeploymentManager |  |  | 4852 | Failed to find the latest AAM version ...

11/16/16 10:07:36:266 | [INFO] |  | ASU | DeploymentManager | DeploymentManager |  |  | 4852 | Install language fallback contains following languages :

11/16/16 10:07:36:266 | [INFO] |  | ASU | DeploymentManager | DeploymentManager |  |  | 4852 |     (en_US)

11/16/16 10:07:36:266 | [INFO] |  | ASU | DeploymentManager | DeploymentManager |  |  | 4852 | Self-Update BootStrapper Relative Path doesn't exist.

11/16/16 10:07:36:266 | [INFO] |  | ASU | DeploymentManager | DeploymentManager |  |  | 4852 | No of updates found (0).

11/16/16 10:07:36:266 | [INFO] |  | ASU | DeploymentManager | DeploymentManager |  |  | 4852 | No of HD products found (15).

11/16/16 10:07:36:295 | [ERROR] |  | ASU | DeploymentManager | DeploymentManager |  |  | 4852 | Failed to get value for conflicting processes...

11/16/16 10:07:36:295 | [WARN] |  | ASU | DeploymentManager | DeploymentManager |  |  | 4852 | Failed to parse the conflictProcessInfo for HD media (COCM1.0)...

11/16/16 10:07:36:323 | [ERROR] |  | ASU | DeploymentManager | DeploymentManager |  |  | 4852 | Failed to get value for conflicting processes...

11/16/16 10:07:36:323 | [WARN] |  | ASU | DeploymentManager | DeploymentManager |  |  | 4852 | Failed to parse the conflictProcessInfo for HD media (COPS1.0)...

11/16/16 10:07:36:335 | [ERROR] |  | ASU | DeploymentManager | DeploymentManager |  |  | 4852 | Failed to get value for conflicting processes...

11/16/16 10:07:36:335 | [WARN] |  | ASU | DeploymentManager | DeploymentManager |  |  | 4852 | Failed to parse the conflictProcessInfo for HD media (CORE1.0)...

11/16/16 10:07:36:346 | [ERROR] |  | ASU | DeploymentManager | DeploymentManager |  |  | 4852 | Failed to get value for conflicting processes...

11/16/16 10:07:36:346 | [WARN] |  | ASU | DeploymentManager | DeploymentManager |  |  | 4852 | Failed to parse the conflictProcessInfo for HD media (CORG1.0)...

11/16/16 10:07:36:351 | [ERROR] |  | ASU | DeploymentManager | DeploymentManager |  |  | 4852 | Failed to get value for conflicting processes...

11/16/16 10:07:36:351 | [WARN] |  | ASU | DeploymentManager | DeploymentManager |  |  | 4852 | Failed to parse the conflictProcessInfo for HD media (KFNT1.0.0)...

11/16/16 10:07:36:362 | [ERROR] |  | ASU | DeploymentManager | DeploymentManager |  |  | 4852 | Failed to get value for conflicting processes...

11/16/16 10:07:36:362 | [WARN] |  | ASU | DeploymentManager | DeploymentManager |  |  | 4852 | Failed to parse the conflictProcessInfo for HD media (PSTI1.3.0)...

11/16/16 10:07:36:372 | [INFO] |  | ASU | DeploymentManager | DeploymentManager |  |  | 4852 | Custom deployment path doesnt exist in options XML

11/16/16 10:07:36:386 | [INFO] |  | ASU | DeploymentManager | DeploymentManager |  |  | 4852 | Found the AppsPanel attribute info (true)

11/16/16 10:07:36:386 | [INFO] |  | ASU | DeploymentManager | DeploymentManager |  |  | 4852 | Found the AdminPrivilege attribute info (true)

11/16/16 10:07:36:387 | [INFO] |  | ASU | DeploymentManager | DeploymentManager |  |  | 4852 | Number of Medias found = 1

11/16/16 10:07:36:390 | [INFO] |  | ASU | DeploymentManager | DeploymentManager |  |  | 4852 | Deployment XML created at path :: C:\Users\MJANTZ~1\AppData\Local\Temp\{7A33DC42-36F5-4661-8BB1-EFDD8588E7B6}\\{E9410CC5-1150-482A-A582-138118067BED}

11/16/16 10:07:36:398 | [INFO] |  | ASU | DeploymentManager | DeploymentManager |  |  | 4852 | Override XML created at path :: C:\Users\MJANTZ~1\AppData\Local\Temp\{7A33DC42-36F5-4661-8BB1-EFDD8588E7B6}\\{7F5A22F1-89D2-4C2B-ADDD-7EFCC159ED34}

11/16/16 10:07:36:399 | [INFO] |  | ASU | DeploymentManager | DeploymentManager |  |  | 4852 | Conflict process info retrieved (<ConflictingProcess headless="false" forceKillAllowed="false" adobeOwned="false"><RegularExpression>^[Ee][Xx][Cc][Ee][Ll]\.[Ee][Xx][Ee]$</RegularExpression><ProcessDisplayName>Microsoft Excel</ProcessDisplayName><ParentRegularExpression/><ParentDisplayName/><RelativePath/></ConflictingProcess><ConflictingProcess headless="false" forceKillAllowed="false" adobeOwned="false"><RegularExpression>^[Aa][Cc][Aa][Dd]\.[Ee][Xx][Ee]$</RegularExpression><ProcessDisplayName>AutoCAD</ProcessDisplayName><ParentRegularExpression/><ParentDisplayName/><RelativePath/></ConflictingProcess><ConflictingProcess headless="false" forceKillAllowed="false" adobeOwned="false"><RegularExpression>^[Ww][Ii][Nn][Ww][Oo][Rr][Dd]\.[Ee][Xx][Ee]$</RegularExpression><ProcessDisplayName>Microsoft Word</ProcessDisplayName><ParentRegularExpression/><ParentDisplayName/><RelativePath/></ConflictingProcess><ConflictingProcess headless="false" forceKillAllowed="false" adobeOwned="false"><RegularExpression>^[Vv][Ii][Ss

11/16/16 10:07:36:399 | [INFO] |  | ASU | DeploymentManager | DeploymentManager |  |  | 4852 | Deployment Manager is running in Install Mode.

11/16/16 10:07:36:400 | [INFO] |  | ASU | DeploymentManager | DeploymentManager |  |  | 4852 | STEP 2: Starting to launch ASU AAM.

11/16/16 10:07:36:400 | [INFO] |  | ASU | DeploymentManager | DeploymentManager |  |  | 4852 | Bootstrapper launch location is :: \\psu\sccm\CampusWide-Packages\Adobe Creative Cloud 2017 Primary Apps Device License\Files\ASU\Set-up.dat

11/16/16 10:07:36:408 | [INFO] |  | ASU | DeploymentManager | DeploymentManager |  |  | 4852 | Build Version - 1.10.0.26

11/16/16 10:07:36:408 | [INFO] |  | ASU | DeploymentManager | DeploymentManager |  |  | 4852 | Logging Level verbosity Set  to 4

11/16/16 10:07:36:408 | [FATAL] |  | ASU | DeploymentManager | DeploymentManager |  |  | 4852 | Failed to create the Bootstrapper process.Stopping the installation process.

11/16/16 10:07:36:408 | [INFO] |  | ASU | DeploymentManager | Utilities |  |  | 4852 | Folder does not exist

11/16/16 10:07:36:408 | [ERROR] |  | ASU | DeploymentManager | DeploymentManager |  |  | 4852 | Failed to get/verify the UpdaterCore inventory base path (C:\Program Files (x86)\Common Files\Adobe\AAMUpdaterInventory\1.0\)

11/16/16 10:07:36:408 | [WARN] |  | ASU | DeploymentManager | DeploymentManager |  |  | 4852 | sendAnalytics : Unable to find deviceId.

11/16/16 10:07:36:595 | [INFO] |  | ASU | DeploymentManager | AAMEEUtilities |  |  | 4852 | The output of process received  in execWithOutput :

Microsoft Windows [Version 6.1.7601]

11/16/16 10:07:36:602 | [INFO] |  | ASU | DeploymentManager |  |  |  | 4852 | Event Guid generated is: '00429d45-eeb2-44c6-ad94-affb828e2cd9'

11/16/16 10:07:36:656 | [INFO] |  | ASU | DeploymentManager |  |  | HTTPConnector | 4852 | GetIEProxyInfo - No default proxy present on the user machine

11/16/16 10:07:37:336 | [INFO] |  | ASU | DeploymentManager |  |  | HTTPConnector | 4484 | HTTP Request Status code 200.

11/16/16 10:07:37:336 | [INFO] |  | ASU | DeploymentManager |  |  | HTTPConnector | 4852 | The http request returned HTTP_Status:0 HttpCommunicator error:0

11/16/16 10:07:37:337 | [INFO] |  | ASU | DeploymentManager |  |  |  | 4852 | Waiting for the async thread to get the task completed

11/16/16 10:07:37:345 | [INFO] |  | ASU | DeploymentManager |  |  |  | 3504 | Async thread is completed. Now exiting from function.

11/16/16 10:07:37:349 | [INFO] |  | ASU | DeploymentManager | DeploymentManager |  |  | 4852 | The install workflow is terminating.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 17, 2016 Nov 17, 2016

Copy link to clipboard

Copied

When the package is created there is a list of conflicting applications included in the Build folder. Check to see that there are no conflicting processes open. Create packages for Adobe Creative Cloud

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 17, 2016 Nov 17, 2016

Copy link to clipboard

Copied

Here's the list it generated:

C:\Program Files (x86)\Common Files\Adobe\OOBE\PDApp\CCP\CreativeCloudPackager.exe

C:\Program Files (x86)\Common Files\Adobe\OOBE\PDApp\UWA\Adobe Application Manager (Updater).exe

C:\Program Files (x86)\Common Files\Adobe\OOBE\PDApp\core\PDapp.exe

C:\Program Files (x86)\Common Files\Adobe\OOBE\PDApp\UWA\AAM Updates Notifier.exe

None of these EXE's are running on any of the test/dev machines.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 18, 2016 Nov 18, 2016

Copy link to clipboard

Copied

Does the issue only happen via SCCM? Does it occur if the files are copied locally?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 18, 2016 Nov 18, 2016

Copy link to clipboard

Copied

The issue occurs if the media is on the local disk or remotely on unc share. Tbh - I haven't gotten as far as testing in sccm in production - I'd kinda like to get my upgrade script tested/working first.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 18, 2016 Nov 18, 2016

Copy link to clipboard

Copied

I apologize - I did a bunch more testing just now and found that the package only fails when running from a unc path.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 03, 2019 Dec 03, 2019

Copy link to clipboard

Copied

LATEST

This has been driving me up the wall lately and I finally nailed down exactly where the problem is.  I don't really understand WHY it is a problem, but I do now it fixes things.

 

Background:

I tried to deploy the CC app via my software distribution tool (Quest Kace KBox) and had mixed results - sometimes it installed, sometimes not.  I never got it to work on a machine that never had CC before.  The really odd part was that I could take the exact same zip the KBox uses, manually extract it and it would work.  It turned out the only difference was that the folders extracted by the KBox had the archive attribute, but manually extracting with Bandizip did not set that attribute.

 

Solution:

After a lot of testing, I nailed it down to the Archive attribute on the build\ASU folder.  Either uncheck that in the folder properties (apply to just that folder) or use the "attrib -a" command on that folder in a script.  After I did that, it installed perfectly.

 

I can only assume that it is parsing the text output of some command and having the attribute set it screwing that up.  It should not have any impact on the actual running of the software, but there you have it...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines