• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Installation cause black desktop

Community Beginner ,
Apr 03, 2017 Apr 03, 2017

Copy link to clipboard

Copied

When I start installing "Adobe CC 2017 devices" my desktop goes black.

I made the package with "Creative Cloud Packager" (v 1.11.0 Build 34). However, when I start the test-installation makes my desktop go black. Guess it is explorer.exe that has shutdown.

Installation continues but cant do anything while installing.

Why???

TOPICS
Deploy and package apps

Views

6.2K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Apr 04, 2017 Apr 04, 2017

Yes Knut additional functionality can not be added to Explorer without it being briefly suspended.  I would recommend contacting Microsoft if you would like to see this limitation adjusted in the Windows operating system.

For deployment purposes I would recommend scheduling the deployment for a period of time when the computer will not be in use.

Likes

Translate

Translate
Community Expert ,
Apr 03, 2017 Apr 03, 2017

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 03, 2017 Apr 03, 2017

Copy link to clipboard

Copied

Knuta Fagmed.uit.no this is normal behavior as additional features are added to Explorer during the installation of the Creative Cloud desktop app.  This is a component which is included with your installation package.  Explorer should relaunch itself automatically.

Did you receive a specific error?  Are you applications now functioning successfully?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 03, 2017 Apr 03, 2017

Copy link to clipboard

Copied

When using SCCM to deploy this software we dont want explorer.exe to close, because users are working with other software.

When I testet installing (explorer.exe closed) everything went black and I had to do a ctrl-alt-del and sign off after "Adobe CC 2017 devices" installed successfully.

If this is a normal behaviour we wont make this software available to our users.

Knut

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 04, 2017 Apr 04, 2017

Copy link to clipboard

Copied

Yes Knut additional functionality can not be added to Explorer without it being briefly suspended.  I would recommend contacting Microsoft if you would like to see this limitation adjusted in the Windows operating system.

For deployment purposes I would recommend scheduling the deployment for a period of time when the computer will not be in use.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Apr 10, 2017 Apr 10, 2017

Copy link to clipboard

Copied

"Contact Microsoft"?? This is something ADOBE should fix, not Microsoft. Never mess with explorer.exe during an install. Users dont like it.

This is bad supporting from Adobe...

Knut

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 10, 2017 Apr 10, 2017

Copy link to clipboard

Copied

Thank you for the feedback Knut.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 03, 2018 Jul 03, 2018

Copy link to clipboard

Copied

This is really sad and pathetic (first time I have ever seen an app designed like this). Any app that needs to add something to the context menus usually just requires a reboot instead of trying to stop explorer.exe. With that said it seems that if you use the creative cloud packager and INCLUDE creative cloud desktop app AND if you add /norestart to the msi command then the black screen only happens for about 5 seconds at the end instead of the whole time. The sad part is with volume serialized licenses adobe does not even recommend the creative cloud desktop app to be installed because a user could install an app which would change the license to user based unless you make it so the user cannot use the apps section during the packager part.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Aug 08, 2018 Aug 08, 2018

Copy link to clipboard

Copied

Yes Knut additional functionality can not be added to Explorer without it being briefly suspended.  I would recommend contacting Microsoft if you would like to see this limitation adjusted in the Windows operating system.

Are you kidding us ? A code module that is currently running cannot be replaced without being unloaded. However, there are mechanisms in Windows allowing this. So this is not an OS limitation but a limitation of the developers not being aware about what they can do with the Windows API.

Anyway, I guess that most users would merely accept a reboot instead of being constantly bothered by an unstable and buggy installation package that is obviously able to damage their system.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 26, 2018 Jul 26, 2018

Copy link to clipboard

Copied

Has this been fixed. I been trying to fix the installation black screen issue when trying you install Adobe CC 2018 for over a week now. Has anyone come up with a workaround????, because we use SCCM to deliver Adobe Creative Cloud. I use Adobe cloud packager, and create a package with the following applications

Adobe XD CC

Adobe Prelude CC 2018

Adobe Premiere Pro CC 2018

Adobe Photoshop CC 2018

Adobe Lightroom Classic CC

Adobe Bridge CC 2018

Adobe Illustrator CC 2018

Adobe InDesign CC 2018

Adobe Animate CC 2018

Adobe Dreamweaver CC 2018

Adobe Character Animator CC 2018

Adobe Media Encoder CC 2018

Adobe InCopy CC 2018

Adobe After Effects CC 2018

Adobe Extension Manager CC

Adobe Fireworks CS6

Adobe Extension Manager CS6

Adobe Flash Builder 4.7 (64 Bit)

Adobe ExtendScript Toolkit CC

Running setup.exe absolutely kills the desktop and 9 times out of 10 the installation fails, and explorer.exe never relaunches, so all the stations are stuck at a black screen with no desktop. In our organization we our running Windows 10 Enterprise 1803

Why is this happening????. is there a solution?. Come on Adobe.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 06, 2018 Aug 06, 2018

Copy link to clipboard

Copied

Agreed.  By far the most poorly designed install packages ever created.  Always crashes and then rolls back the installation without any prompts.  So after waiting an hour for the POS to install, you have to wait another hour as it removes any software it successfully installed.  What a joke.  It would be nice to see more than "Please wait.  Your Creative Cloud products are installing."  How about a status update, progress bar, or perhaps something like, "Please wait, we have your money and no longer care..."  would be more appropriate.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 14, 2018 Sep 14, 2018

Copy link to clipboard

Copied

I have to set it to run install while no user is logged on. So unfortunately users might not have the Adobe apps until they come in the next morning. So I don't offer it in the Software center and everyone has to request it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Aug 08, 2018 Aug 08, 2018

Copy link to clipboard

Copied

Hi,

While investigating the CC Desktop installer unending problems described here​, I discovered this issue by looking at the installation logs. As a former developer and software engineer, I have never seen an installer program daring to voluntarily kill the explorer.exe process without asking the user and without considering the possible side effects of such a questionable practice. This is just unacceptable.

If a DLL that must be replaced is currently in use, there are two possibilities to handle this situation :

1. Register a system reboot.

2. Use the system provided DLL unloading and loading mechanisms in order to make the replacement transparent. This requires some clever coding but this is possible.

Brutally killing the explorer.exe process might have negative side effects (especially on tasks currently running in Explorer) and, IMHO, is explaining why, with certain configurations, the rest of the installation often fails. Depending on which add-ons are currently running in Explorer, the consequences of killing the explorer.exe process can be severe.

Such a bad programming practice just has to be stopped. Period.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 08, 2018 Aug 08, 2018

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 12, 2019 Mar 12, 2019

Copy link to clipboard

Copied

I have no issue with Explorer being shut down as much as it not restarting automatically at the end of the install.  Surely there is a way to force Explorer to restart consistently.  I currently need to CTRL+ALT+DEL and launch Explorer manually at the end fo the install.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 08, 2019 May 08, 2019

Copy link to clipboard

Copied

OS: Windows 10

Adobe Creative Cloud 4.8.1.435

With Process Monitor I captured the command that close explorer.exe. It happens when the setup.exe tries to install CoreSyncCustomHook with the command:

"C:\Program Files (x86)\Common Files\Adobe\CoreSyncExtension\customhook\CoreSyncCustomHook.exe" "--install=C:\Program Files (x86)\Common Files\Adobe" --component=CoreSyncExtension --mode=install

If you try to execute that command you will see the exact behavior that happens during the installation!

Unfortunately I think it's "hard coded" inside the setup process so you can't modify it....

Please check your:

"C:\Program Files (x86)\Common Files\Adobe\Installers\CoreSyncInstall.log"

[09.05.2019 09:40:04]: Info: customhook: Invoked with args: '--install=C:\Program Files (x86)\Common Files\Adobe --component=CoreSyncExtension --mode=install' (coresynccustomhook.cpp.main.710)

[09.05.2019 09:40:04]: Info: customhook: Component given: CoreSyncExtension (coresynccustomhook.cpp.main.724)

[09.05.2019 09:40:04]: Info: customhook: Value of Privilege0 (privilegeelevation.cpp.SetPrivilege.86)

[09.05.2019 09:40:04]: Info: customhook: Privilege does not exist elevating (privilegeelevation.cpp.SetPrivilege.92)

[09.05.2019 09:40:04]: Info: customhook: Successfully elevated process privilege (privilegeelevation.cpp.elevateProcessPrivilege.159)

[09.05.2019 09:40:04]: Info: customhook: Path exists! (coresynccustomhook.cpp.main.744)

[09.05.2019 09:40:04]: Info: customhook: Installing extension (coresynccustomhook.cpp.install.491)

[09.05.2019 09:40:04]: Info: registry.entries: Non essential registry entry setting: succeeded! (registryentries.cpp.RegistryEntries::SetCurrentUserEntries.335)

[09.05.2019 09:40:04]: Info: customhook: Running as admin (coresynccustomhook.cpp.install.502)

[09.05.2019 09:40:04]: Info: customhook: Attempting explorer restart as current user (coresynccustomhook.cpp.install.503)

[09.05.2019 09:40:04]: Info: explorer.killer: Process Name: Esplora risorse (explorerkiller.cpp.rmGetList.335)

[09.05.2019 09:40:04]: Info: explorer.killer: Process ID: 3148 (explorerkiller.cpp.rmGetList.336)

[09.05.2019 09:40:04]: Info: explorer.killer: Process Restartable?: 1 (explorerkiller.cpp.rmGetList.337)

[09.05.2019 09:40:04]: Info: explorer.killer: Process Status Unknown?: 1 (explorerkiller.cpp.rmGetList.341)

[09.05.2019 09:40:04]: Info: explorer.killer: Process Running?: 1 (explorerkiller.cpp.rmGetList.342)

[09.05.2019 09:40:04]: Info: explorer.killer: Process Stopped?: 0 (explorerkiller.cpp.rmGetList.343)

[09.05.2019 09:40:04]: Info: explorer.killer: Process Stopped Other?: 0 (explorerkiller.cpp.rmGetList.344)

[09.05.2019 09:40:04]: Info: explorer.killer: Process Restarted?: 0 (explorerkiller.cpp.rmGetList.345)

[09.05.2019 09:40:04]: Info: explorer.killer: Process Error On Stop?: 0 (explorerkiller.cpp.rmGetList.346)

[09.05.2019 09:40:04]: Info: explorer.killer: Process Error On Restart?: 0 (explorerkiller.cpp.rmGetList.347)

[09.05.2019 09:40:04]: Info: explorer.killer: Process Shutdown Masked?: 0 (explorerkiller.cpp.rmGetList.348)

[09.05.2019 09:40:04]: Info: explorer.killer: Process Restart Masked?: 0 (explorerkiller.cpp.rmGetList.349)

[09.05.2019 09:40:16]: Info: explorer.killer: INFO: Restarted explorer processes in RestartManager session. (explorerkiller.cpp.rmRestartResources.385)

[09.05.2019 09:40:16]: Info: explorer.killer: Initial Explorer restart SUCCESSFUL. Cleanup is SUCCESSFUL (explorerkiller.cpp.restartExplorer.210)

...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 13, 2019 May 13, 2019

Copy link to clipboard

Copied

Hello Everyone,

We are sorry for the inconvenience.

We have reported this to the engineering and they are working on it. They are working on updating the CoreSyncExtension with the fix to this issue. Hopefully this will be fixed soon. I will update the thread as soon as I will have more information on this.

Thanks,

Nikhil Gupta

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 18, 2019 Jun 18, 2019

Copy link to clipboard

Copied

Any update on this?

I was able to get our deployment going using the Package option, but we'd prefer to use Applications.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 08, 2019 Jul 08, 2019

Copy link to clipboard

Copied

FYI, I had an install from March with this issue. Just rebuilt from the Adobe admin console and comparing the files there were changes to CoreSync...and the install no longer kills explorer. The install worked great running manually as an admin, and via SCCM via the system account.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 15, 2019 Jul 15, 2019

Copy link to clipboard

Copied

What apps did you test? I tried packaging photoshop 20.0.5 and it still killed the desktop for a few seconds but then finally it was able to bring it back (using sccm system account while logged in as a user).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 16, 2019 Jul 16, 2019

Copy link to clipboard

Copied

It is still happening periodically with me on just an Acrobat package through SCCM.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 16, 2019 Jul 16, 2019

Copy link to clipboard

Copied

It was only a package for InDesign 2019 v14.0.2

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 05, 2019 Aug 05, 2019

Copy link to clipboard

Copied

I am having this problem deploying Creative Cloud through sccm software center. Have to control alt delete to get explorer back. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 25, 2019 Oct 25, 2019

Copy link to clipboard

Copied

Hello,
The updated Creative could version should be available via Admin console. Could you please try creating a new package and test if that works now.
Thanks,
Nikhil Gupta

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 28, 2019 Oct 28, 2019

Copy link to clipboard

Copied

LATEST

This is now working well for me after creating new packages. Thank you!!! The sad part is that this took this long to be acknowledged and then some time to be fixed as well. Support kept making it look like it is Microsoft's fault when it was Adobe.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines