Adobe Campaign workflow Load File WDB-200001 error

Community Beginner ,
Jun 08, 2021 Jun 08, 2021

Copy link to clipboard

Copied

My latest workflow stopped working after a while with an error (see below) on the Load file step which had previously worked. I’m pretty sure I did not change that process although I did change other ones in the workflow. I tried deleting the Load File step and adding a new one back in. No change to the error message.
Error Message: WDB-200001 SQL statement 'INSERT INTO XtkWorkflowEvent (iEventIdentifier, tsCreation, tsProcessing, sActivity, iStatus, iKeepResult, sTransition, iWorkflowId, iWorkflowEventId) VALUES ($1, $2, $3, $4, $5, $6, $7, $8, $9)' could not be executed. Param(0)=26 Param(1)=2021-06-08 08:43:23.884+01 Param(2)=2021-06-08 08:43:23.884+01 Param(3)=start1 Param(4)=2 Param(5)=0 Param(6)=initial Param(7)=17903625 Param(8)=18089801

It’s not obvious what is going on but I suppose the INSERT SQL is not working because either one of the unique key values / FK constraints already exists or else one of the values is not right. Either way its not something I think I can do anything about directly. I didn't directly create the Parameters as such.

How do I get around this?

 

TOPICS
Troubleshooting

Views

40

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Community Beginner , Jun 09, 2021 Jun 09, 2021
An update this which may help anyone coming across this in future. I spoke to my Adobe help and he indicated that the workflow or part of it had been corrupted. The workaround was to duplicate the workflow and start using the new copy. I did this (and also in the copy deleted the Load File and added a new one) and when I Started that copied workflow it went succesfully past the block and no more WDB-200001 error. Then deleting the old workflow and renaming my copy back to the original name and a...

Likes

Translate

Translate
Community Beginner ,
Jun 09, 2021 Jun 09, 2021

Copy link to clipboard

Copied

LATEST

An update this which may help anyone coming across this in future. I spoke to my Adobe help and he indicated that the workflow or part of it had been corrupted. The workaround was to duplicate the workflow and start using the new copy. I did this (and also in the copy deleted the Load File and added a new one) and when I Started that copied workflow it went succesfully past the block and no more WDB-200001 error. Then deleting the old workflow and renaming my copy back to the original name and all is good.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines