Cant download older versions

New Here ,
Mar 30, 2021 Mar 30, 2021

Copy link to clipboard

Copied

Hello everyone,

 

I need to download Adobe premiere pro and after effects maybe like a 2019 version? I do have MacOS 10.13 but creative cloud is persistent and only gives me the option that I MUST download MacOS 10.14 but that makes my mac so slower and I in the past always downloaded the 2019 version (i guess was that one) but now the option to download older version is gone!! what can I do? 😞 I have a student account so it says that I have to contact my IT department but they're not smart lol .

thanks guys!!

TOPICS
Creative Cloud, Installation

Views

93

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Community Professional , Mar 30, 2021 Mar 30, 2021
Hi @JAVIER IGNACIO5F9E, Adobe assumes all users have the latest OS and software, no more than 2 versions back.  When a major new release comes out, the older version is dropped from CC desktop app.   On Mac you need Mojave or higher.  Next year when Apple releases another OS, it will be Catalina or higher and so on...   Please refer to the updated system requirements below. - https://helpx.adobe.com/creative-cloud/system-requirements.html Also pay attention to new GPU requirements. See links...

Likes

Translate

Translate
Adobe Community Professional ,
Mar 30, 2021 Mar 30, 2021

Copy link to clipboard

Copied

LATEST

Hi @JAVIER IGNACIO5F9E,

Adobe assumes all users have the latest OS and software, no more than 2 versions back.  When a major new release comes out, the older version is dropped from CC desktop app.  

 

On Mac you need Mojave or higher.  Next year when Apple releases another OS, it will be Catalina or higher and so on...   Please refer to the updated system requirements below.

- https://helpx.adobe.com/creative-cloud/system-requirements.html

Also pay attention to new GPU requirements. See links below.
- https://helpx.adobe.com/photoshop/system-requirements.html
- https://helpx.adobe.com/photoshop/kb/photoshop-cc-gpu-card-faq.html

Eventually you will need to upgrade your equipment or buy a Win PC which doesn't require you to get a new OS every year as Apple does.  Your choice.

 

In the meantime, contact your IT dept's plan admin and ask for an older version package.

 

[While I was replying, a moderator moved this question from Download & Install to Enterprise & Teams.]

 

Nancy O'Shea, Adobe Product User & Community Professional
Alt-Web Design & Publishing ~ Web : Print : Graphics : Media

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines