Highlighted

RemoteUpdate Manager fails to install some downloads

Explorer ,
Jan 22, 2020

Copy link to clipboard

Copied

My AUSST server started to fail download/installs about a week ago, it was working great up until then. I've conducted a "fresh" install on my server and as always there are errors, but I ignored them as usual. When I attempt to run remoteupdate from any of my clients, I'm told that some applications are not in need of updates, but the ones that are, failed to download from my AUSST server. I've enclosed both the DLM and the RemoteUpateManager file for review. 

Topics

Enterprise, Troubleshooting

Views

445

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

RemoteUpdate Manager fails to install some downloads

Explorer ,
Jan 22, 2020

Copy link to clipboard

Copied

My AUSST server started to fail download/installs about a week ago, it was working great up until then. I've conducted a "fresh" install on my server and as always there are errors, but I ignored them as usual. When I attempt to run remoteupdate from any of my clients, I'm told that some applications are not in need of updates, but the ones that are, failed to download from my AUSST server. I've enclosed both the DLM and the RemoteUpateManager file for review. 

Topics

Enterprise, Troubleshooting

Views

446

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Employee ,
Jan 23, 2020

Copy link to clipboard

Copied

Hi,

I reviewed the logs and it seems that there is a network error wherein the local machine is not able to access the folders which are on your server. It can happen if there are any changes in folder locations or override files. Kindly check the settings again to confirm.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Jan 27, 2020

Copy link to clipboard

Copied

I've reviewed my settings and they are as they were when I first setup the Ausst Server. I can access the updates location via the URL on any of my PCs with no errors. As stated earlier, everything was working up until a week ago and now only Acrobat will update and all others fail to download. Unlike the original posting, I cannot upload my PDApp, or my new RemoteUpdateManager files from this morning attempt after I completed the latest Ausst update downloads. Any other suggestion would be helpful. I even reimaged (physical) my PC with updated OS load, installed the same AdobeCC suite, copied the original overrides files to the proper location, verified that I could access all the folders/files on Ausst server and attempted to run remoteupdate application and got the same results. I've attempted to uploade the current PDApp, and remoteupdatemanager file, but for some reason I cannot on this thread.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Jan 28, 2020

Copy link to clipboard

Copied

Kindly check and confirm if you are able to access those folders/files which are on AUSST server on the client machine. There is a connectivity issue wherein the client machine is not able to connect to the folder/files on the server.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Jan 29, 2020

Copy link to clipboard

Copied

@Techburner,

 

I am able to access all folders on the AUSST server from any local PC on the network. I can access via the web interface using either the IP addr, or FQDN. Is there a specific file/folder that the logs are indicating I cannot access? I've tried to decyper the logs, but they are so cryptic! I even rebuilt my overrides file an still got the same results. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Jan 29, 2020

Copy link to clipboard

Copied

I reviewed both the logs and found below error:

 

Remote Update manager logs:

01/22/20 11:32:43:630 | [INFO] | | AAMEE | Utilities | RemoteUpdateManager | | HDPIM | 15160 | Exiting hdpimDownloadProduct with status '0'
01/22/20 11:32:44:829 | [FATAL] | | AAMEE | Utilities | RemoteUpdateManager | | HDPIM | 15220 | Fatal Error '125' occurred while download
01/22/20 11:32:44:830 | [FATAL] | | AAMEE | Utilities | RemoteUpdateManager | | HDPIM | 15220 | Error occurred in download workflow with error code 125 error message {http://myServer//ACC/services/ffc/packages//LTRM/9.1/win64/Application.json?name=LTRM&version=9.1&platform=win64&build=9.1.0.201911291132,P:-4,PS:404,G:-4}
01/22/20 11:32:45:267 | [ERROR] | | AAMEE | Utilities | RemoteUpdateManager | | | 15160 | Failed to download HD media (LTRM, 9.1), library returned error (125)...
01/22/20 11:32:45:267 | [INFO] | | AAMEE | Utilities | RemoteUpdateManager | | HDPIM | 15160 | Inside hdpimControlProgress for request type '2' with driverXML <DriverInfo><RequestInfo/></DriverInfo>

 

 

Checked DLM logs:

01/22/20 11:14:44:422 | [INFO] | | | | | | ProcessUtils | 5040 | In revertThreadContextToProcessContext. Success in RevertToSelf.
01/22/20 11:14:44:422 | [INFO] | | | | | | | 5040 | The file to be downloaded is http://sfevwut09u//ACC/services/ffc/packages//LTRM/9.1/win64/Application.json?name=LTRM&version=9.1&platform=win64&build=9.1.0.201911291132
01/22/20 11:14:44:422 | [INFO] | | | | | | | 5040 | Going to download the file at C:\Users\quentin.a.sligh.adm\AppData\Local\Adobe\RemoteUpdateManager_Downloads\LTRM_9.1.0.201911291132_win64/Application.json
01/22/20 11:14:44:534 | [INFO] | | | | | | | 5040 | Preference: Preference is set for adding compression header
01/22/20 11:14:44:534 | [INFO] | | | | | | | 5040 | Preference: Client has set the preference for single stream download
01/22/20 11:14:44:668 | [INFO] | | | | | | ProcessUtils | 8832 | In changeThreadContextToExplorerContext.explorer process ID: 1892.
01/22/20 11:14:44:669 | [INFO] | | | | | | ProcessUtils | 8832 | In changeThreadContextToExplorerContext. Success in changingContext.
01/22/20 11:14:44:676 | [INFO] | | | | | | ProcessUtils | 8832 | In revertThreadContextToProcessContext. Success in RevertToSelf.
01/22/20 11:14:44:676 | [ERROR] | | | | | | | 8832 | The error has come and the http error code is - 404
01/22/20 11:14:44:677 | [ERROR] | | | | | | | 8832 | Failed to send the request to server to get the response - 404
01/22/20 11:14:44:677 | [ERROR] | | | | | | | 8832 | the download job (0) failed to execute. The job state is STOPPED_STATE
01/22/20 11:14:44:677 | [ERROR] | | | | | | | 8832 | the download job (0) failed to execute. The job state is ERROR_STATE
01/22/20 11:14:44:677 | [INFO] | | | | | | | 8832 | WorkerThread::ThreadProc Current job is in Error State which is not recoverable
01/22/20 11:14:46:590 | [INFO] | | | | | | | 10860 | *******************End****************

 

 

As per the RUM logs, it is giving error 125 which comes when there is connectivity issue and the DLM logs show the path/location which is inaccessible and giving network error 404.

 

I am not sure why it is not working after updating the override file. I need to check the logs again.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Jan 31, 2020

Copy link to clipboard

Copied

Ok,

Now that I've become better educated at reading Adobe's "cryptic" logs, I think I may be seeing the issue. When I look at the DLM.log I noted that location from which the specific download (in general) does not exists. Basically when RUM is attempting to download the updates for example, "http://myserver/ACC/services/ffc/packages/PHSP/21.0.3/win64/Build 21.0.3.91" the "Build 21.0.3.91" is missing from my updates, it is like they never downloaded when I ran the Removeupdateservertool. Which would make sense, if the update is not there, then it would return a 404 error because it cannot fine the file it needs. Does this makes sense? The larger question is why did the server stop updating and how to get it to start downloading updates again. When I run the update tool now I get updating 322, and it goes through its process and in the end, it states 322 errors. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Feb 01, 2020

Copy link to clipboard

Copied

The error 322 is again related to the network connectivity issue. Somewhere the connection might be broken. I think you have to check the whole setup again with the path you have defined.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Feb 03, 2020

Copy link to clipboard

Copied

I'm sorry, I may have misphrased the "322 errors." What I meant was that when I run the remote update manager, it indicates that I have 322 files available and once it completes, it indicates that I had 322 errors. How can I upload additional files? There does not seem to be an option for doing so.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...