In InDesign CC 2018, cep extension is not getting displayed in windows menu option, after updating CEP version to 8.0 in manifest file.

New Here ,
Feb 26, 2019 Feb 26, 2019

Copy link to clipboard

Copied

Hello,

We are having a extension which is working fine in InDesign CC 2017, now we are trying to use the same with InDesing CC 2018 with supported CEP version 8.0. For that we have updated our manifest file entry as:

<ExecutionEnvironment>

        <HostList>

            <Host Name="IDSN" Version=["13.1", "13.9"]/>

        </HostList>

        <LocaleList>

            <Locale Code="All"/>

        </LocaleList>

        <RequiredRuntimeList>

            <RequiredRuntime Name="CSXS" Version="8.0"/>

        </RequiredRuntimeList>

    </ExecutionEnvironment>

But we are unable to see the extension in InDesign's option "Window > Extensions menu".

Also, If we will keep the CEP version to 7.0 then it seems to work.

TOPICS
Exchange

Views

595

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 26, 2019 Feb 26, 2019

Copy link to clipboard

Copied

Seems you have not set the debug mode for CEP 8.0. Have a look at the following link to know how its done

CEP-Resources/CEP 8.0 HTML Extension Cookbook.md at master · Adobe-CEP/CEP-Resources · GitHub

You will have to do this for every version of CEP that you intend to use in your extensions.

-Manan

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 26, 2019 Feb 26, 2019

Copy link to clipboard

Copied

Hello Manan Joshi,

I have configured the debug mode for CEP 8.0 according to cookbook and still facing the same problem.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 26, 2019 Feb 26, 2019

Copy link to clipboard

Copied

I am not sure what is happening then, are you able to load any debug extensions in your installation of CC2018 using CEP 8, or the issue is with only with this extension?

I am moving this discussion to the extensions forum where these issues are generally discussed

-Manan

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 26, 2019 Feb 26, 2019

Copy link to clipboard

Copied

Have a look at the following post, it discusses an issue that resembles yours

https://www.davidebarranca.com/2017/10/html-panel-tips-25-cc-2018-survival-guide/

-Manan

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 28, 2019 Feb 28, 2019

Copy link to clipboard

Copied

LATEST

Hello Manan,

I don't think the issue is with this extension only because I have tried using sample extensions provided with CEP-8 and those are also not working, if I update the CEP version in manifest file to 8.0.

Thanks,

Sumit

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines