Highlighted

Quick reference of CSSDK and CEP supported application version

Adobe Community Professional ,
Sep 27, 2017

Copy link to clipboard

Copied

Here is a list of app versions, You can reference when you edit Host Version in your manifest.xml file.

CSXS 2.0…Creative Suite 5(Flash)

  • Illustrator 15.0
  • Photoshop 12.0
  • InDesign 7.0
  • InCopy 7.0
  • Bridge 4.0
  • Dreamweaver 11.0
  • Fireworks 11.0
  • Flash 11.0
  • PremierPro 5.0

CSXS 2.5…Creative Suite 5.5(Flash)

  • Illustrator 15.1
  • Photoshop 12.1
  • InDesign 7.5
  • InCopy 7.5
  • Bridge 4.0
  • Dreamweaver 11.5
  • Fireworks 11.5
  • Flash 11.5
  • PremierPro 5.5

CSXS 3.0…Creative Suite 6(Flash)

  • Illustrator 16.0
  • Photoshop 13.0
  • InDesign 8.0
  • InCopy 8.0
  • Bridge 5.0
  • Dreamweaver 12.0
  • Fireworks 12.0
  • Flash 12.0
  • PremierPro 6.0
  • Prelude 1.0

CSXS 4.0…Creative Cloud(2013Release)(HTML/CEP)

  • Illustrator 17.0
  • Photoshop 14.0
  • InDesign 9.0
  • InCopy 9.0
  • Dreamweaver 13.0
  • Flash 13.0
  • PremierPro 7.0
  • Prelude 2.0

CSXS 5.0…Creative Cloud 2014(HTML/CEP)

  • Illustrator 18.0
  • Photoshop 15.0(FlashRuntime removed)
  • InDesign 10.0
  • InCopy 10.0
  • Dreamweaver 15.0
  • Flash 14.0
  • PremierPro 8.0
  • Prelude 3.0
  • Aftereffects 13.0
  • Audition 7.0

CSXS 6.0…Creative Cloud2015(HTML/CEP)

  • Illustrator 19.0
  • Photoshop 16.0
  • InDesign 11.0
  • InCopy 11.0
  • Dreamweaver 16.0
  • Flash 15.0
  • PremierPro 9.0
  • Prelude 4.0
  • Aftereffects 13.5
  • Audition 8.0

CSXS 7.0…Creative Cloud2015.3 and 2017(HTML/CEP)(FlashRuntime removed)

  • Illustrator 20.0/21.0
  • Photoshop 17.0/18.0
  • InDesign 11.4/12.0
  • InCopy 11.4/12.0
  • Dreamweaver 16.0/17.0
  • Animate 15.2/16.0
  • PremierPro 10.3/11.0
  • Prelude 5.0/6.0
  • Aftereffects 13.8/14.0
  • Audition 9.2/10.0

CSXS 8.0…Creative Cloud2018(HTML/CEP)Welcome back Bridge!

  • Illustrator 22.0
  • Photoshop 19.0
  • InDesign 13.0
  • InCopy 13.0
  • Bridge 8.0
  • Dreamweaver 18.0
  • Animate 18.0
  • PremierPro 12.0
  • Prelude 7.0
  • Aftereffects 15.0
  • Audition 11.0

Now, we can reference official document, You can check below link.

CEP-Resources/CEP 8.0 HTML Extension Cookbook.md at master · Adobe-CEP/CEP-Resources · GitHub

TOPICS
Exchange

Views

952

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Quick reference of CSSDK and CEP supported application version

Adobe Community Professional ,
Sep 27, 2017

Copy link to clipboard

Copied

Here is a list of app versions, You can reference when you edit Host Version in your manifest.xml file.

CSXS 2.0…Creative Suite 5(Flash)

  • Illustrator 15.0
  • Photoshop 12.0
  • InDesign 7.0
  • InCopy 7.0
  • Bridge 4.0
  • Dreamweaver 11.0
  • Fireworks 11.0
  • Flash 11.0
  • PremierPro 5.0

CSXS 2.5…Creative Suite 5.5(Flash)

  • Illustrator 15.1
  • Photoshop 12.1
  • InDesign 7.5
  • InCopy 7.5
  • Bridge 4.0
  • Dreamweaver 11.5
  • Fireworks 11.5
  • Flash 11.5
  • PremierPro 5.5

CSXS 3.0…Creative Suite 6(Flash)

  • Illustrator 16.0
  • Photoshop 13.0
  • InDesign 8.0
  • InCopy 8.0
  • Bridge 5.0
  • Dreamweaver 12.0
  • Fireworks 12.0
  • Flash 12.0
  • PremierPro 6.0
  • Prelude 1.0

CSXS 4.0…Creative Cloud(2013Release)(HTML/CEP)

  • Illustrator 17.0
  • Photoshop 14.0
  • InDesign 9.0
  • InCopy 9.0
  • Dreamweaver 13.0
  • Flash 13.0
  • PremierPro 7.0
  • Prelude 2.0

CSXS 5.0…Creative Cloud 2014(HTML/CEP)

  • Illustrator 18.0
  • Photoshop 15.0(FlashRuntime removed)
  • InDesign 10.0
  • InCopy 10.0
  • Dreamweaver 15.0
  • Flash 14.0
  • PremierPro 8.0
  • Prelude 3.0
  • Aftereffects 13.0
  • Audition 7.0

CSXS 6.0…Creative Cloud2015(HTML/CEP)

  • Illustrator 19.0
  • Photoshop 16.0
  • InDesign 11.0
  • InCopy 11.0
  • Dreamweaver 16.0
  • Flash 15.0
  • PremierPro 9.0
  • Prelude 4.0
  • Aftereffects 13.5
  • Audition 8.0

CSXS 7.0…Creative Cloud2015.3 and 2017(HTML/CEP)(FlashRuntime removed)

  • Illustrator 20.0/21.0
  • Photoshop 17.0/18.0
  • InDesign 11.4/12.0
  • InCopy 11.4/12.0
  • Dreamweaver 16.0/17.0
  • Animate 15.2/16.0
  • PremierPro 10.3/11.0
  • Prelude 5.0/6.0
  • Aftereffects 13.8/14.0
  • Audition 9.2/10.0

CSXS 8.0…Creative Cloud2018(HTML/CEP)Welcome back Bridge!

  • Illustrator 22.0
  • Photoshop 19.0
  • InDesign 13.0
  • InCopy 13.0
  • Bridge 8.0
  • Dreamweaver 18.0
  • Animate 18.0
  • PremierPro 12.0
  • Prelude 7.0
  • Aftereffects 15.0
  • Audition 11.0

Now, we can reference official document, You can check below link.

CEP-Resources/CEP 8.0 HTML Extension Cookbook.md at master · Adobe-CEP/CEP-Resources · GitHub

TOPICS
Exchange

Views

953

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Sep 27, 2017 3
Engaged ,
Sep 29, 2017

Copy link to clipboard

Copied

According to this post: Adobe Bridge CC: Support for HTML 5 Based Plug-ins Coming in 2017 | Creative Cloud blog by Adobe  also Bridge will be in the number.

Also, peeking at CEP8.x manifest.xml in Adobe's GitHub repo here: CEP-Resources/manifest.xml at master · Adobe-CEP/CEP-Resources · GitHub the list is growing.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 29, 2017 0
Ten A LATEST
Adobe Community Professional ,
Oct 01, 2017

Copy link to clipboard

Copied

Thanks David,

now, I had update. However, I don't get some applications version.

Probably, fill it next time.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 01, 2017 0