• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
Locked
0

ActionScript generation - Can it ignore ActionScript keywords in 4.0.1?

New Here ,
Aug 12, 2010 Aug 12, 2010

Copy link to clipboard

Copied

When using Flash Builder eclipse plug-in Version 4.0 (build 272416), we are able to digest the Data/Services of a BlazeDS enabled server.  The ActionScript generator dynamically connects to the BlazeDS server, and then generates the necessary ActionScript.  Another developer happened to download their Flash Builder a few weeks later 4.0.1 (build 277662) and is getting the following error when attepting to digest the Data/Services:

ActionScript generation is not supported for entities containing properties or methods that clash with ActionScript keywords.  Entity "MapLink" contains illegal property "to".

Indeed, the error message is correct; Our MapLink object does have an attribute "to".  However, we have no ability to change this attribute!

So my question is:  Is there a way to configure the ActionScript generator to ignore this rule?  Or is there another work-around for this (other than roll all the developers back to the 4.0 version of Flash Builder)

Views

835

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 26, 2011 Jun 26, 2011

Copy link to clipboard

Copied

I have the same error with defferent phrase :

ERROR [1]: ActionScript generation is not supported for entities containing properties or methods that clash with ActionScript keywords.  Entity "CachedClass" contains illegal property "void".

It happens when i try to digest a groovy entity (domain class) using the BlazeDS. Did any one resolve this issue ?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 26, 2011 Jun 26, 2011

Copy link to clipboard

Copied

LATEST

No, the issue was not resolved.  Since it was a temporary project (short lifespan) we just cloned the 4.0 environment for anyone that happened to get the 4.0.1 load.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines