• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
Locked
0

Debugging: Why are "setter" entries displayed in "Variables" view?

Explorer ,
Mar 15, 2011 Mar 15, 2011

Copy link to clipboard

Copied

I just don't understand why anybody would display setters in the debug variables..

They appear FIRST, taking up the prime spot where other useful stuff could show, and make debugging just extremely annoying.

In my case I have model entities with 30+ properties. Most of them are inherited from a base class.

This means I have to click the "[inherited]" node first, then scroll down a page or two, to finally see the property I am looking for.

Do this for a rather complex object graph and you go nuts.

Views

929

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 23, 2011 Mar 23, 2011

Copy link to clipboard

Copied

(hem hem)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 30, 2011 Mar 30, 2011

Copy link to clipboard

Copied

Any word on this from the component lead? Mr Venkataramana?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Apr 06, 2011 Apr 06, 2011

Copy link to clipboard

Copied

Knock knock

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 11, 2011 May 11, 2011

Copy link to clipboard

Copied

Still an issue in FB 4.5 -- please respond

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 17, 2011 May 17, 2011

Copy link to clipboard

Copied

Hi,

The reason is that as far as the actionscript virtual machine is concerned, a "variable" with that name exists. Its attributes make it a setter and we show the entry in the Variables view. You could assign a value to the setter via the watch expression view.

While you cannot infer the value of a setter or do anything with it, my take on this is that when you expand a variable, the debugger should show *all* the  fields.

That said, an enhancement request for an option to filter away "setter" entries is a very valid request and one that I would personally vote for.

-Anirudh

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 18, 2011 May 18, 2011

Copy link to clipboard

Copied

Hi!

And thanks a lot for answering.

Please look at this bug

https://bugs.adobe.com/jira/browse/FB-26609

Do you think that covers it? Also please note my comment and bug link at bottom of that page. Maybe my original bug should become a enhancement request and be reopened..

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 30, 2011 May 30, 2011

Copy link to clipboard

Copied

La la laa...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 01, 2011 Jun 01, 2011

Copy link to clipboard

Copied

LATEST

I had forwarded the bug to the right people. Should have kept the forum thread updated, sorry about that.

-Anirudh

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines