• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
Locked
0

error 303 with packaging my AIR icon

New Here ,
Jul 19, 2010 Jul 19, 2010

Copy link to clipboard

Copied

Hi guys & gals

this is a very simple task that has been giving me a curious amount of trouble and frustration for being so commonplace, and I would appreciate the help

This is a part of my application-app.xml file

    <icon>
        <image48x48>data/application/icons/MY_ICON.png</image48x48>
    </icon>

When I try to export a release build in flash builder, it gives me error 303 Error creating AIR File, Icon is missing from package

In the 3rd step of exporting, under AIR File Contents (Select the output files to include in the exported AIR file) I do not have any option to select the icon file.. is it supposed to appear here, and if so how? Because it is not even displaying my data folder in this screen, much less let me select a file

I also couldn't find anything under the build path for the project properties to include assets either. Just source files and swcs.

What am I doing wrong here, this is supposed to be a very simple task and so far I have dumped hours into this without avail

Thanks again!

Views

5.1K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 22, 2010 Jul 22, 2010

Copy link to clipboard

Copied

Are you embedding that icon in your application via or @Embed?

If you embed it, the compiler will not copy it to the final output folder (from where it is packaged) due to the compiler setting "Do not copy embedded assets".

Quick fix: Create a copy of the icon in another place (or with a different name).

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Aug 21, 2011 Aug 21, 2011

Copy link to clipboard

Copied

this can help you!

ios app aceepts only 29,48,57,72.

if you using another 32,26 size png file , occures error!

i think android need not 48size icon...

:a:

iPhone application icons
You define the following icons for an iPhone application:
•A 29-by-29–pixel icon—Spotlight search results on the iPhone and iPod touch use this icon.
•A 48-by-48–pixel icon—Spotlight search results on the iPad use this icon.
•A 57-by-57–pixel icon—The iPhone and iPod touch home screens display this icon.
•A 72-by-72–pixel icon (optional)—The iPad home screen displays this icon.
•A 512-by-512–pixel icon—iTunes displays this icon. The 512-pixel PNG file is used only for testing development versions of your application When you submit the final application to the Apple App Store, you submit the 512 image separately, as a JPG file. It is not included in the IPA.
In Flash Professional CS5, add these icons in Icons tab of the the iPhone Settings dialog box. See “Setting iPhone application properties in Flash Professional CS5” on page 14.
You can also add the locations of the icons to the application descriptor file:
<icon>
<image29x29>icons/icon29.png</image29x29>
<image57x57>icons/icon57.png</image57x57>
<image72x72>icons/icon72.png</image72x72>
<image512x512>icons/icon512.png</image512x512>
</icon>
The iPhone adds a glare effect to the icon. You do not need to include it in your source image. To remove this default glare effect, add the following to the InfoAdditions element in the application descriptor file:
<InfoAdditions>
<![CDATA[
<key>UIPrerenderedIcon</key>
<true/>
]]>
</InfoAdditions>

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 24, 2011 Aug 24, 2011

Copy link to clipboard

Copied

I had this same issue until I placed the .png icon files in both the "src" and "bin-debug" directories.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 26, 2011 Aug 26, 2011

Copy link to clipboard

Copied

LATEST

I simply removed src from the path in the xml file,
originally it looked like this:
src/assets/72.png

<image72x72>src/assets/72.png</image72x72>

and simply changed it to:
assets/72.png

<image72x72>assets/72.png</image72x72>

this fix seemed to work fine for me, hope this helps other people!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines