• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
Locked
0

Error Connecting to ColdFusion Data Service

New Here ,
May 14, 2010 May 14, 2010

Copy link to clipboard

Copied

I'm completely new to ColdFusion and Flash Builder (I've done some work with Flex 2 a while back) so forgive me if my terminology is not the best.

I have installed ColdFusion 9 locally and have Flash Builder 4 installed with Coldfusion Builder as a plug-in. Eeverything seems to be up and running correctly. I have several CFC files which I am trying to connect to as a data service however each one is returning the following error...

"The CFC file is invalid. Possible causes can be found by accessing:http//localhost:8500/.../CFIDE/componentutils/cgcexplorer.cfc?method=getCFCMetaData&name=cfcfile&path=/..."

One of the CFC files I copied direct from here just as a test http://help.adobe.com/en_US/Flex/4.0/FlexTutorials/WSbde04e3d3e6474c44e9f0a921210cbd7a14-8000.html

So I am assuming it's not an issue with the CFC file but a possible serve configuration error?

Any help would be much appreciated,

Mike.

Views

759

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Jun 01, 2010 Jun 01, 2010

Copy link to clipboard

Copied

Hi,

did u try pasting the URL in the browser. could u tell me what result you got.

Nishad

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 01, 2010 Jun 01, 2010

Copy link to clipboard

Copied

I deleted the project and started again and it worked fine. Must have gotten corupt somewhere along the line.

Cheers anyway.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 09, 2011 Mar 09, 2011

Copy link to clipboard

Copied

I have the same error but I know why I'm getting it:

If I create a project in the webroot: http://localhost (where /CFIDE resides) it create the data service as expected

However, when I create it in a different folder: http://localhost/test it throws an error:

The CFC file is invalid. Possible causes can be found by  accessing:

http://localhost/test/CFIDE/componentutils/cfcexplorer.cfc?method=getCFCMetaData&name=users&path=%2Fcfc%2Fusers.cfc

Where can I edit this behavior? so it will always look for CFIDE in the root?

In my Coldfusion Admin it is set to /CFIDE

I would think this is a Flash Builder issue.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 09, 2011 Mar 09, 2011

Copy link to clipboard

Copied

LATEST

Ok I figured out the problem.

When creating a new project in flash builder, the first screen dictates where I'm putting my files:

E:\sites\test

on the 2nd screen (Configure Coldfusion Server) I had previously made the Web Root and Root URL

E:\sites\test

http://localhost/test

when they should have been:

E:\sites

http://localhost

Now when I create a data service... it all works in harmony.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines