• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
Locked
0

Export Release Build - Problem with Server Settings

New Here ,
May 26, 2011 May 26, 2011

Copy link to clipboard

Copied

Hello, i have a big problem and i searched the whole day yesterday but didnt found an answer...

I started a Flex Mobile and PHP Project. The Project has a Data/Services included wich loads some customer from a database (sql)... for the first a

used Zend and try it local (http://localhost and used the htdocs Folder of Zend)... EVERYTHING WORKS PRETTY FINE... so NOW my problem

I wanted to export this project to a release build for my android phone... so the first warning of Flash Builder ist that the project ist currently configured to access data services from a local url. Before exporting the application, you may need to deploy your services to a remote server, then change the server root URL for your project. Click here to change server settings.

When i click the button i get the server setting.

Web root: C:\Program Files (x86)\Zend\Apache2\htdocs

Root URL: http://localhost

whe i change it now i get an eror:"The selected web root folder does not exist (i attached i screenshot of it).

i entered de domain of my server (i also tried the ip) at Root URL. And i think there ist a problem with the Web root...? i get scary

screen.jpg

TOPICS
PHP

Views

797

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
May 27, 2011 May 27, 2011

Copy link to clipboard

Copied

The server URL mentioned as root URL gets embedded into your application while exporting. When you use localhost in your URL you have the PHP server running on the same machine as the the FlashBuilder. So everything works as expected. However when you deploy your application on a device "localhost" refersr to the device itself instead of the machine where PHP server is running. This is the reason why FlashBuilder warns you while exporting your application to use the actual server URL. In the screen shot you have posted you probably have the incorrect WebRoot which does not exist on your machine as FlashBuilder allows you to proceed even when the Root URL is inaccessible. Please try inputting the correct WebRoot and Root URL.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 27, 2011 May 27, 2011

Copy link to clipboard

Copied

LATEST

i know WHY Flashbuilder tells me that i have to change the setting when i deploy on the device

my problem ist that i got this error...

and the domain wich i have in the screenshot should only explain how i tried it...

i entered my server url (the real domain) and i entered the folder "app" wich i have created via ftp on my server...

BUT i also get this error (lik in the screenshot)

i think at ROOT URL i cant make lot mistakes .... http://myserver.de or the ip

but i think maybe my web root ist incorrect? i entered here the folder wich is directliy on my server...?

i dont know exactly but i got an error like in the screen

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines