• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
Locked
0

FlashBuilder 4.7 wont publish to Samsung Galaxy Note 10.1 but will publish to Samsung Galaxy S4

Explorer ,
Feb 22, 2014 Feb 22, 2014

Copy link to clipboard

Copied

OS: WIndows 7 x64

Hardware: ATI Radion 65xxx series HD, 12GB DDR3, Galaxy Note 10.1 & Galaxy S4

Android 4.1.2 is on the Tablet and 4.2.2 is on the mobile.

Software: Adobe CC (Full) - FlashBuilder 4.7 - AIR for android on both devices 4.x installed

Flashbuilder modification 1: APACHE FLEX Latest downloaded and installed into SDK directory

Flashbuilder modification 2: AIR 4.0 SDK downloaded and installed into eclipse plugins flash compiler directory

Dev test 1: (success)

Built test application to test some Away3D 4.x programming and interaction on AIR.

Result: Flash Player opened SWF and all appeard fine.

Dev test 2: (success)

Created new project - Flash Mobile - merged dev test 1 code into project and compiled on Galaxy S4

Result: FlashBuilder recognised device, installed apk and ran it just fine (AIR 4.x is already installed on device)

Dev test 2b: (failure)

Still using project dev test 2, I unplugged the Galaxy S4 and pluggined in the Galaxy Note 10.1. Pressed debug.

Result: Flashbuilder didn't get any further than displaying the message "Launching: Determining the device on which to install the application..."

Dev test 2c: (failure)

Closed FlashBuilder, unplugged device, CTRL + ALT + DEL then end tasked all ADB processes. Re-opened FlashBuilder, plugged Tablet back in and pressed debug again.

Result: Sat on "Launching: Installing application on device" heard windows noise for unplugged usb device sound?!!??  Waited.. and waited and eventually got the message "Launching 'Away3DIsometricBlockBuilder' has encountered a problem. Error occurred while installing the application: rm failed for /data/local/tmp/Away3DIsometricBlockBuilder.apk, No such file or directory

protocol failure

- waiting for device -"

http://www.allforthecode.co.uk/fun/error_01.jpg

Dev test 2d: (success)

Unplugged device, end tasked all ADB.exe instances and plugged in galaxy s4 and pressed debug.
Result: Success!



Dev test 2e: (failure)
Unplugged all devices, end tasked all ADB.exe instances and shut down flashbuilder. Opened a command prompt window and adb version = 1.0.31. Downloaded Goolge Android SDK x64 and removed existing android installation folder I had already and extracted files there. Opened SDK Manager and installed the latest Android 4.4 SDK  and some other tools etc. Now I went looking for where adb exists. Found the ones relevant to FlashBuilder 4.7 and checked which version they were. SDK used version was 1.0.31 and the AIR eclipse plugins ADB version was also 1.0.31. Checked fresh installed adb version from Google Android SDK and it was also v 1.0.31. Tried a manual install on the device of the apk. Re-opened FlashBuilder re-connected device (tablet) and pressed debug.
Result: Got to Launching 57%, windows made usb disconnection sound and it got no further and popped up the error window which was detailed in "Dev test 2c" above. Device shows connected windows explorer no longer shows device.

Dev test 2f: (failure)

Unplugged device, end tasked all adb.exe instances. Plugged device back in.
Check 1: Windows shows android device plugged in GT-N80810
Check 2: Opened admin rights dos window and typed in adp devices - found 1 at some address
Check 3: adb version = 1.0.31

Check 4: apk file exists

Execute manual install: adp install -r package_name.apk

Result:

-- in dos window --

protocol failure

- waiting for device -

rm failed for /data/local/tmp/apkname.apk, No such file or directory

Dev test 3: (failure)

Created a new flashbuilder 4.7 ActionScript Mobile AIR Project

Name: TabletTest01

Permissions: Internet, Write external storage, wake lock, access network

Auto reorient: yes

Full screen: yes

Added code: trace("hello world");

Pressed debug

Set launch method: on device

Build target = device

Click apply then debug

Result: Same as error shows in 2c


Dev test 3b: (success)

Rebooted pc, rebooted device plugged back in after flashbuilder was running and pressed debug.

Result: sucess traced out "hello world" to console!

Dev test 3c: (failure)

Added code: trace("YYYYYYYYYYYYYYYYYYEEEEEEEEESSSSS!");

Pressed debug.

Result: FAILURE! Same as error shows in 2c

Adobe or anyone know how to fix this issue? or even what is going on?!

I'm tempted to flash the Galaxy Note with Android 4.2.2 or 4.4 google stock rom, to see if it fixes any problems...
However it wouldn't be a true Galaxy Note 10.1 test device anymore, which was the point in buying the thing.

The only things which stand out in all this to me are:


1. The tablet disconnects mid way through the debug publish process, but sometimes the galaxy s4 does also but it doesn't stop it from working?! Timing issue with compiler and data transfer timings? Missing apk file in data temp directory?


2. Android 4.1.2 is on the Tablet and 4.2.2 is on the mobile, could it be an issue with the AIR SDK not correctly handling 4.1.2 where as it is fine with 4.2.2?

Maybe I should have gone the way of the virtual machine... 😕

My next tests will be to root the device (odin) and see if I can copy over APK files for installation via the file browser on the device as at the moment APK file transfer is blocked (I don't have the apk copying issue on a non-rooted galaxy s4 however).

Anyone got anything?

D

PS. Adobe - Image upload doesn't work on this forum editor (chrome).

Views

1.9K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 24, 2014 Feb 24, 2014

Copy link to clipboard

Copied

Bump..

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 26, 2014 Feb 26, 2014

Copy link to clipboard

Copied

LATEST

Result:

FlashBuilder appears to have a problem with Android version 4.2.2.

Discovery / Assumption reasoning

Tested same application in FlashBuilder to publish to Android 4.0.x, Android 4.1 and to Android 4.4 all result in success on both virtual machine, tablet and mobile devices.

Advice for Tablet users using Android 4.1.x with same problem:

1. Google search "install android 4.4 on entery your device name here"

2. Follow instructions which usually comprises of

2.1. Download bootloader recovery software and flash with odin 1.85

2.2. Download rom

2.3. Download pa_gapps_modular full

2.4. Download Super User

2.5. Copy files 2.2 and 2.3 to your internal memory on device or to external SD card

2.6. Reboot into backup & recovery tool

2.7. Backup everything

2.8. Install rom via zip selection

2.9. Install gapps (google apps) via zip selection

2.10. Install update (root) via zip selection

2.11. Reboot and enjoy Android 4.4 on your Tab 10.1

If you insist on using 4.2.2 then your going to have to either start publishing to the app store and installing and re-installing from there to test or try installing the apk via a memory card reader on the external sd card and installing it via file browser and select on the device.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines