• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
Locked
0

>500 lines in <fx:Script> and it all stops working.

New Here ,
May 10, 2011 May 10, 2011

Copy link to clipboard

Copied

Well, it's a little ridiculous; and probably unbelievable, but when I have more than five hundred lines of actionscript in <fx:Script> tags in my MXML FLEX Main.mxml, all syntax highlighting, error and syntax verification, error reporting, "Problems" pane, and even sometimes compilation fail.  Upon removing any chunk of code, it works again.

I don't see why Adobe could release a product such as Flash Builder 4.5 Premium, have this big of a problem; and nobody notice.  Therefore I believe the problem has to do with my computer, or my project; as there's now ay more people have had this happen if I can't even find it on Google.

Additionally, many objects that have been defined in the MXML properties above the code, even those in All States, are now showing as warning: Access of undefined property down the side of my document.  However, these warnings are not showing up in the "Problems pane", and aren't even yellow squigly underlining the right sections of code to pertain to the message.

**Steps I have taken to TRY and fix this:**
I have tried restarting, as well as re-installing the IDE (Adobe Flash Builder 4.5).
I have tried creating a new project.
I have tried splitting my code into smaller .as files and including them.
I have tried compiling my application.

Nothing has worked, PLEASE HELP.

Views

611

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 17, 2011 May 17, 2011

Copy link to clipboard

Copied

Hi,

There must be some particular actionscript syntax in your code that is confusing Flash Builder. It is highly unlikely that this is based on the number of lines, but must be due to some particular actionscript block. For example, do you use a lot of E4X?

If you can send us your MXML file by filing a bug in http://bugs.adobe.com/flex/ (or personally email it to us if you do no want to share your code publicly), we will be able to nail down the problem exactly.

Also, please note that there is an "error reporting" feature (denoted by orange icons) in 4.5 that is separate from the compiler. If your syntax highlighting and intellisense breaks, then error reporting will also break. You can disable error reporting via the preferences pane in the meantime.

Your patience is much appreciated,

----

Anirudh Sasikumar

Computer Scientist, Adobe Systems

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
May 18, 2011 May 18, 2011

Copy link to clipboard

Copied

LATEST

Hi,

You can send us the sample MXML to rbhat@adobe.com. As mentioned in the post above, the errors markers shown are not from compiler, but from error reporting feature of Flash Builder.

-Radhakrishna

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines