• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
Locked
0

How do I set Flash Builder word boundaries for Alt+Left/Right keyboard navigation?

New Here ,
Jan 08, 2011 Jan 08, 2011

Copy link to clipboard

Copied

The word boundaries in my setup are defined as a complete reference to the last property/method being referenced on an object rather than using the '.' character as the point to place the cursor.  This is driving me nuts when I want to press Alt+Left/Right to navigate the properties/methods of an object on the same line. Like so;

_currentCommand.addEventListener( CommandExecutionEvent.COMMAND_COMPLETE, onCommandCompleted );

Pressing Alt+Right at the start of the line will jump me to the opening bracket rather than 'addEventListener', and pressing again will take me to the comma rather than the static property reference.  This is such a strange behaviour for a code editor that I have to believe there is a way to add the '.' character as denoting a word boundary for keyboard navigation. 

The behaviour is the same for Alt+Left which is even worse because if I want to return to the start of the line it will include all the tab spaces to the left of the first character thus taking me to the very start of the line rather than where the code begins.

I'm certain this was not the case with earlier versions of Flex Builder so if anyone has a solution I'd be very happy to hear it.

Thanks in advance.

Views

378

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 13, 2011 Jan 13, 2011

Copy link to clipboard

Copied

Which version of FB are you using and on what platform ?

On Windows the behavior is as expected when using Ctrl+Left/Right keys (dot is treated as a word boundary).

On Mac the behavior is buggy as you have mentioned.

The behavior is same in JDT as well (correct behavior on Win and incorrect behavior on Mac when the smart cursor positioning option is turned off).

Because of this I think this is Eclipse platform bug and hence is a problem in FB as well because FB is depending on the platform for key navigation.

Please log a bug in bugs.adobe.com/jira so that this can be fixed in FB.

Thanks

Sreenivas

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 21, 2011 Jan 21, 2011

Copy link to clipboard

Copied

LATEST

On Mac -

Go to System Preferences > Language & Text > Text > Word Break

set it to English (United States, Computer)

You may have to restart Flash Builder.

It's still inconsitant and highly annoying, but slightly more usable.

Hopefully there will be a propper fix soon.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines