• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
Locked
0

Migrating a Flash CS4 project to FlashBuilder

New Here ,
Apr 23, 2010 Apr 23, 2010

Copy link to clipboard

Copied

I'm migrating a Flash CS4 project  to Flash Builder.  My CS4 project has a lot of assets that are assigned  classes in the Flash library.  For example, a graphic in the library has  a class name of MyBitmap, and a base class of  flash.display.BitmapData.  I've built my CS4 project as a SWC file and  included it as a library in my Flash Builder project.  The project  builds fine, but when it runs, it says MyBitmap is not defined.  Is  there a way to resolve this?

Thanks,

Brian

Views

775

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Apr 26, 2010 Apr 26, 2010

Copy link to clipboard

Copied

That's odd that it would fail at runtime. Can you make sure the SWC contains what you expect? In Flash Builder, in Package Explorer, look for your SWC under "Referenced Libraries". Perhaps the class wasn't actually compiled into the SWC.

Jason San Jose

Software Engineer, Flash Builder

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 27, 2010 Apr 27, 2010

Copy link to clipboard

Copied

LATEST

The class was in the SWC, but I looks like the problem occured because I didn't declare any variables referring to the SWC assets (didn't need to do this in CS4).  Once I declared a variables, I was able to use the SWC classes.  I'll probably move most of these directly to the Flash Builder project using the [EMBED ...] tag anyway.

-- Brian

Jason San Jose wrote:

That's odd that it would fail at runtime. Can you make sure the SWC contains what you expect? In Flash Builder, in Package Explorer, look for your SWC under "Referenced Libraries". Perhaps the class wasn't actually compiled into the SWC.

Jason San Jose

Software Engineer, Flash Builder

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines