• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
Locked
0

NetConnection.Call.Failed: HTTP: Status 404: url: 'http://localhost:8080/WebContent/messagebroker/amf''

New Here ,
Jun 04, 2015 Jun 04, 2015

Copy link to clipboard

Copied

Hello everybody,

I have traveled the forum but I still have not found a solution to my problem:

I recently installed Flash Builder 4.7 and I want to run my web application with java / Flex / BlazeDS.

I use the 4.0.1.21287 version of BlazeDS with tomcat 7.

It was working fine with Flex Builder 3 and tomcat 6.

I seem to have set everything correctly but I always this error :
ErrorFlex.jpg

Here are the settings in my services-config.xml :

<?xml version="1.0" encoding="UTF-8"?>

<services-config>

    <services>

        <service-include file-path="remoting-config.xml" />

        <service-include file-path="proxy-config.xml" />

        <service-include file-path="messaging-config.xml" />       

    </services>

    <security>

        <login-command class="flex.messaging.security.TomcatLoginCommand" server="Tomcat"/>

    </security>

    <channels>

        <channel-definition id="my-amf" class="mx.messaging.channels.AMFChannel">

            <endpoint url="http://{server.name}:{server.port}/{context.root}/messagebroker/amf" class="flex.messaging.endpoints.AMFEndpoint"/>

        </channel-definition>

        <channel-definition id="my-secure-amf" class="mx.messaging.channels.SecureAMFChannel">

            <endpoint url="https://{server.name}:{server.port}/{context.root}/messagebroker/amfsecure" class="flex.messaging.endpoints.SecureAMFEndpoint"/>

            <properties>

                <add-no-cache-headers>false</add-no-cache-headers>

            </properties>

        </channel-definition>

        <channel-definition id="my-polling-amf" class="mx.messaging.channels.AMFChannel">

            <endpoint url="http://{server.name}:{server.port}/{context.root}/messagebroker/amfpolling" class="flex.messaging.endpoints.AMFEndpoint"/>

            <properties>

                <polling-enabled>true</polling-enabled>

                <polling-interval-seconds>4</polling-interval-seconds>

            </properties>

        </channel-definition>

    </channels>

    <logging>

        <target class="flex.messaging.log.ConsoleTarget" level="Error">

            <properties>

                <prefix>[BlazeDS] </prefix>

                <includeDate>false</includeDate>

                <includeTime>false</includeTime>

                <includeLevel>false</includeLevel>

                <includeCategory>false</includeCategory>

            </properties>

            <filters>

                <pattern>Endpoint.*</pattern>

                <pattern>Service.*</pattern>

                <pattern>Configuration</pattern>

            </filters>

        </target>

    </logging>

    <system>

        <redeploy>

            <enabled>false</enabled>

            <!--

            <watch-interval>20</watch-interval>

            <watch-file>{context.root}/WEB-INF/flex/services-config.xml</watch-file>

            <watch-file>{context.root}/WEB-INF/flex/proxy-config.xml</watch-file>

            <watch-file>{context.root}/WEB-INF/flex/remoting-config.xml</watch-file>

            <watch-file>{context.root}/WEB-INF/flex/messaging-config.xml</watch-file>

            <watch-file>{context.root}/WEB-INF/flex/data-management-config.xml</watch-file>

            <touch-file>{context.root}/WEB-INF/web.xml</touch-file>

             -->

        </redeploy>

    </system>

</services-config>

Does anyone can help me on this ?

Thanks in advance for your help!

Views

3.5K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

New Here , Jun 09, 2015 Jun 09, 2015

Hi,

I finally solved my problem.

In fact, the .flexProperties file automatically generated by FB is not set correctly.

The serverContextRoot = "/WebContent" instead of /ProjectName.

By changing this setting everything works properly.

I think it's a bug of FB because in the project properties, my contextRoot is defined with /ProjectName.

Votes

Translate

Translate
New Here ,
Jun 09, 2015 Jun 09, 2015

Copy link to clipboard

Copied

Hi,

I finally solved my problem.

In fact, the .flexProperties file automatically generated by FB is not set correctly.

The serverContextRoot = "/WebContent" instead of /ProjectName.

By changing this setting everything works properly.

I think it's a bug of FB because in the project properties, my contextRoot is defined with /ProjectName.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 17, 2017 Mar 17, 2017

Copy link to clipboard

Copied

LATEST

Hi,

Can you please send me a screen shot of where you fixed it in flash builder properties. I am having same issue. Below is what appears and the link I have is as

"/eTrackerHRP/Gateway.aspx");

is that why it is cauing trouble in mxml file?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines