• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
Locked
0

Setting the language for runtime error messages

Guest
Aug 24, 2011 Aug 24, 2011

Copy link to clipboard

Copied

I'm running Flash Builder 4.5 and am getting runtime error messages in German. The machine I work on has the locale set to German at the OS level but I want error messages in the Flash environment to be generated in English.

There used to be a post on this but it is impossible to find due to the way that the Search function works from within the Adobe forums. If you are positioned in a particular forum, say Using Flash Builder and enter an argument into the Search Forums text control results are returned for all forums i.e. hundreds of unrelated results. If you change the search options to limit the search to Using Flash Builder you get 0 results even though there were posts in the forum containg the search arguement.

Views

652

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Aug 25, 2011 Aug 25, 2011

Copy link to clipboard

Copied

Setting the argument '-nl en_US' should retrieve all the messages and strings in English, irrespective of the OS language. This param can be set either in FlashBuilder.ini file (that is available along with executable), or either can be pass through command line.

I would recommend to set this parameter in the .ini file as it would persist the parameter across restarting sessions.

If you are on Windows, FlashBuilder.ini file is available in the <installation location>.

On Mac, to find the .ini file -> right-click on "Adobe Flash Builder 4.5" executable and select Show Package Contents. Then traverse to Contents->MacOS->Adobe Flash Builder 4.5.ini

Most likely, the FlashBuilder.ini file should already have -nl argument. So just changing its value to 'en_US' should suffice. Hope this helps. Let me know if that does not solve your usecase.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Aug 25, 2011 Aug 25, 2011

Copy link to clipboard

Copied

Unfortunately, this did not work for me. Here are the contents of the FlashBuilder.ini file:

-nl
en_US
-startup
eclipse/plugins/org.eclipse.equinox.launcher_1.1.0.v20100507.jar
--launcher.library
eclipse/plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.1.1.R36x_v20100810
--launcher.defaultAction
openFile
-vmargs
-Xms256m
-Xmx512m
-XX:MaxPermSize=256m
-XX:PermSize=64m
-Dorg.eclipse.equinox.p2.reconciler.dropins.directory=eclipse/dropins
-Declipse.application=com.adobe.flexbuilder.standalone.FlashBuilderApplication

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Aug 25, 2011 Aug 25, 2011

Copy link to clipboard

Copied

LATEST

Whe you say:

This param can be set either in FlashBuilder.ini file (that is available  along with executable), or either can be pass through command line.

do you mean set it as a compiler directive/option?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines