• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
Locked
0

Severe OS X Issue When Opening MXML Files

Guest
Feb 25, 2011 Feb 25, 2011

Copy link to clipboard

Copied

Every time I open an MXML file, Flash Builder totally locks up, uses 100% (or more, yeah, more) CPU, gives me the spinning beach ball and says "(Not Responding)" in Activity Monitor for about 1 minute. It always recovers from this, but it always happens and always lasts about a minute. Closing and reopening the same file does the same thing. Even opening a file that's ALREADY OPEN in a new window causes this to happen. This problem does not occur with .as files.

It's a waste of time to work on a huge project with this issue, it's just not worth the waiting. I've tried reinstalling and upping Eclipse JVM memory, neither fixed it. The strange thing is that the UI is responsive after opening an MXML for maybe 1 second before it freezes.

Flash Builder Burrito using Flex Hero

OS X 10.6.6, 2.26 GHz Core 2 Duo, 4GB RAM

Why only MXML files? A design view bug? I've searched around here and Google for similar issues but found nothing.

Views

826

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Explorer , Feb 28, 2011 Feb 28, 2011

Hi,

Would it be possible for you to share your project with me ?  my email id is ranik@adobe.com

Please give the build number details also.


If you are not using the design view, please disable the same using windows ->Enable Design Mode uncheck this option.

thanks,

Rani

Votes

Translate

Translate
Explorer ,
Feb 28, 2011 Feb 28, 2011

Copy link to clipboard

Copied

Hi,

Would it be possible for you to share your project with me ?  my email id is ranik@adobe.com

Please give the build number details also.


If you are not using the design view, please disable the same using windows ->Enable Design Mode uncheck this option.

thanks,

Rani

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guest
Feb 28, 2011 Feb 28, 2011

Copy link to clipboard

Copied

LATEST
Wow I COMPLETELY missed the "Enable Design Mode" toggle. I was hunting around for it too (I figured it would be in the Preferences window). That actually seemed to have fixed the issue.
The project itself is under NDA so I don't think I can send it. If I am allowed to strip things out and send I'll let you know. Thanks!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines