• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
Locked
0

SWFloader causing "transcode" errors

New Here ,
Mar 25, 2011 Mar 25, 2011

Copy link to clipboard

Copied

I'm trying to embed an SWF file (dynamic application) into my current mxml file and I'm getting errors (detailed code below).  The index.swf that I'm trying to embed is located in my src and my bin-release folders.  Why can't it find the swf file?  Maybe I'm just not understanding the meaning of the transcoding errors.  Please help.


My Code:

<?xml version="1.0" encoding="utf-8"?>
<s:Application xmlns:fx="http://ns.adobe.com/mxml/2009"
               xmlns:s="library://ns.adobe.com/flex/spark"
               xmlns:mx="library://ns.adobe.com/flex/mx" minWidth="1000" minHeight="600"
               currentState="CloseArchives">
    <fx:Style source="archive.css"/>
    <s:states>
        <s:State name="CloseArchives"/>
        <s:State name="OpenArchives"/>
    </s:states>
    <fx:Declarations>
        <!-- Place non-visual elements (e.g., services, value objects) here -->
    </fx:Declarations>
    <s:BorderContainer id="s1" x="0" y="0" width="1000" height="600" backgroundColor="#730F0F" width.OpenArchives="675" x.OpenArchives="325">
            <s:Label text="Map Area" x="0" fontSize="17" fontWeight="bold" color="#FFFFFF"/>
            <s:Button width="42" enabled="true" x="0" y="284" label="&gt;" includeIn="CloseArchives" click="currentState='OpenArchives'"/>
            <mx:SWFLoader x="0" y="0" width="1000" height="600" width.OpenArchives="675" x.OpenArchives="0" id="mapload" source="@Embed(source='index.swf')"/>
    </s:BorderContainer>

    <s:BorderContainer includeIn="OpenArchives" x="0" y="0" width="325" height="600" backgroundColor="#4289AA" id="s2">
        <s:Button x="273" y="287" label="&gt;" width="42" enabled="true" id="OpenArchives" x.OpenArchives="294" y.OpenArchives="289" label.OpenArchives="&lt;" click="currentState='CloseArchives'"/>
        <s:RichText x="10" y="10" text=" Previous Years Information:&#xd;  2009&#xd;   Albemarle-Pamlico&#xd;    Map&#xd;    Report&#xd;    Project Photos&#xd;      Project Name (Before)" width="294" height="578"/>
    </s:BorderContainer>
    <s:transitions>
        <s:Transition id="opening" fromState="CloseArchives" toState="OpenArchives">
            <s:Parallel targets="{[s2]}">
                <s:Fade duration="1000"/>
            </s:Parallel>
        </s:Transition>
    </s:transitions>   
</s:Application>

My Errors all for the line where the SWFloader is located:

unable to resolved 'index.swf' for transcoding

Unable to transcode index.swf

Thank you in advance,

Alison

Views

507

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 25, 2011 Mar 25, 2011

Copy link to clipboard

Copied

Have you tried

source="@Embed(source='/index.swf')" to force it to look at the root?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 25, 2011 Mar 25, 2011

Copy link to clipboard

Copied

LATEST

Hi Michael,

Thank you for the tip.  I tried making it a full path and received the same error message.

-Alison Page

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines