• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
Locked
0

Where is the Services folder?

LEGEND ,
Jul 15, 2010 Jul 15, 2010

Copy link to clipboard

Copied

I did a release build but in the build there is no Services Folder like in the debug build? Where is the Services folder and where do I put it?

Sorry, new to Flex and FB .... 😉

Brad Lawryk

Adobe Community Professional: Dreamweaver

Northern British Columbia Adobe Usergroup: Manager

My Adobe Blog: http://blog.lawryk.com

Views

598

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 21, 2010 Jul 21, 2010

Copy link to clipboard

Copied

The services folder does not get included as part of the release build as its a file that is accessed on the server. That is where ever the release swf is deployed it should be able to access the service file through the zend amf library which gets installed as part of creating a php service.

Hope this helps.

-Sunil

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jul 21, 2010 Jul 21, 2010

Copy link to clipboard

Copied

Thanks Sunil,

I think I have it figured out now - but I get a whole list of errors on my page now in the browser. I cannot figure out what these mean. I assume there is something I need to change on the gateway.php file?

Seriously there needs to be some documentation on exactly what to do to move an application to the web. Like exactly what has to be all uploaded and what has to be changed and where.

There is no plain English documentation any where. I would assume that almost all of the applications built are not meant to be on the local machine and need to be moved somewhere else that is accessible by the outside world. Why is there absolutely no documentation on this?

Can you please have a look at http://www.auroragraphix.com/quotes/Quotes.html and see what I am missing?

Thanks,

Brad Lawryk

Adobe Community Professional: Dreamweaver

Northern British Columbia Adobe Usergroup: Manager

My Adobe Blog: http://blog.lawryk.com

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 21, 2010 Jul 21, 2010

Copy link to clipboard

Copied

About the site you sent, I think it’s a bad sql being executed, the error that I got was this

>>

MySQL Error - 1047: Unknown command

#0 /homepages/35/d280850650/htdocs/auroragraphix/quotes/services/QuotesService.php(59): QuotesService->throwExceptionOnError()

#1 : QuotesService->getAllQuotes()

#2 : ReflectionMethod->invokeArgs(Object(QuotesService), Array)

#3 /homepages/35/d280850650/htdocs/auroragraphix/ZendFramework/library/Zend/Server/Reflection/Function/Abstract.php(368): call_user_func_array(Array, Array)

#4 : Zend_Server_Reflection_Function_Abstract->__call('invokeArgs', Array)

#5 /homepages/35/d280850650/htdocs/auroragraphix/ZendFramework/library/Zend/Amf/Server.php(356): Zend_Server_Reflection_Method->invokeArgs(Object(QuotesService), Array)

#6 /homepages/35/d280850650/htdocs/auroragraphix/ZendFramework/library/Zend/Amf/Server.php(550): Zend_Amf_Server->_dispatch('getAllQuotes', Array, 'QuotesService')

#7 /homepages/35/d280850650/htdocs/auroragraphix/ZendFramework/library/Zend/Amf/Server.php(626): Zend_Amf_Server->_handle(Object(Zend_Amf_Request_Http))

#8 /homepages/35/d280850650/htdocs/auroragraphix/quotes/gateway.php(69): Zend_Amf_Server->handle()

#9

<<

About the documentation, can you check this http://help.adobe.com/en_US/flashbuilder/using/WS6f97d7caa66ef6eb1e63e3d11b6c4d0d21-7f99.html#WSbde04e3d3e6474c4590ecaa71247398d84f-8000

Thanks

-Sunil

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jul 21, 2010 Jul 21, 2010

Copy link to clipboard

Copied

LATEST

Hi Sunil,

I believe I have done all that the documentation says except change

production to true from false. I left as false so I could see the errors.

This small simple app works fine locally and the database is identical

on both local and live locations. Maybe I'll start allover again, but I

don't see how that would help when its working fine locally.

If you come up with any ideas please let me know.

Thanks again for your time,

Brad Lawryk

Adobe Community Professional: Dreamweaver

Northern British Columbia Adobe Usergroup: Manager

My Adobe Blog: http://blog.lawryk.com

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines