OS X 10.11 El Capitan breaks Flash Builder

Explorer ,
Jun 17, 2015

Copy link to clipboard

Copied

OS X 10.11 El Capitan removes the legacy Java 6 SE runtime, which is required for Flash Builder 4.7 to run. Are there any plans to update Flash Builder to prevent this problem? At the moment there is a workaround which bypasses the OS X Java version checks in order to reinstall Java 6:

Resolved - Apple Java 6 for 10.11 | Page 2 | MacRumors Forums

But this isn't a very good solution...

Views

21.9K

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

1 Correct Answer

Explorer , Aug 21, 2015
slmille4 Explorer , Aug 21, 2015
The problems that El Capitan introduced with Flash Builder seem to have been fixed as of 10.11 beta 7

Likes

Translate

Translate
Jump to answer Jump to answer
Engaged ,
Jun 17, 2015

Copy link to clipboard

Copied

+1 for this.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
slmille4 AUTHOR
Explorer ,
Jun 19, 2015

Copy link to clipboard

Copied

update: In order to use this with AIR, you need to copy cacerts from "Contents/Home/lib/security/" on the latest version of Java to the same location in the Java 1.6 install

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Jun 22, 2015

Copy link to clipboard

Copied

Also +1 for this. Same problem for my colleagues and me. And this is not the only problem we have.

SVN not working anymore on Flash Builder 4.7

Perhaps is at the time to update the Flash Builder with a newer Eclipse?

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
slmille4 AUTHOR
Explorer ,
Jul 10, 2015

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Jul 11, 2015

Copy link to clipboard

Copied

it seems not work to me.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
slmille4 AUTHOR
Explorer ,
Jul 11, 2015

Copy link to clipboard

Copied

Yep, I think I got prematurely excited. All the Apple link did was provide the same version of Java 6, except that El Capitan would install it right away without requiring Pacifist to bypass the version check.

Flash Builder ran on El Capitan Betas 1/2 once Java 6 was installed, but on Beta 3 it won't even load without hanging.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Jul 11, 2015

Copy link to clipboard

Copied

so sad

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jul 27, 2015

Copy link to clipboard

Copied

Released today:

http://www.macupdate.com/app/mac/39490/apple-java

Works under 10.11 beta 4

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Oct 28, 2015

Copy link to clipboard

Copied

THIS IS THE RIGHT FILE!!!!!!!!!!!!!!!!!!!!!! MAny thannks FRANS VAN DER GEEST

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Nov 19, 2015

Copy link to clipboard

Copied

I was hoping that the Java download would somehow also fix my Flash 5.5, but it doesn't. Any suggestions?

Flash 5.5 does run, but there are certain files that it will crash on immediately after opening, files that I've been working on for about a year under the old system. I tried downloading the trial version of Flash CC to see if I could somehow open and modify the files in some way that would make them open in Flash 5.5... I had some clues, like maybe it had to do with El Capitan's new color palette, or maybe how fonts were used, but these may have been red herrings because I was never able to reliably determine what was crashing 5.5.

The reason I stupidly upgraded my system: I was trying to learn Swift coding, which required a new Xcode. After a 40 minute download Xcode required El Capitan, which took 3 hours. I didn't think it through that keeping my old Adobe production bundle working, and avoiding the expensive Creative cloud, was a lot more important than learning Swift. Going back to an older system looks to be a nightmare process for me. Ugh!

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Explorer ,
Aug 21, 2015

Copy link to clipboard

Copied

The problems that El Capitan introduced with Flash Builder seem to have been fixed as of 10.11 beta 7

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Contributor ,
Oct 04, 2015

Copy link to clipboard

Copied

I have just updated to El Capitan. Flash Builder 4.6 Premium loads, then before it opens, it crashes.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
slmille4 AUTHOR
Explorer ,
Oct 05, 2015

Copy link to clipboard

Copied

I've only tried it with FB 4.7, but did you install the El Capitan version of Java 6?

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more