Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Locked

Flash Content is not working with Chrome

Community Beginner ,
Feb 13, 2018 Feb 13, 2018

Copy link to clipboard

Copied

hi all

i have got Chrome updated recently to (Version 64.0.3282.140 (Official Build) (64-bit). but websites with flash content are no more working. i can only hear the sound but no video. i am using win 10 (64 bit). it pops up me that Flash Plugins is blocked (in the top right corner in address bar). when i enable it, it doesn't respond. i tried all possible solutions mentioned in forums and youtube but nothing worked ( uninstalling chrome, uninstalling Adobe Flash, re-install them again, checking chrome settings, "always" allowing flash). it only worked when i installed the older version of chrome (63). flash started working again fine. but the problem is that Chrome is programmed to auto-update to the latest version, and problem came back  

youtube is working fine without any problem
my other browser firefox has no problem with flash at all, the problem is only with Chrome

appreciate your assistance

thanks

TOPICS
Browser, Product issue

Views

64.4K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 13, 2018 Feb 13, 2018

Copy link to clipboard

Copied

YouTube no longer uses Flash for videos and uses HTML5 video, instead.  To verify, right-click on the content to display the context menu.

Please provide the following information:

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 14, 2018 Feb 14, 2018

Copy link to clipboard

Copied

hi maria

it is Windows 10  version 1709 (OS build 16299.192)
the problem is not in 1 website. it is in all websites that use flash (example https://vidbob.com/ds74gshbe851  )


the problem is only in the latest chrome version 64. when i downloaded the previous version 63, flash worked perfectly. but chrome automatically updated itself to 64


thanks

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 14, 2018 Feb 14, 2018

Copy link to clipboard

Copied

Test machine configuration:

  • Windows 10 Home Version 1709 OS Build 16299.162
  • Chrome 64.0.3282.167 (Official Build) (64-bit)
    • I reset Chrome to it's default installation settings
    • By default, Flash is set to 'Ask first (recommended)', which means user is prompted to enable Flash whenever they attempt to view Flash content.
      • I tested with this default setting and with Flash blocked

I went to the link in your post and was not prompted to enable Flash, either with the default setting (ask first) and with Flash blocked.  In both cases, the video played fine.  This seems to indicate the video is not Flash video.  It seems the right-click functionality has been disabled, so I can't view the context menu to see if it is Flash or not.

If you believe it is Flash video, please work through the following troubleshooting help documents:

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 14, 2018 Feb 14, 2018

Copy link to clipboard

Copied

hi maria

thank you for your time replying to me

if it is not Flash Vedio, what is it then? i can give you other websites that i usually used and they were working fine last week before they suddenly stopped working:

[links removed]

all are working fine in Firefox

i dont know wht right click is disabled for the first link i gave you. but for the 3 above links, right click is activated so you can check if it is flash or not.

by the way, the first link i gave you earlier, i was prompted that FLASH PLUGIN HAS BEEN BLOCKED. when i clicked to allow plugin, chrome didnt respond accordingly


i will check the troubleshooting documents and give you the update asap

thanks

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 14, 2018 Feb 14, 2018

Copy link to clipboard

Copied

If Flash Player is working and you're getting the context menu and just a black rectangle for video, my guess is that it's either a problem with hardware video acceleration or you're not getting the actual video stream.  If you're getting the context menu and it says About Flash Player, then Flash Player is running.

There's no widespread problem with Flash video playback on Chrome, which points to either a local issue or an outage (or Firewall issue) affecting the service providers that you mentioned in your reply.

My recommendation would be to follow the video troubleshooting guide that Maria linked in the previous reply, in particular, disabling hardware acceleration.

If that doesn't help, then checking the video test links in the guide would be useful.  Do you see both the Flash and HTML5 videos there?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 16, 2018 Feb 16, 2018

Copy link to clipboard

Copied

But why would flash work in two other browsers but not in Chrome? And only since the recent update?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 14, 2018 Feb 14, 2018

Copy link to clipboard

Copied

<edited>

The very first link you posted (comment # 3) has a 'Download Now' option.  When selecting that, the video format is .pm4

For the links in your comment #6:

The first link is not available in my region.  It returns the error "This content is not available in your country"

The second link contains 2 videos - one is a YouTube video and YouTube uses HTML5 video.  The second links, when I open it in full screen goes to a Google Drive URL and shows the name of the file as "The.Good.Doctor.S01E01.720p.HDTV.(www.HaMaDHD.cf).mkv"  mkv video format is not Flash content.

The third link also does not appear to be Flash content.  It appears to be HTML5 video

Essentially, none of these appear to be Flash video content

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 14, 2018 Feb 14, 2018

Copy link to clipboard

Copied

Hi maria

it is really weird! i used to see movies and video in different websites and i dont know what type of player these websites are using. out of sudden all stopped except youtube. if the links i gave you are not flash, what might be the reason? i have a doubt that it is hardware issue. but if it is really hardware issue, then why is firefox working fine? why is previous version of chrome also working fine? if it is hardware issue, then i shouldn't be able to play these contents in all browsers, in all versions. is it compatibility issue?

by the way, there was 1 website (beinmatch.com) where it poped up me very clearly that "flash player was blocked" and when i tried to unblock it, chrome dint respond (attached)

being a technical expert, do you have any explanation for this?

thanks
1.jpeg2.jpeg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 15, 2018 Feb 15, 2018

Copy link to clipboard

Copied

why is previous version of chrome also working fine?

I would recommend contacting Google for assistance. If it worked fine in previous version, but not new version it's possible one of their changes is the culprit.


In your comment #9, the second screenshot that has 'Flash was blocked on this page', what happens when you click 'Manage'?

Of all the sites you've provided, beinmatch.com is the only one where I've been prompted to 'Allow Flash':

After I click 'Allow' the page displayed the following:

It's not clear to me what content is Flash content on the page.  I clicked on the link for one of the matches and video displayed, but it's not clear if it's Flash video or not:

Right-clicking on the video launches a new tab to some other site.

Are these new sites you are visiting? Or have you visited these numerous times in the past?  I'm wondering if Chrome's Site Engagement Index feature is preventing Flash content.  Go to chrome:/site-engagement.  In the 'Origin' column, look for the site that is not working.  What is the corresponding number in the 'Base' column?  If it's less than 100, change it to 100 and restart Chrome.

More information on Site Engagement available at:

Another alternative is to whitelist all Flash sites in Chrome:

  1. Go to chrome://settings/content/flash.
  2. In the Allow section, click Add
  3. Add the folloowing to the Allow list:
  4. Reload Chrome.
  5. Does Flash content display now?

If you've tried these suggestions and Google's suggestions on Use or fix Flash audio & video - Computer - Google Chrome Help  and nothing works, I recommend contacting Google for assistance.  Ultimately it's their browser loading Flash content and controlling whether or not Flash content displays, not Flash Player.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 15, 2018 Feb 15, 2018

Copy link to clipboard

Copied

i dont think Google are helpful in this as they will not reply to me personally as you in adobe. so a big thank you for your efforts

* when i clicked "manage" last time it took me to flash setting in chrome where i can give permissions for flas (ask, always allow, allows block)
* when i  go now to the same page, i am no more getting this pop up for flash plugins blocked (as i attached earlier)
* what you did in your last attempt was not allowing "FLASH". it was allowing "NOTIFICATION". i always block notifications. however, for this time, i allowed notification just to see if it is really the reason. but it is same, flash is still not working. this means that when you tried last time, it didnt work because you allowed "notification", it worked because it is originally working fine with your chrome
*yes, "right click" wont work in the first nor second attempt. but if try one more time, you will be able to do "right click"
* right click here will open a menu which is not the one you are looking for as i think. it will open a menu for (Loop, show Control, cast, and inspect) there is no option for flash logo as you said last time. not only in this website, but many others
*yes, i always use these websites for different purposes. it is not the first time. i access them. videos used to play normally without any issue till last week when i firstly faced this issue

regarding site engagment, find attached screen shot. you are right.  it is less than 100. site eng.jpg

i changed value to 100, but it didnt work. find attached again

site eng 2.jpg

i tried to add (https://*.*)  and (http*.*) but i got a response that they are invalid. i put instead (https) and  (http) . it was accepted. i dont know if what i did is correct or not. please advise

unfortunatly, google people are useless here

awaiting for your feedback

thanks for your patience

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 15, 2018 Feb 15, 2018

Copy link to clipboard

Copied

I didn't select anything in the 'Notification' pop-up.  Just relaying to you the experience I observed.

For whitelisting all websites, I had a typo in my comment, try http://* and https://* 

In your chrome://site-engagement screenshot, the entry for http://www.beinmatch.com is still at 5.31.  Can you try changing this to 100 and reloading Chrome?

Please post a screenshot of your chrome://settings/content/flash settings

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 15, 2018 Feb 15, 2018

Copy link to clipboard

Copied

i corrected the whitelis value

regarding engagment value, i sent you 2 screen shot, the first was original settings. and the second is  after i did the change. it is 100 in the second screenshots

still not working...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 15, 2018 Feb 15, 2018

Copy link to clipboard

Copied

You posted 2 screenshots, I'm referring to the second screenshot, where http://www.beinmatch.com still has a score of 5.31:

Untitled.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 15, 2018 Feb 15, 2018

Copy link to clipboard

Copied

Another thing, go to chrome://flash and paste the directory path for the version of Flash that Chrome is using.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 15, 2018 Feb 15, 2018

Copy link to clipboard

Copied

sorry i didnt notice that there are 2 lines for the same website. here you are screen shot again. still not working

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 16, 2018 Feb 16, 2018

Copy link to clipboard

Copied

Dear Maria

your colleage jeromiec mentioned me to another topic (Audio but no Video in Chrome ) where only sound is playing, no sound, and some rectangles are there. these are symptoms of my problem as well. i replied to him  as below

Audio but no Video in Chrome

----------------------

yes, my problem is that there are also rectangle and only sound, no video. when i try to do right click, there is no settings options. there are other options like below:
(link is   https://ok.ru/video/614407085652 )

by the way, and for the first time after i firstly faced this issue, now i can play vedio in one website that i used to use. both video and sound are playing fine. i dont know what i did, and what is the reason. only website is (جسور والجميلة - Shahid.net ) this is only for that video. other videos in the same website are still facing the problem. so we are here talking about some videos that are playing fine, and others (in the same website) are not. it is really weird!

right click doesnt have settings still:

however, before the video plays, usually there is an ads for 10 sec, this ads is again playing only sound with no video with the same rectangles.

regarding "Hardware Acceleration", and since i wasnt able to access this settings using right click option, i went to this settings in side chrome settings, and i disabled it. guess what is the results!!


ALL WEBSITES AND ALL VIDEOS ARE NOW PLAYING WELL AND FINE

i think case is solved for me. however, i still need to know how disableing this option will affect me in future? how will it affect other contents or experience. what is the use of this option (Hardware Acceleration)


thank you man for your efforts

-------------------

thank you maria. you were unable to help me because i didnt give the full symptoms of my problem (only sound is playing, no video, and rectangles). now it is ok.

thank you maria

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 16, 2018 Feb 16, 2018

Copy link to clipboard

Copied

None of these videos appear to be Flash.  The context menu is not the Flash Player context menu. This is the HTML5 video context menu.

Here is a screenshot of the Flash Player context menu:

Screen Shot 2018-02-16 at 12.14.36 PM.jpg

This cnn.com CNN Live video uses some other video technology along with Flash Player

Screen Shot 2018-02-16 at 12.09.43 PM.jpg

Here is a screenshot of YouTube HTML5 video context menu, which is the same as the context menu in your screenshots, and what I get in videos in every single link you've posted.  Link to this video is Incredibles 2 - Olympics Sneak Peek - YouTube

Screen Shot 2018-02-16 at 12.11.37 PM.jpg

<edited>

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 16, 2018 Feb 16, 2018

Copy link to clipboard

Copied

dear maria

but one of the website that was not working is a video that poped me up very clearly that "flash plugins was blocked" ( i sent you screenshot earlier) how come it is blocked and it is HTML5? why youtube (which is HTML5) was working fine? what is hardware Acceleration?

thx

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 13, 2018 Feb 13, 2018

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Feb 14, 2018 Feb 14, 2018

Copy link to clipboard

Copied

i tried it many times. it didnt work..

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 15, 2018 Feb 15, 2018

Copy link to clipboard

Copied

Hi all,

same problem here.

Windows 10 Pro build 16299
I have Google Chrome v. 64.0.3282.167 x64 and Adobe Flash Player plugin v. 28.0.0.161 (open a tab with chrome://components to verify)

I can't play any flash object with Chrome. It works with Firefox and Edge.
I was wondering if this is a compatibility issue.

Regards
Fab

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 15, 2018 Feb 15, 2018

Copy link to clipboard

Copied

Hi sardus87

Please provide direct links to content that is not working.  And please see my replies to OP for troubleshooting recommendations.

--

Maria

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 15, 2018 Feb 15, 2018

Copy link to clipboard

Copied

You want https://* and http://* - not "https://*.*"

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 24, 2018 Feb 24, 2018

Copy link to clipboard

Copied

Hi all,

I had the same issue in windows 10 + chrome 64 :

in Chrome : facebook or dailymotion videos ko, youtube ok

in IE : 0 problem with any site

I thought this was an adobe flash issue and tried many of solutions found on the net with no sucess.

Finally I read Maria's advise to contact Google. Then I went to Google forum and found a recent topic on this issue.

It was told to deactivate hardware acceleration and then restart chrome. I did that and after new test : video were working for all the sites in chrome like before !

This is very important to restart chrome, I found the solution previously on another web site but did not restart chrome so I thought it was ko after a test and put option for hardware acceleration back .

To access hardware acceleration option and deactivate it before the chrome restart, put this in the chrome adress bar: chrome://settings/system

Hope this will help and work for anyone who's got this issue.

Regards.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
    • 1
    • 2