Locked

Adobe Flash Installation page in chinese?

New Here ,
May 09, 2017 May 09, 2017

Copy link to clipboard

Copied

I noticed that there was an Adobe Flash update for OSX and proceeded to download it via System Preferences. Upon clicking to update adobe flash player, i noticed the page was in chinese when the installer file was being prepared to download. I thought this was a fluke and proceeded to update flash via web on Adobe's check flash player page(https://www.adobe.com/uk/software/flash/about/). Through Adobe's own page the downloader was in english.

I had to download the new flash update on my second computer and the chinese lettering was the same when i went through System Preferences to update.

Screen Shot 2017-05-09 at 8.54.39 PM.png

Is this just some random bug with the update, as this is the first ive actually seen the update page in chinese.

Views

2.9K

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 10, 2017 May 10, 2017

Copy link to clipboard

Copied

Hi,

Was the Flash Player installer itself displaying in Chinese, or was it just the download/completion page that displayed in Chinese?

Please provide the following two screenshots:

  • System Preferences > Language & Region
  • System Preference > Language & Region > Advanced

Once I receive your reply and screenshots I'll forward to the team that manages the download page.

Thank you.

--

Maria

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 10, 2017 May 10, 2017

Copy link to clipboard

Copied

It was just the download page for what i know

I actually used the installer from the chinese download page on my second computer and the installer was in english; im not sure why the page was in chinese.

Screen Shot 2017-05-10 at 2.03.37 PM.png

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 10, 2017 May 10, 2017

Copy link to clipboard

Copied

Can you post the second screenshot, of System Preference > Language & Region > Advanced?

Thank you.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 10, 2017 May 10, 2017

Copy link to clipboard

Copied

Screen Shot 2017-05-10 at 2.09.44 PM.png

?

There wasnt anything much different in advanced

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 10, 2017 May 10, 2017

Copy link to clipboard

Copied

I'm just not sure what setting the page uses to determine which language to display, and wanted to get the 2 screenshots to send to the team that handles that page.


Your System Preferences > Language & Region > Advanced setting is different than mine.  I'm using OS X 10.11.6 and the system Preferences > Language & Region > Advanced includes a 'Format language' setting that your screenshot doesn't have:

Screen Shot 2017-05-10 at 2.45.03 PM.jpg

What OS X version do you have?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 10, 2017 May 10, 2017

Copy link to clipboard

Copied

Im using macOS Sierra 10.12.4

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 10, 2017 May 10, 2017

Copy link to clipboard

Copied

Thank you.  Also, to confirm, in your first post you mention https://www.adobe.com/uk/software/flash/about/ UK in the URL indicates you are located in the UK.  Is this correct?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 10, 2017 May 10, 2017

Copy link to clipboard

Copied

No im in the US.

The original link i used to check my flash version online was broken at one point and i used the UK one ever since

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 10, 2017 May 10, 2017

Copy link to clipboard

Copied

Ok.. Thank you for clarifying. I'll forward this information to the team that handles that page.  Hopefully they have enough to go on to investigate why the page displayed in Chinese.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 10, 2017 May 10, 2017

Copy link to clipboard

Copied

Hi,

Thanks for quick check for our questions. as you confirmed now https://get3.adobe.com/flashplayer/update/osx and https://get3.adobe.com/flashplayer/ppapiosx and https://get.adobe.com/flashplayer all are displaying English text and continue with English page after clicking on Download now button.

This issue is important to us, we will try to reproduce the issue from our end and fix it.

Thanks

Sreeharsha

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 12, 2017 Jul 12, 2017

Copy link to clipboard

Copied

I'm having this issue too and wondering if it is safe to download from the page. I also clicked the translate to English and it just sits and does nothing except say it is translating. I finally just closed it out, but I'm not about to download from a chinese page these days

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 13, 2017 Jul 13, 2017

Copy link to clipboard

Copied

What operating system are you using?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 18, 2017 Jul 18, 2017

Copy link to clipboard

Copied

Based on the screenshot, it looks like we might have had a bug related to language detection on our distribution site.  It didn't make my radar and complaints are very limited.  I imagine that this was caught and fixed very quickly. 

To give you a sense of scope, we serve around 2.5 Billion Flash Player downloads in a given month.  I'd expect at least a few hundred identical complaints if this has persisted for even a few hours.

It's also possible that as part of that bug (I've seriously not heard anything about this, but it seems like a plausible mistake that could happen), we set "your" language preference when we incorrectly detected it, and now it's stuck on Chinese by default.  If that's the case, we probably set a cookie on your browser.  If you *are* still getting the page in Chinese, you can revisit the page using your browser's incognito or private browsing mode.  If you see it in English in private browsing mode, clearing your cookies will resolve that (and if you want to be super surgical about it, clearing your cookies for just *.adobe.com and/or *.macromedia.com should get it done).

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 11, 2017 Oct 11, 2017

Copy link to clipboard

Copied

Well that was July, it's now October 2017 and the Adobe page for the PPAPI installer doing the same thing again, meaning, it is presented in Chinese.  My settings for Language and Region have been the same for as long as I have had a Mac and are correct.  Despite the installer PPAPI page showed up in Chinese on the Adobe site I still downloaded the Installer anyway and it is now up to date.  Something is wrong with your language detection.

Chris

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 11, 2017 Oct 11, 2017

Copy link to clipboard

Copied

Hi,

What Mac version do you have?

What is your geo-location?

Does the Adobe page you are downloading Flash Player from have a language code in it?  Please post the entire link to the Adobe page you downloaded the installer from.

Please post a screenshot of the following System Preference windows:

  • System Preferences > Language & Region
  • System Preferences > Language & Region > Advanced

Thank you.

--

Maria

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 11, 2017 Oct 11, 2017

Copy link to clipboard

Copied

Hi Maria,

Mac OS version is 10.12.6

Location is Perth, Western Australia

Link to the Adobe page is Adobe - 安装 Adobe Flash Player

Screen Shot 2017-10-12 at 07.49.09.jpg

Screen Shot 2017-10-12 at 07.49.20.jpg

Version details of the Adobe plugin.

Screen Shot 2017-10-12 at 07.51.01.jpg

Cheers

Chris

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 11, 2017 Oct 11, 2017

Copy link to clipboard

Copied

My suspicion is that this was a temporary, regional problem related to the global load balancer servicing APAC and AMEA.  I'm thinking that there was a bug that gave you the incorrect language, that someone noticed and fixed it quickly, but we set a cookie on your machine with the bogus preference, causing the problem persists for you.

I'm routed to the right pages when I visit that link, which kind of validates my theory. 

Adobe has a few thousand engineers and this isn't the part of the organization that I work closely with, so I'm not directly in the know, but it feels very familiar to issues I've seen over the years. 

If my hunch is right, visiting that link using your browser's incognito mode *should* get you the english page.  If so, you might try scrolling down to the very bottom of the page at https://www.adobe.com/ and choosing "change region".  If that doesn't help, but Incognito mode works, you'll need to either clear your cookies, or surgically remove the ones associated with adobe.com to shake off that incorrect default language. 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Oct 12, 2017 Oct 12, 2017

Copy link to clipboard

Copied

It's never happened to me before and I have owned a Mac since 2005 and been using the Flash Player plugin for as long as it has been required to be a browser plugin.  So......  I'll have a ferret around and see.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 13, 2017 Oct 13, 2017

Copy link to clipboard

Copied

Hi chrispy104


Thank you for posting the screenshots.  I'll forward this to the team responsible for that page to investigate further.

--

Maria

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 16, 2019 Aug 16, 2019

Copy link to clipboard

Copied

Same thing happening to me for the Version 32.0.0.238 update. US Mac user; MacOS version 10.13.6; Safari version 12.1.2.

Clearing cookies did not help. Not sure what you mean about incognito mode in Safari, but nothing I have tried has made any difference.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 16, 2019 Aug 16, 2019

Copy link to clipboard

Copied

Adobe is a huge company, and there's a dedicated team that manages the distribution websites.  I'm not generally in the loop on those day-to-day maintenance activities.  My guess, given that you were posting in the wee hours, is that we were probably doing some overnight maintenance when you tried this.  It's within the realm of possibility that we pushed a change to the site that was bad, and then rolled it back when they did their final post-publication sanity check.

If the problem was with the website, it's likely that we noticed that the cookie was gone after you cleared it, and helpfully set your preference back to Chinese again when the page loaded and you encountered the problem again.

I'm definitely not seeing the problem at this point, and it didn't make my radar, so I'm guessing it was relatively short-lived.

You can try by going to File > New Private Window in Safari and going to https://get.adobe.com/flashplayer

If the problem goes away, just clear your cookies again and you should be good to go.

If the problem persists, there's something super weird going on, and I'd like to rule out a couple things:

First, clear your cookies again and reboot.  It forces Safari to reload without those cookies present, and rules out a universe of possibilities about bad memory states and things.

If Safari's cookie store is messed up, it's possible we're interpreting some garbage data coming back from your browser as a request to see Chinese content.  It's worth a quick look.  Just grab any other browser as an experiment (Chrome, Firefox, etc.).  If the problem persists, we know for sure that it's not cookies.

We use a content distribution network composed of thousands of geographically distributed servers to deliver content to our global audience.  You're supposed to get routed to the one closest (or with the least latency anyway) to you.  If it's not cookies, I want to rule out bad geo-detection, or a crazy route.  That seems super unlikely (and hard to troubleshoot), so let's rule out the other stuff first.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines