Locked

Adobe Flash Player Vrs 28

New Here ,
Mar 04, 2018 Mar 04, 2018

Copy link to clipboard

Copied

Hi Im Bev, I have a real quick question?

My operating system is Mac OSX 10.8.5 I have downloaded Adobe Flash Player version 28. It said it was good for Mac OSX10.6.0 Through OSX 10.9.0. Then I saw something that said I had to have OSX 10.9.0? I just want to make sure I can install this Flash Player Plug in Version 28? That is my question can I do this? Yes or No? My safari browser version is Version 6.2.8

Views

212

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Employee , Mar 05, 2018 Mar 05, 2018
Hi,You can download and install latest Flash Player from Adobe Flash Player Install for all versions page. It should work on Mac 10.8.5. However, the supported OS are mentioned on Tech specs | Adobe Flash Player .Thanks!

Likes

translate

Translate

Translate
Adobe Employee ,
Mar 05, 2018 Mar 05, 2018

Copy link to clipboard

Copied

Hi,

You can download and install latest Flash Player from Adobe Flash Player Install for all versions page. It should work on Mac 10.8.5. However, the supported OS are mentioned on Tech specs | Adobe Flash Player .

Thanks!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines