Locked

FireFox is Disabling Shockwave Flash

New Here ,
May 11, 2018 May 11, 2018

Copy link to clipboard

Copied

Firefox disables shockwave flash plugin option to "Never Active" and "Block dangerous and intrusive Flash content" option is selected while running scripts through selenium webdriver. Because of it, unable to click on Flash objects.

I have tried below options but didn't work for me.

  1. Tried manually setting shockwave flash plugin( version 29.0) option to "Always Activate" and deselected "Block dangerous and intrusive Flash content" option.
  2. Used below code in configuration file.

   3. I tried changing all the possible combinations of

  • plugins.http_https_only
  • plugins.flashBlock.enabled,

Still when my script is running, Shockwave Flash is set to "Never Activate" in Firefox quantum browser(Version:60.0) but same issue is not noticed in older versions of FireFox broswer(version:46).

Please provide solution to set shockwave Flash plugin to "Always Activate".

This post moved from Adobe Shockwave Player to Using Flash Player [Moderator]

Title edited for brevity by moderator. Was:"While Automating Websites through Selenium, FireFox(Version:60) is Disabling Shockwave Flash ( version 29.0) player because of it  Flash Objects cannot be clicked while running scripts. Please provide us solution to always enable flash player ."

Views

4.3K

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
May 12, 2018 May 12, 2018

Copy link to clipboard

Copied

meanwhile you can also contact firefox developers and post your issue there.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 14, 2018 May 14, 2018

Copy link to clipboard

Copied

This is a browser issue, not Flash Player issue.  The browser is the one that controls when to load the plugin, not Flash Player.  Please contact Firefox for assistance.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 14, 2018 May 14, 2018

Copy link to clipboard

Copied

I tried contacting Firefox developers, but i did not receive any help. so i posted the issue here also.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
May 15, 2018 May 15, 2018

Copy link to clipboard

Copied

did you try with other browsers like opera, edge?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 15, 2018 May 15, 2018

Copy link to clipboard

Copied

I need to run my scripts on latest Firefox browser only!.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 18, 2018 May 18, 2018

Copy link to clipboard

Copied

Unfortunately, this is the browser imposing restrictions in the normal operation of Flash Player.  The solution needs to come from the browser.

You might have some luck playing with options in about:config.

plugins.flashBlock.enabled seems promising, but Mozilla would be the authoritative source.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 21, 2018 May 21, 2018

Copy link to clipboard

Copied

Yes i tried with all the option of Config properties, but still Mozilla blocks the Flash player.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 22, 2018 May 22, 2018

Copy link to clipboard

Copied

Have you tried this?

Set Adobe Flash to "click to play" on Firefox | Firefox Help

Short of that, I don't have any great suggestions.

Either your testing requirements will need to change to accommodate the constraint (e.g. just pin your testbed to the last version of Firefox that allowed you to keep Flash enabled), or you'll need to change to a more flexible automation tool which can interact with the browser's security dialogs (e.g. Sikuli).

I guess there's a third option, since Firefox is Open Source.  You could build your own Firefox with a patch that disables the click to activate plug-ins feature, but that seems pretty painful, and you'd have to integrate the patch every time you want to build....

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines