Locked

Flash 27 not playing on Firefox 56 / Linux

Community Beginner ,
Oct 03, 2017 Oct 03, 2017

Copy link to clipboard

Copied

I have version 27.0 of the Flash plugin installed on Firefox 56.0 / Ubuntu 16.04.3.  It was working fine until today, but suddenly no sites with Flash (not even Adobe - Flash Player ) will display it — any Flash videos just appear as a blank space.  However, Is Flash installed? - WhatIsMyBrowser.com still says "Flash 27.0.0 is installed in this browser".

Does anyone know of a way to troubleshoot this?

Thanks!

Views

7.2K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Community Beginner , Oct 05, 2017 Oct 05, 2017
And suddenly today, Flash works again.  No idea what broke it yesterday or what fixed it today.I'll include the output of `lshw` just in case, but I don't know if it's worth pursuing when I can't reproduce the issue any more.

Likes

Translate

Translate
Adobe Employee ,
Oct 03, 2017 Oct 03, 2017

Copy link to clipboard

Copied

You can try disabling hardware acceleration in Flash Player.  If it doesn't help, please turn it back on.

https://helpx.adobe.com/flash-player/kb/video-playback-issues.html

Similarly, you should be able to disable hardware acceleration in Firefox.  Again, if it doesn't help, turn it back on.

If that doesn't work, you might try another browser (I suspect that this is a Firefox thing) like Google Chrome, just to validate that assumption.

If it *is* Firefox specific, then you might pick up a copy of the Firefox ESR.  It will be an older version of Firefox, but patched with security fixes.  If the problem goes away, you know that it was introduced by a recent Firefox version.  In that instance, you might check the Nightly version of Firefox, to see if there's already a fix in the pipeline.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 04, 2017 Oct 04, 2017

Copy link to clipboard

Copied

Thanks jeromiec83223024​.  Here are my results:

  • I couldn't find a way to disable hardware acceleration in Flash, because the logo didn't show up for me on the link you mentioned.
  • I tried disabling acceleration in Firefox, but it didn't change anything.
  • Flash does work for me in Chrome, FWIW.
  • It also works in Firefox ESR 52.4.
  • Neither the current beta (57.0b5) nor nightly (58.0a1) works.

So the mystery isn't 100% solved, but using an ESR of Firefox is a pretty good solution for now at least.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 04, 2017 Oct 04, 2017

Copy link to clipboard

Copied

Exactly the same situation, Chrome working, Firefox not.

Somewhere else they suggested to switch to Firefox-esr but of course thay is a workaround.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 04, 2017 Oct 04, 2017

Copy link to clipboard

Copied

Great, thanks.  This fits with my intuition. 

I'll spin up an Ubuntu machine this afternoon and see if I can reproduce it.

Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 04, 2017 Oct 04, 2017

Copy link to clipboard

Copied

I'm not able to reproduce this, although I *did* find and report a different Firefox bug. 

I'm guessing there's a hardware specific aspect to this.

Can you give me the system specs?  I need to go find a similar machine.

This should output them to a file called specs.txt.  You can just copy and paste the contents here.

sudo lshw > specs.txt

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 05, 2017 Oct 05, 2017

Copy link to clipboard

Copied

And suddenly today, Flash works again.  No idea what broke it yesterday or what fixed it today.

I'll include the output of `lshw` just in case, but I don't know if it's worth pursuing when I can't reproduce the issue any more.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 05, 2017 Oct 05, 2017

Copy link to clipboard

Copied

Flash still does not work for me right now but I see a pending update of:

  chromium-browser chromium-browser-l10n chromium-codecs-ffmpeg-extra cpp-5

  firefox firefox-locale-en firefox-locale-it g++-5 gcc-5 gcc-5-base

  gcc-5-base:i386 libasan2 libatomic1 libcc1-0 libcilkrts5 libgcc-5-dev

  libgfortran3 libgomp1 libitm1 liblsan0 libmpx0 libquadmath0 libstdc++-5-dev

  libstdc++6 libstdc++6:i386 libtsan0 libubsan0

So the Firefox update may fix it.......

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 06, 2017 Oct 06, 2017

Copy link to clipboard

Copied

And it did, so case solved for me

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 05, 2017 Oct 05, 2017

Copy link to clipboard

Copied

I probably should have led with "If you haven't already, completely power down the machine, then power it back on again".  It looked like a corrupted video buffer.  It's possible that an underlying driver or something was in a bad state.  If you figure out how to reproduce it, definitely let us know.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 17, 2017 Oct 17, 2017

Copy link to clipboard

Copied

LATEST

I had this same issue with Firefox 56.0, how I fixed it was in /etc/adobe/mms.cfg

EnableLinuxHWVideoDecode=0

WindowlessDisable=false

OverrideGPUValidation=true

After making these settings flash works in Firefox again.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines