Locked

Flash player doesn't work in Win 10

New Here ,
Feb 21, 2016 Feb 21, 2016

Copy link to clipboard

Copied

My flashplayer doesn't work in win10, neither in Explorer or edge. Adobe flash player is enabled in the settings, but still not working.

Does anyone know how to solve my problem

Views

1.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 21, 2016 Feb 21, 2016

Copy link to clipboard

Copied

Hi,

Could you please share more information:

What is the exact issue you are facing? Share any Flash URL site.

Please check from below link what is the Flash player version the browser has?

Thanks

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 01, 2016 Mar 01, 2016

Copy link to clipboard

Copied

HI

My version of flash is

You have version 20,0,0,306 installed

Från [xxxxxxxxxxxxxxxxxxxxxxxxxxxxx]

Skickat: den 22 februari 2016 06:56

Till: [xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx]

Ämne:  Flash player doesn't work in Win 10

Flash player doesn't work in Win 10

created by  <https://forums.adobe.com/people/Kratika+Agarwal> Kratika Agarwal in Using Flash Player -  <https://forums.adobe.com/message/8521030#8521030> View the full discussion

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Mar 04, 2016 Mar 04, 2016

Copy link to clipboard

Copied

First, confirm that ActiveX Filtering is configured to allow Flash content:

https://forums.adobe.com/thread/867968

Internet Explorer 11 and Edge introduce a number of changes both to how the browser identifies itself to remote web servers, and to how it processes JavaScript intended to target behaviors specific to Internet Explorer. Unfortunately, this means that content on some sites will be broken until the content provider changes their site to conform to the new development approach required by modern versions of IE.

You can try to work around these issues by using Compatibility View:

http://windows.microsoft.com/en-us/internet-explorer/use-compatibility-view#ie=ie-11

If that is too inconvenient, using Google Chrome may be a preferable alternative.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 10, 2017 May 10, 2017

Copy link to clipboard

Copied

I am having the same issue. I have Adobe Flash Player - Version: 25.0.0.171 I am running Win10 home Version 1703
Win10 in its latest update is blocking Flash from working on all browsers. ie, edge and chrome. I go to m.mlb.com to watch a game and get the following error message:

You have launched an event that is only accessible with Adobe Flash Player.

To watch this event, please install the latest version. Download»
If Flash is installed, please enable the Adobe Flash plugin in your browser settings. For instructions, please click here».

How do I get WIN10 to recognize Flash?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 10, 2017 May 10, 2017

Copy link to clipboard

Copied

Edge and Chrome use two completely different plugins, and they are not interchangeable.  Edge uses the embedded ActiveX Control, installed via Windows Updates.  Chrome uses the PPAPI plugin.  Google embeds Flash Player in Chrome, but you can also download and install the PPAPI plugin from adobe.com.

Most browsers these days are forcing a Flash click-to-play model, meaning Flash Player is disabled by default, or set to only 'ask sites to run Flash' and defaulting to HTML5 content.  If the content isn't coded to accurately detect Flash Player, even when it's disabled, you'll get the behaviour you're seeing instead of a message to enable the disabled Flash Palyer.

Please refer the following tech notes and help documents for enabling Flash Player:

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 10, 2017 May 10, 2017

Copy link to clipboard

Copied

For me,This is what worked

I went to chrome://flags/#enable-npapi

searched for Flash found and bingo. it worked

Run all Flash content when Flash setting is set to

And changed the condition from Default to Allow.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 10, 2017 May 10, 2017

Copy link to clipboard

Copied

Each browser has a distinct copy of Flash.  Chrome and IE/Edge each have one built in to the browser.  Firefox uses the NPAPI Flash Player, which I'm guessing that you installed at some point.

By turning on NPAPI Flash Player in Chrome, you're having that browser fall back to an older browser plugin technology that's quite a bit less secure than what would normally ship with Chrome.

I believe in the Chrome instance, if you turned enable-npapi back off, and also turned off prefer HTML over Flash, you'd probably end up with the built-in PPAPI Flash Player for Chrome working the way that you want.  (Background: Google has started making changes to how and when Flash content will run, which most websites will probably interpret as Flash not being installed.)

Anyway, what you did will certainly work, but I would not recommend it to others discovering this thread, as it walks back the last ~5 years of security work to harden the sandbox for plug-ins running in Chrome.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 10, 2017 May 10, 2017

Copy link to clipboard

Copied

What version of Chrome are you using?  The latest version (58) doesn't have chrome://flags/#enable-npapi.  Chrome dropped support for NPAPI plugins in Sept 2015 (NPAPI deprecation: developer guide - The Chromium Projects )

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 10, 2017 May 10, 2017

Copy link to clipboard

Copied

Version 58.0.3029.110 (64-bit)

Running Win10 Version 1703 build 15063.296

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 10, 2017 May 10, 2017

Copy link to clipboard

Copied

I installed Chrome 58.0.3029.110 (64-bit) on a Win 10 Version 1703 system with OS build 15063.296.  Chrome hadn't been installed on this system before.  After installation I performed the following:

  1. go to chrome://flags
  2. search for flash
  3. only 2 options:

          - Prefer HTML over Flash (#prefer-html-over-flash)

          - Run all Flash content when Flash setting is set to "allow" (#run-all-flash-in-allow-mode)

there is no #enable-npapi option.  I suspect you're referring to the 2nd option (#run-all-flash-in-allow-mode).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 10, 2017 May 10, 2017

Copy link to clipboard

Copied

LATEST

It's also possible that the legacy settings persist through upgrades, or that for some reason, the settings file isn't able to be updated by the Chrome updater (corrupted permissions, etc.).  I'm not sure how they handle it off the top of my head, but it might explain why PPAPI doesn't work. 

If this was an older version of Windows upgraded in-place to Win10 instead of a fresh Win10 install, that would fit with my intuition.

In that instance, if you're logged into your Google account with Chrome, it's backing up all of your important settings to their servers.  Simply doing an uninstall/reinstall and logging back into your account would get you to a pristine state with your settings overlaid.  Chrome installs Flash a few minutes after first launch (it helps them to distribute the load across their content distribution network), so you'd probably want to do the reinstall, fire it up, give it ~10 minutes, and then give that Flash content a shot again.

Also, the advice about the prefer html over flash flag would still apply.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines