Locked

flash player on opera 49 does not work

New Here ,
Nov 20, 2017 Nov 20, 2017

Copy link to clipboard

Copied

i have been using opera with my flash player for months without a bug or problem. with the last uptade it started not to work. in some sites, there is a puzzle icon and it says "click here to activate adobe" and when i click nothing happens. i looked out for some fixes but could not find anything. and also my opera lets adobe work in any site. anyone know how to fix the bug?

[moderator: added opera version to title]

TOPICS
Browser, Product issue

Views

26.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 20, 2017 Nov 20, 2017

Copy link to clipboard

Copied

Same thing here, I have used Opera and loved it for FB games. Today, I went to play one of my FB games and it won't run, keeps telling me I need Flash 11.5 or higher. I followed the Adobe site for downloading the most current Flash version for Opera, even uninstalled and rebooted my computer and no matter what I have found no solution as to why Opera doesn't see Flash installed. Even the Adobe site when I check what my current version is says it isn't installed or isn't enabled. I tested Firefox and have same issue there. Only can get my flash based game to play in Chrome that has a built in Flash. Would love to find a solution as I love Opera over Chrome.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 22, 2017 Nov 22, 2017

Copy link to clipboard

Copied

Same situation over here. And I tried with both Opera and Chrome but any of them run the applications. I was trying to use Pixlr Express Online, and Adobe Flash Player insists that I need to download the recent version. I installed it and reebot my computer but it dosn't work. If someone knows how to fix this, please, help!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 22, 2017 Nov 22, 2017

Copy link to clipboard

Copied

Same got last update yesterday, now it doesn't work.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 22, 2017 Nov 22, 2017

Copy link to clipboard

Copied

Flash is not working. It's installed, yet none of my browsers recognize it; Opera, Vivaldi (chromium) and Edge. Adobe link to "test" if it is installed says that it is NOT installed. I've installed it several times with no problems with installation. Revo and Windows 10 both show it as being installed.. version 27. I use it every day for HBOGo, and other streaming news sites. None of them work today.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 22, 2017 Nov 22, 2017

Copy link to clipboard

Copied

As each of the major browsers moves to make Flash Player click-to-play by default, you're going to see an increasing amount of friction when trying to use content that depends on Flash Player.  For ~15 years, that content has also safely been able to assume that if Flash Player wasn't available, that it wasn't installed.  That's no longer the case, so expect some bad guidance from websites.

Here's some general guidance on how to enable Flash Player in various browsers:

Use or fix Flash audio & video - Computer - Google Chrome Help

Adobe Flash Player enabled but not recognized in Windows 10 Edge

Enable Flash Player for Firefox

Opera 29 also seems to have pushed out some click-to-play stuff.  We don't work closely with them like we do with the Edge and Chrome teams, but it looks very much in line with what Chrome is doing.  I'm assuming that they just inherited the functionality from the Chromium project, since modern Opera is based on Chromium.

Short of that, there's not really enough detail (like operating system and version) for me to figure out what's going on.  It sounds like folks are having some distinct problems, but there's not enough detail to give you more personalized advice.  I can say that Opera 49.0.2725.39 with Flash Player 27.0.0.187 works fine on MacOS 10.12.6.  I'd be happy to look at other configurations as well, but narrowing that universe of possibilities would be pretty helpful.

I'd encourage each of you to try the guidance above, and if you're still stuck, starting a new thread that includes the following details:

https://forums.adobe.com/thread/1195540

This will allow us to give you each personalized advice.  Otherwise, I'm pretty sure that this is just going to be generally confusing for everyone on the thread.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 22, 2017 Nov 22, 2017

Copy link to clipboard

Copied

It looks like the problem may be related to Windows Creators update, at least in my case. Following the instructions from https://forums.adobe.com/thread/2340228​, I was able to get Edge working. Steps for Edge don't seem to apply to Opera or Vivaldi, and I haven't figured out how to re-enable Flash Player in either of those browsers. Settings in both browsers show Flash Player as enabled.

EDIT: I just noticed that the Creators Update referred to in the link above was from May. I just received the FALL Creators Update (build 1709) a couple days ago.

Windows 10 (64 bit)Pro, V. 1709, Build 16299.64; Opera 49; Vivaldi 1.13

Revo shows Flash Player is installed.

Capture 2.PNG

Adobe Flash Player Help says it isn't

Opera.JPG

Attempting to stream video indicates it either isn't installed, or it's disabled.

MSNBC no flash.JPG

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 22, 2017 Nov 22, 2017

Copy link to clipboard

Copied

Ok. sorry for posting with a bad formatting

I read other questions and found that my case is the same as: https://forums.adobe.com/thread/2409413

So it seems obvious that the problem it's on Opera's side.

We'll have to wait for them to fix that problem.

In that  thread there's this post: https://forums.adobe.com/message/9985636#9985636

Surprisingly it fixed the problem for me. It seems totally unrelated but it worked, so if you have the same problem you can try it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 22, 2017 Nov 22, 2017

Copy link to clipboard

Copied

Yeah, Opera is a fork of Chromium, so they're just inheriting all of this stuff from Chrome.  I think this all got rolled in when they pushed Opera 49.

The Chrome guidance should apply well:

Use or fix Flash audio & video - Computer - Google Chrome Help

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 26, 2017 Nov 26, 2017

Copy link to clipboard

Copied

My fix was simple. After exhausting everything i had been told to try and nothing helped i decided to try something myself.

I uninstalled Opera 50 and then went into programs files (x86) and deleted the opera folder. Went into user appdata and deleted all Opera folders. Next i downloaded Opera 47 from Index of /pub/opera/desktop/  and reinstalled.    Working fine now with flash. now i can do facebook games again.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 14, 2017 Dec 14, 2017

Copy link to clipboard

Copied

The autoupdate i had to turn off under opera://flags scroll down find updates and disable it. using opera 39 beta now with update turned off, flash installed and working great on windows 7 64bit

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 07, 2017 Dec 07, 2017

Copy link to clipboard

Copied

I found a way to make it work, but it is a bit of a pain.

You need to go in the Settings for Opera.

In the search field, search for Flash.

Click on Manage exceptions and then you need to input the address of the web site you want to be permitted to run Flash.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Dec 08, 2017 Dec 08, 2017

Copy link to clipboard

Copied

Yes that is correct.  We are in the process of updating the Enable Flash Player for Opera document with the instructions for the latest version of Opera.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 08, 2017 Dec 08, 2017

Copy link to clipboard

Copied

I had the same problem, will be glad when Opera for PC fixes that!  But in the meantime, this works for me.  I do have the latest version of Adobe Flash Player installed.  In Opera:

Menu >> Settings >> Websites >> Flash

Make sure "Ask first before allowing sites to run Flash" is chosen. Which is a very annoying choice but only option that allows flash. So, then I clicked the "Manage exceptions" button beneath. In the window that opened I added:  [*.]com  and picked "Allow". After that flash would work in the Opera PC version, without prompting me for websites ending with .com

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 09, 2017 Dec 09, 2017

Copy link to clipboard

Copied

Your suggestion for Flash Player on Opera worked perfect. [*.]com

Thank you very much..

Kay

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 09, 2017 Dec 09, 2017

Copy link to clipboard

Copied

For Chrome it has the same problem as Opera, after last update Flash don't work in it for me either. Click the left-hand 3-dot menu option >> Settings >> In "Search settings" type in "Flash" >> That will show a menu pointing out "Content settings" lower on the list >> Open "Content settings" >> Look for "Flash" and open that >> Make sure "Ask first" is chosen (it never does ask first for me but it needs to be chosen as only option to run it) >> then a little further down under "Allow" click on "Add" >> Add this:  [*.]com  >> Then click on the "Add" button. >> Close Chrome and reopen, then Flash should play on most websites that end with a .com

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 11, 2018 Jan 11, 2018

Copy link to clipboard

Copied

Nothing has worked for me.  I put in that [*.]com on both Chrome and Opera and it did not fix the problem.  I have downloaded both versions of Adobe for both FF and Opera and Chrome.  I can play FB games on Chrome, but not on Opera.  I have uninstalled and reinstalled Adobe and updated Opera to the latest 50 something version.  I have tried everything suggested in every thread I have read and I can get flash to work in every other browser but Opera.  Works in Chrome and Firefox, just not Opera.  If there are any other tips not mentioned, please let me know and I will try those.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 12, 2018 Jan 12, 2018

Copy link to clipboard

Copied

@RockyMtnHiker

I am investigating the issue you posted at Still Cannot Get Flash to Work in Opera for FB Games and will reply there.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 09, 2017 Dec 09, 2017

Copy link to clipboard

Copied

Try this:

Settings

Websites

Flash - manage exceptions - in the box type in [*.]com  allow.

This worked great for me.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 13, 2018 Feb 13, 2018

Copy link to clipboard

Copied

LATEST

I tried this and it worked;

1. Go to settings on Opera.

2. Click on Websites.

3. Click "Manage Exceptions" under Flash

4. Paste the URL of the site and change behavior to allow

Site should load with flash working

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines