Locked

Flash Player with Chromium 61, MAC OSX 10.9.5

New Here ,
Jun 25, 2017 Jun 25, 2017

Copy link to clipboard

Copied

Hi,

I am trying to make flash running since a long time on my Chromium on MAC OS X. But it doesn't work. I tried a lot of forums and instructions.

Situation now:

- I deinstalled all the Chromium data of my MAC OS X 10.9.5

- I installed the newest Chromium version 61.0.3141.0

- I installed the newest Flash on my MAC, NPAPI-Plug-In-Version 26.0.0.131, PPAPI-Plug-In-Version 26.0.0.131

What I have tried:

A. I activated flash in the Chromium-Settings

B. I tried to activate flash over this link: https://www.macromedia.com/support/documentation/en/flashplayer/help/settings_manager02.html

C. I tried the instruction of Julia Casado in this discussion https://groups.google.com/a/chromium.org/d/msg/chromium-discuss/ftGxvj9TcjE/WWzLt1qGEAAJ Does not chance nothing.

D. I tried the steps on the following websites:

D.1: https://helpx.adobe.com/flash-player/kb/flash-player-chromium.html

D.2: https://helpx.adobe.com/en/flash-player/kb/enabling-flash-player-chrome.html

D.3: https://support.google.com/chrome/answer/6258784?hl=en

and some more...

Things that are strange:

1. If I go to "chrome://version/" I have the following Information about Flash:

"26.0.0.131 /Library/Internet Plug-Ins/PepperFlashPlayer/PepperFlashPlayer.plugin"

But I want to use the normal Flash of Adobe via PPAPI. I don't now why it ist that strange. Also this folder does not exist in my MAC, the Folder "Internet Plug-Ins" is empty. Maybe I just have to fix this, but I don't know how.

2.  If I go to "chrome://components" I have no entry with Adobe Flash or similar things. But there should be something like that. (Because of the new version, I can not use chrome://plugins). Why is Chromium not finding the Flash Plugin?

3. If I go in MAC OS X to the Flash Plugin, it says, that the settings are only for Safari and not for Chromium. I should klick this link to get more info: https://helpx.adobe.com/en/flash-player/kb/changing-flash-player-settings-chrome.html But this link does not help me.

So, maybe someone can help me, or give me hints to solve my problem.

Thank you!

Timothy

[moderator: edited title, adding os/browser versions]

Views

4.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 27, 2017 Jun 27, 2017

Copy link to clipboard

Copied

Most of the resources you reference are old and no longer applicable to the latest version of Chrome/Chromium

But I want to use the normal Flash of Adobe via PPAPI

What do you mean by this?  what is "the normal Flash of Adobe via PPAPI" you are referring to?

"26.0.0.131 /Library/Internet Plug-Ins/PepperFlashPlayer/PepperFlashPlayer.plugin"

But I want to use the normal Flash of Adobe via PPAPI. I don't now why it ist that strange. Also this folder does not exist in my MAC, the Folder "Internet Plug-Ins" is empty

This is referring to the system /Library directory, not the users ~/Library directory.  If the /Library/Internet Plug-ins is empty Flash isn't installed.  In Finder menu click Go > Go to Folder... in the 'Go to Folder:' window enter /Library and click Go. Finder will launch to the /Library directory.  Scroll down to Internet Plug-ins directory

Try the following:

  1. Launch Chromium and go to the website you wish to view Flash content at
  2. To the left of the web address, click the icon you see: Lock Lock, Info Info, or Dangerous Dangerous.
  3. Next to "Flash," click the Arrows .
  4. Select "Always allow on this site."
    • Note that this setting is enabled Flash for this particular site, not any other site.  If Flash isn't working on some other site, you'll need to repeat this for that site and add the site to the list of sites to allow Flash (chrome://settings/content > Flash)
  5. Restart the browser

Does Flash content display?  If not, try the following:

  1. Launch Chromium and navigate to chrome://flags/#prefer-html-over-flash
  2. This flag is most likely set to Default, change it to Disable
  3. Click the RELAUNCH NOW button at the bottom of the page

Does Flash content display?

This last option (chrome://flags) is a last resort.  Enabling Flash per site should work. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 28, 2017 Jun 28, 2017

Copy link to clipboard

Copied

Hi,

thank you for your answer.

m_vargas  schrieb

This is referring to the system /Library directory, not the users ~/Library directory.  If the /Library/Internet Plug-ins is empty Flash isn't installed.  In Finder menu click Go > Go to Folder... in the 'Go to Folder:' window enter /Library and click Go. Finder will launch to the /Library directory.  Scroll down to Internet Plug-ins directory

Okay, my mistake. If I go to HDD/Libary/Internet-Plugins I have a lot of programs. Including "Flash Player.plugin" and "flashplayer.xpt". In the folder "PepperFlashPlayer" are the files "manifest.json" and "PepperFlashPlayer.plugin".

Try the following:

  1. Launch Chromium and go to the website you wish to view Flash content at
  2. To the left of the web address, click the icon you see: Lock Lock, Info Info, or Dangerous Dangerous.
  3. Next to "Flash," click the Arrows .
  4. Select "Always allow on this site."
    • Note that this setting is enabled Flash for this particular site, not any other site.  If Flash isn't working on some other site, you'll need to repeat this for that site and add the site to the list of sites to allow Flash (chrome://settings/content > Flash)
  5. Restart the browser

I tried both. No change, it does not work. I tried also to manipulate the settings in different way, but nothing worked so far.

m_vargas  schrieb

Does Flash content display?  If not, try the following:

  1. Launch Chromium and navigate to chrome://flags/#prefer-html-over-flash
  2. This flag is most likely set to Default, change it to Disable
  3. Click the RELAUNCH NOW button at the bottom of the page

Does Flash content display?

This last option (chrome://flags) is a last resort.  Enabling Flash per site should work. 

I tried this as well. No change.

I really don't get the problem. What is the problem? I deinstalled all the components completely and installed them again. And I have the newest versions.

Are there any programs that can supress the flash just in Chromium? In Safari everything works fine, but I don't want to use this program...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 30, 2017 Jun 30, 2017

Copy link to clipboard

Copied

The long and short of it is that we test and support Google Chrome. 

This usually means that Flash Player works as expected in the context of Chromium, but with the recent addition of changes to Chrome and Chromium that affect how Flash Player gets launched, it's very possible that there are bugs (particularly in the context of constantly-changing restrictions and related user-interface support).  Those bugs are in Chromium. 

You can report bugs in Chromium over at:

Issues - chromium - An open-source project to help move the web forward. - Monorail

You might also look at the Chromium forums to see if there's any guidance over there.

Normally, I'd offer to just file the bug on your behalf, but Adobe's office are closed all next week.  We'll have a skeleton crew for another week while people tack on their regular vacation days to the mandatory week off, and we'll be playing catch-up.  It's probably going to be a couple weeks before I can get to it once we're back, and I don't want to leave you hanging (especially when it isn't our product misbehaving).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 25, 2017 Oct 25, 2017

Copy link to clipboard

Copied

LATEST

It looks like you need to launch Chromium from the commandline to use Flash Player now.  This works for me.

~/Downloads/chrome-mac/Chromium.app/Contents/MacOS/Chromium --ppapi-flash-path=/Library/Internet\ Plug-Ins/PepperFlashPlayer/PepperFlashPlayer.plugin/Contents/MacOS/PepperFlashPlayer --ppapi-flash-version="27.0.0.183"

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines