Locked

Flash preventing fitbit.com from working properly

New Here ,
Sep 27, 2017 Sep 27, 2017

Copy link to clipboard

Copied

Using

Google Chrome is up to date

Version 61.0.3163.100 (Official Build) (64-bit)

OS X El Capitan Version 10.11.6

MacBook Air

When I go to https://www.fitbit.com/foods/log I get the attached report.Screen Shot 2017-09-27 at 16.33.22.png

I am using the latest Flash and have enabled https://www.fitbit.com/foods/log  in Chrome. Any answers to what I should do ? This doesn't happen in Firefox.

Views

391

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 27, 2017 Sep 27, 2017

Copy link to clipboard

Copied

Hi,

I logged onto https://www.fitibit.com/foods/log and do not see the puzzle piece in the address field:

Screen Shot 2017-09-27 at 9.19.39 AM.jpg

Please go to chrome://settings/content/flash and post a screenshot of the Flash settings.

Google's https://support.google.com/chrome/answer/6258784 support page may also be of assistance.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 27, 2017 Sep 27, 2017

Copy link to clipboard

Copied

Screen Shot 2017-09-27 at 20.02.49.png

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 27, 2017 Sep 27, 2017

Copy link to clipboard

Copied

Screen Shot 2017-09-27 at 20.05.46.png

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 27, 2017 Sep 27, 2017

Copy link to clipboard

Copied

Thank you for the screenshots.

In chrome://settings/content/flash, move the 'Ask first' setting to the right (it'll turn blue, like the one above it). Reload the browser.  Does this change fix the problem?

<edit>

For more information on these Flash settings in Chrome, see Google's support document https://support.google.com/chrome/answer/6258784

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 27, 2017 Sep 27, 2017

Copy link to clipboard

Copied

For what it's worth, this works fine on my machine.  (MacOS 10.12.16 and Chrome Version 61.0.3163.100 (Official Build) (64-bit).

I did notice that the blocked plugin icon consistently gets displayed on this page.  I think that even when authorized, it's still blocking some of the analytic and tracking stuff on FitBit's page that uses Flash.  This is by design (see Google's Plug-In Power Saver and PPS Tiny features for details).

That said, the graph loads and populates for me.  I'm not sure why you're getting a different experience.  Do you have a third-party plug-in that might be causing problems?  (Ad-blocker, anti-tracking utility, etc?)  If you just installed Chrome for the first time, it takes several minutes to download the Flash plug-in on first launch.  I don't have a good theory as to why we're having different experiences.  I reset my Chrome installation to default to rule out any magic flags that I might have enabled.

Also, just to be clear, this isn't Flash Player breaking anything.  This is Chrome intentionally preventing Flash Player from launching normally.  This in turn invalidates assumptions that some content makes about Flash Player being either readily available or not installed.

As the major browsers move Flash Player to exclusively click-to-play status, they all have a different implementation, and they all have imperfections.  Experimenting with the available browsers is probably going to be something that you'll have to do more and more.  While we can refer this information over to the folks at Chrome, we don't have any direct control over a situation where the browser prevents us from launching.

The intent on the part of the browser vendors is to really force content providers to move to exclusively HTML and JavaScript.  By increasing friction for consumers using Flash, the goal is to generate complaints sufficient to encourage content providers like FitBit to make that migration.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 28, 2017 Sep 28, 2017

Copy link to clipboard

Copied

Thanks jeromiec and m_vargas. I have unticked adblock for the site and have moved the slider to Ask first. Unfortunately there seems to be some problem with the site itself at the moment so can't check if the suggested changes have worked but will try later and let you know. I have also been getting a warning saying the adobe flash isn't installed, which obviously is.f1.pngf2.pngf3.png

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 28, 2017 Sep 28, 2017

Copy link to clipboard

Copied

Yeah, the vast majority of websites are going to be written under the assumption that Flash Player is either available, or it's not installed.

That situation has changed in the context of all of these recent browser changes, but every single website on the planet would need to update their content to handle this uncertainty in a more nuanced way.  That's simply not going to happen for a large subset of content currently on the web.

For what it's worth, I have Always Ask disabled.  I think it was your ad blocker in play, but we won't know until you can retry against a working site. 

I'm also curious if simple Flash content works for you, like http://www.homestarrunner.com/

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 28, 2017 Sep 28, 2017

Copy link to clipboard

Copied

Screen Shot 2017-09-28 at 19.30.39.pngCheers jeromiec. I'm still waiting for Fitbit to get back to normal, there was an (unasked for by me) update today but that went wrong at their end ! I tried homestarrunner and got this:

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 28, 2017 Sep 28, 2017

Copy link to clipboard

Copied

Just added homerunner,com to content and that now works !

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 28, 2017 Sep 28, 2017

Copy link to clipboard

Copied

Okay, so we know that Flash Player is installed and working on your machine (at least under the right circumstances).  I think that if you disabled Always Ask, you wouldn't encounter that prompt, unless you want to authorize individual websites.

At the point that FitBit's service is stable again, it *should* work, but you might have an extension in play that prevents the content from loading.  Since it's working for me on a very similar config, I'm pretty sure that Chrome's click-to-play logic works right in the FitBit scenario.  You might try clearing your browser cache too, as you may not be picking up the most current changes on FitBit's website.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 28, 2017 Sep 28, 2017

Copy link to clipboard

Copied

Thanks, will try it when fitbit working ok again. Just realised that the problem is only when I go from Dashboard on the fitbit home site for users to the Log.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 29, 2017 Sep 29, 2017

Copy link to clipboard

Copied

Unfortunately it didn't work, still get plugin blocked when I go to the Log page. The whole thing seems to be going very slow so it could I suppose be something with the Fitbit site.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines