Locked

Flash settings won't go away, no matter how much you click "Allow" or "Deny"

New Here ,
Jun 22, 2017 Jun 22, 2017

Copy link to clipboard

Copied

Has anyone else seen in Mac OS where every time you go to a new Flash site, the Flash settings panel comes up with "Allow" and "Deny," and it freezes the browser window/tab. No amount of clicking on "Allow" or "Deny" makes it go away, ever. I've reinstalled Flash several times, nothing fixes it. help, please?

This happens in the latest version of all browsers in Mac OS - Safari, Chrome, Firefox (I have all as I'm a Web Developer and need them for testing).

I'm on a Mac Pro, 3.5 GHz 6-Core Intel Xeon E5, 16 GB RAM, Mac OS Sierra 10.12.5, Adobe Flash version 26.0.0.131 both NPAPI & PPAPI (as I have all browser for testing), Safari v.10.1.1 (12603.2.4), Google Chrome v.59.0.3071.109 (Official Build) (64-bit), and Firefox v.54.0 (64-bit).

Any help that could be offered would be most appreciated.

best,

—  faddah

     portland, oregon, u.s.a.

Screenshot 2017-06-22 10.39.46.png    

TOPICS
Performance, Product issue

Views

3.3K

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 28, 2017 Jun 28, 2017

Copy link to clipboard

Copied

This is Flash Player's anti-clickjacking logic being overzealous.  When we show permission dialogs, we need to know that they're not obscured by other content on the page.  Because we're a plug-in, and not the host browser, this problem is ugly. 

In essence, what we do is sample the pixels where the dialog is displayed and we check to see that they match our expectations about what *should* be there.  This is imperfect (and fixing it tends to be a game of whack-a-mole -- we make a change for one configuration, and it breaks three others), and it's particularly problematic if the dialog pops up over the top of anything moving, like video.

The best way to deal with it is to just avoid having the dialog pop up in the first place.  If you go to Settings > Flash Player > Storage, and choose "Allow Sites to Store Information On This Computer", you won't run into the dialog.  Blocking local storage with Flash Player doesn't really buy you anything in terms of privacy in 2017, and you're far, far better off using your browser's private browsing mode (in combination with a trustworthy VPN service) if you're worried about your online footprint.  Efforts by browsers to deprecate Flash Player mean that advertisers and other entities engaged in tracking your online habits have largely shifted away to much more powerful capabilities offered directly through HTML5 and JavaScript, and server-side tracking by your ISP (thank your congressional representative for that).  Good times.

Hope that helps!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines