Locked

Global Security Settings Not Saving in IE11

New Here ,
Sep 13, 2017 Sep 13, 2017

Copy link to clipboard

Copied

I am working in IE 11 ver 11.0.45 on Windows 10.  I am trying to play a  SWF files that are located locally.  In the past  i have entered Adobe - Flash Player : Settings Manager - Global Security Settings panel and was able to save the location of the files and it will then run the files.  Now, if i leave the settings page open and then try to open a swf file, it will open correctly and play, however, if i close the browser and then try to open the swf file, it will not play.  Shockwave Flash is enabled under the Manage Add-ons of IE.  The date and version of the shockwave flash object is Version 27.0.0.130 with a date of September 2, 2017.  How am i able to save the files' location so I don't have to keep on allowing the files to run?

Views

1.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 13, 2017 Sep 13, 2017

Copy link to clipboard

Copied

The online settings manager is for PPAPI plugin (used by Chrome and chromium-based browsers).  You should use the Local Settings Manager in the Control Panel.


For more information on loading local swf content, see the 'Disabling local-with-filesystem access in Flash Player by default' section in Release Notes Flash Player 23 AIR 23​.  This includes instructions on allowing local content using the Local Settings Manager.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 14, 2017 Sep 14, 2017

Copy link to clipboard

Copied

Thank you for that.  I have added it in the local settings, however, it will play one of the files and then it will loose the setting.  I have tried on a different computers, both with Win 10 and they are doing the same thing.  The settings to allow the local files to run do not stay.  Is there anything else i might check?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 14, 2017 Sep 14, 2017

Copy link to clipboard

Copied

We disabled local-with-filesystem access in Flash Player by default a couple versions ago.  The local-with-filesytem sandbox was intended to allow SWFs to access the local filesystem, but prevent them from sending data to remote servers.

The local filesystem stuff really came about to support online help systems on CD-ROMs, and had some fundamental flaws.  In the context of the modern web, it's a behavior that needed to be retired.

You can re-enable this legacy behavior by setting the EnableInsecureLocalWithFilesystem flag in mms.cfg, which should make the bevhaior persist.

See the Flash Player System Administrator's guide, pp. 24, 29 for details:

http://wwwimages.adobe.com/content/dam/acom/en/devnet/flashplayer/articles/flash_player_admin_guide/...

That said, if you can avoid this, it's a good idea.  If your use of local SWFs is limited to trusted content, it's probably not a problem.  If you're running anonymous, potentially malicious content (like SWF-based games from a torrent site), you should really think about the implications before deciding to flip that switch.

If you're a developer, you're way better off running a local webserver and doing your development and testing in a configuration that reasonably represents your staging/production environment, as you won't get late breaking surprises around cross-domain security restrictions that might not be in play when you're accessing all of your resources as destinations on the same local filesystem.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 16, 2017 Nov 16, 2017

Copy link to clipboard

Copied

I am using IE 11 and for some reason the global settings are not getting saved. I am an admin on the PC.

I went to control panel and added the website.

Not sure what the issue is. Any suggestions?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 22, 2017 Nov 22, 2017

Copy link to clipboard

Copied

LATEST

Please upgrade to the latest version (27.0.0.187) and see if that resolves it for you.  I'm pretty sure that it's fixed now.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines