Locked

I can't get flash player to work in Safari.

Community Beginner ,
Sep 21, 2017 Sep 21, 2017

Copy link to clipboard

Copied

Everything is up to date. I've removed and re-installed flash player with no luck. I'm trying to use HBONow which worked up until a few days ago. Chrome & Firefox work fine. I've tried all the 'fixes' posted, checked my versions etc. but still with no luck. I keep getting the message 'Can't play vide. The latest Adobe Flash Player must be installed and enabled in your browser.' I've enabled flash, and double & triple checked that it's enabled. Can someone please help, this is getting really frustrating!

MacBook Pro, 2 months old, 10.12.6.

Safari Version 11.0 (12604.1.38.1.7)

Adobe Flash Player Version 9999.3.183.75

TOPICS
Browser, Product issue

Views

39.0K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Sep 22, 2017 Sep 22, 2017

Copy link to clipboard

Copied

I encountered very similar problems, I haven't got a Mac here to give you the steps, but there are some plugin security settings in Safari that you can set to either block flash entirely, allow it for specified sites, or prompt...

Pretty sure there are some settings in Preferences to specifically allow Flash for specific sites.

Also, not sure if you've tried this;

Enable Adobe Flash Player for Safari

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 22, 2017 Sep 22, 2017

Copy link to clipboard

Copied

Apple changed (yet again) the Flash Player settings in Safari 11.  We're in the process of updating the Enable Adobe Flash Player for Safari tech note with the Safari 11 behaviour.  Flash is still disabled (off) by default, but the settings location has changed:

  1. Open Safari, and choose Safari > Preferences
    Picture1.png
  2. Click the Websites tab and scroll down to the Plug-ins section.  Locate the Adobe Flash Player entry
    Picture2.png
  3. Click the check-box to enable Flash Player.
    Picture3.png
  4. For ‘When visiting other websites’ setting, select the option of your choosing: Ask, Off, or On
    Picture4.png
  5. Flash can also be configured for individual websites (domains).  For each website appearing in the ‘Allow websites to use this plug-in with the settings below:’ section, choose: Ask, Off, or On
    Picture5.png
  6. Exit out of Preferences when finished configuring Flash Player.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 22, 2017 Sep 22, 2017

Copy link to clipboard

Copied

I've already tried all of these and it's still not working. I've tried setting it to Ask but it asks me & then says I need to install the latest version!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 25, 2017 Sep 25, 2017

Copy link to clipboard

Copied

katesviolin

Please post the direct link to the site you are having problems with.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 25, 2017 Sep 25, 2017

Copy link to clipboard

Copied

It's hbonow.com. I can't give you the direct link because you have to log in.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 25, 2017 Sep 25, 2017

Copy link to clipboard

Copied

I later downloaded Flash using the Firefox browser. It worked just like it was supposed to. I suppose now that I have flash properly downloaded, it would probably work with any browser, but I don't know.  Anyway, I am out of the discussion. Thanks.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 26, 2017 Sep 26, 2017

Copy link to clipboard

Copied

Thank you.  I'll notify the licensing team.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 25, 2017 Sep 25, 2017

Copy link to clipboard

Copied

That looks great, except that I do not see an option for flash, only silverlite

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 25, 2017 Sep 25, 2017

Copy link to clipboard

Copied

@edwardw87310994

If you do not see Flash Player in the plug-ins section, it would suggest Flash Player is not installed.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 25, 2017 Sep 25, 2017

Copy link to clipboard

Copied

I think I just fixed the problem. Downloaded Firefox and see the xfinity videos that I was trying to get just fine! Never liked Safari that well anyway

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Jan 10, 2018 Jan 10, 2018

Copy link to clipboard

Copied

Same problem here. None of the answers here solved it. Installed Flash, activated it for all sites, still no video in Safari.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 10, 2018 Jan 10, 2018

Copy link to clipboard

Copied

Please see if Remove restrictions on Flash content playing in Safari works for you.  If not, provide the following:

  • Mac OS version
  • Safari version
  • direct link to content that is not working.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 24, 2018 Feb 24, 2018

Copy link to clipboard

Copied

I've done this and still not working.

Mac OS 10.13.3

Safari Version 11.0.3

EDIT [link removed by moderator]

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 27, 2018 Feb 27, 2018

Copy link to clipboard

Copied

Hi,

A moderator removed the link you provided.  Please private message it to me.  To send a private message, click on my user_name link and then on the 'Message' button link.  For reference, include a link to this discussion topic.

Thank you.

--

Maria

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Feb 28, 2018 Feb 28, 2018

Copy link to clipboard

Copied

I think there might be an issue with the Flash detection on that site.  It appears to be completely ignoring the Flash content.  I tested on several different browsers, white-listing all sites for Flash on the various browser's and he behaviour is the same.  I recommend contacting the content owner for assistance.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 05, 2018 Mar 05, 2018

Copy link to clipboard

Copied

LATEST

I am having the same problem and can not figure it out

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines