Highlighted

Opera browser updated and now I can't get flash player to install

Community Beginner ,
Nov 09, 2017

Copy link to clipboard

Copied

My opera browser had an update and now that I have rebooted the computer the flash player does not work and I get a message that I need to install flash player when I go to facebook to play one of the games I get a message stating that I need to update/install Adobe Flash to enable my Flash Player Experience.

I have gone to the Adobe Flash Player Install for all versions and tried installing that version, but I still get the same message and if I go to  Flash Player Help to check to see if it is installed it says that it is not installed on my computer.  (it also states that I am running windows 8 but my system is windows 10 now).

I have followed the steps to make sure that it is enabled in Opera and that is not the problem.

I have gone to Adobe Flash Player Install for all versions to download the player from there and do that install and it too has been unsuccessful. 

I have tried uninstalling and then installing the player multiple times.  I have used the uninstaller that I found at Uninstall Flash Player for Windows and then followed the steps there - but I was unable to delete all the files found in C:\Windows\system32\Macromed\Flash so I renamed the folder to flash.old

I am not sure exactly what is meant for the next step  (am I supposed to delete those files / folders as well?)

Follow steps a, b, and c for the following:
C:\Windows\SysWOW64\Macromed\Flash
%appdata%\Adobe\Flash Player
%appdata%\Macromedia\Flash Player

I have also followed the steps I found at https://forums.adobe.com/thread/2283833

I have also tried the download found at http://labs.adobe.com/downloads/flashplayer.html

Download Adobe Flash Player 28 Beta for Desktops - Adobe Labs

After uninstalling the program - both with the uninstaller or from control panel, I am rebooting the computer, then installing the download and the browser is not open while doing this.   I have then opened the browser and checked to see if it is installed by going back to Flash Player Help  and it still shows as not being installed.  I have then tried again but rebooting the computer after the install and then checking with the same results.  I have even disabled my anti-virus program during the install and that has not helped.

I have been trying for the past 3 hours to get the darn flash player to install and work with no luck at all.  It is showing as being installed in Control Panel     Programs and Features.    

I have tried the 3 different downloads

flashplayer27pp_fa_install

flashplayer27pp_hc_install

install_flash_player_ppapi

but nothing is working.  Below are the screen shots that may or may not help

flash not installed.JPG

opera settings for flash.JPG

programs and features.JPG

sys wow folder.JPG

sys32 macromed flash.JPG

Topics

Download install

Views

29.5K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Opera browser updated and now I can't get flash player to install

Community Beginner ,
Nov 09, 2017

Copy link to clipboard

Copied

My opera browser had an update and now that I have rebooted the computer the flash player does not work and I get a message that I need to install flash player when I go to facebook to play one of the games I get a message stating that I need to update/install Adobe Flash to enable my Flash Player Experience.

I have gone to the Adobe Flash Player Install for all versions and tried installing that version, but I still get the same message and if I go to  Flash Player Help to check to see if it is installed it says that it is not installed on my computer.  (it also states that I am running windows 8 but my system is windows 10 now).

I have followed the steps to make sure that it is enabled in Opera and that is not the problem.

I have gone to Adobe Flash Player Install for all versions to download the player from there and do that install and it too has been unsuccessful. 

I have tried uninstalling and then installing the player multiple times.  I have used the uninstaller that I found at Uninstall Flash Player for Windows and then followed the steps there - but I was unable to delete all the files found in C:\Windows\system32\Macromed\Flash so I renamed the folder to flash.old

I am not sure exactly what is meant for the next step  (am I supposed to delete those files / folders as well?)

Follow steps a, b, and c for the following:
C:\Windows\SysWOW64\Macromed\Flash
%appdata%\Adobe\Flash Player
%appdata%\Macromedia\Flash Player

I have also followed the steps I found at https://forums.adobe.com/thread/2283833

I have also tried the download found at http://labs.adobe.com/downloads/flashplayer.html

Download Adobe Flash Player 28 Beta for Desktops - Adobe Labs

After uninstalling the program - both with the uninstaller or from control panel, I am rebooting the computer, then installing the download and the browser is not open while doing this.   I have then opened the browser and checked to see if it is installed by going back to Flash Player Help  and it still shows as not being installed.  I have then tried again but rebooting the computer after the install and then checking with the same results.  I have even disabled my anti-virus program during the install and that has not helped.

I have been trying for the past 3 hours to get the darn flash player to install and work with no luck at all.  It is showing as being installed in Control Panel     Programs and Features.    

I have tried the 3 different downloads

flashplayer27pp_fa_install

flashplayer27pp_hc_install

install_flash_player_ppapi

but nothing is working.  Below are the screen shots that may or may not help

flash not installed.JPG

opera settings for flash.JPG

programs and features.JPG

sys wow folder.JPG

sys32 macromed flash.JPG

Topics

Download install

Views

29.5K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Employee ,
Nov 09, 2017

Copy link to clipboard

Copied

Thank you for providing the detailed information.  It's very helpful.  Please provide the following information:

  • Opera browser version
  • direct (exact) link to the content that is not playing.

Thank you.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Nov 09, 2017

Copy link to clipboard

Copied

Information on the Opera Browser is : Version:49.0.2725.34 (PGO) - Opera is up to dateUpdate stream:StableSystem:Windows 10 64-bit (WoW64)

Exact link showing that flash player is not playing is  https://apps.facebook.com/forbiddengarden/?fb_source=bookmark&ref=bookmarks&count=9&fb_bmpos=_9  as well as   https://apps.facebook.com/klondikegame/?fb_source=bookmark&ref=bookmarks&count=4&fb_bmpos=_4

If I go to Flash Player Help it states that it is not installed or not enabled but I have checked the settings as directed.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Nov 09, 2017

Copy link to clipboard

Copied

I forgot to ask which Windows 10 OS version you have.  Took a guess and tested with Windows 10 Home Version 1703 OS Build 15063.674.

I installed Flash Player PPAPI plug-in version 27.0.0.183

I first tested both sites you provided on Opera 48.0.2685.50 and they both played fine.

I then updated to Opera 49.0.2725.34(PGO).  I navigated to helpx.adobe.com/flash-player.html and at first, the browser did not detect the Flash plugin.  I manually added the domain to the list of exceptions for Flash to play:

  1. Launch Opera
  2. Navigate to settings
  3. In the menu on the left, select Websites
  4. Locate the Flash section and click Manage Exception button link
    • Alternatively, skip steps 2-4 and go directly to opera://settings/contentExceptions#plugins
  5. In the Hostname pattern field enter helpx.adobe.com and in the corresponding drop-down menu, select Allow
  6. click Done to close the Manage Exceptions window
  7. Refresh/reload Opera and navigate to helpx.adobe.com/flash-player.html
  8. Click the Check Now button
  9. Opera will now allow Flash content and display the version installed:

You will  need to Allow flash on both sites you provided by clicking the 'Get Adobe Flash Player' button, which will display the option to allow/deny Flash.

Forbidden Garden game:

Click the Get Adobe Flash Player button

The info bar displays, asking to allow/deny flash.  Click Allow

Opera enables Flash and the game plays with Flash content:

Klondike game:

Click the Get Adobe Flash Player button

The info bar displays, asking to allow/deny flash.  Click Allow

Opera enables Flash and the game plays with Flash content:

If you navigate back to opera://settings/contentExceptions#plugins you'll see that https://apps.facebook.com:443 has been added to the list of Flash Exceptions.

As long as this is listed here, you shouldn't have to 'Allow' Flash again on https://apps.facebook.com:443.

If you continue to have issues with enabling Flash on Opera, I recommend contacting Opera as it's the click-to-play Flash implementation that determines when Flash will load, not the plugin itself.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Nov 09, 2017

Copy link to clipboard

Copied

I should have mentioned that I am running windows home edition - sorry about that.

The darn thing was running just fine with the Opera 48.0 version yesterday and first thing this morning and I have been trying to figure out how to go back to that version since posting here and on the opera site.

Thanks so very much for all the help.  I will follow the steps you have given and hopefully things will be working again.   I will also be contacting Opera to let them know about the issue.

Again, Thank You So Very Much

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Nov 09, 2017

Copy link to clipboard

Copied

You're welcome.  I did assume you had the Home edition, which is what I used to test.

I forgot to mention, it's possible the content hasn't been updated to conform to Opera's changes.  Although, this (disable flash by default) has been in the pipeline for quite sometime on Chromium, which Opera is based on.

I looked at the the Opera change log, Changelog for 49 - Opera Desktop​, and see "DNA-63703 Remove Click to Play option to align flash settings with chromium" in the '49.0.2723.0 – 2017-09-25' section, so this has been in the works in Opera 49 (first in dev version, then beta version) for almost 2 months, giving developers time to adjust their content, if needed.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Nov 09, 2017

Copy link to clipboard

Copied

Well, I was able to add the link to the exceptions but I am still getting a message that flash player is not installed - darn opera and their changes!!!!

Anyway, I also noticed that I am not getting any sort of pop-up asking me to allow or deny the flash player when at those sites.   I did enter the apps.facebook.com:443

to the exceptions list and that does get me the screen you are showing - but no pop-up asking me to allow or deny it.c

I have contacted Opera to let them know what you said and hopefully they will be able to do something on their side or at least let me know how to go back to the version 48.0

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Nov 09, 2017

Copy link to clipboard

Copied

Do you see the 'Get Adobe Flash Player' image, the one I circled in my screenshot?

Can you post a screenshot of the Facebook app game screen you're seeing? For posting a screenshot, see https://forums.adobe.com/docs/DOC-7043#jive_content_id_How_do_I_attach_a_screenshot

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Nov 09, 2017

Copy link to clipboard

Copied

If I go to the one game website I get a screen shot like you have shown (but that only started after I added apps.facebook.com:443 to the exceptions list and the other game is still showing the screen telling me update or install the flash playerforbidden screen shot.JPGklondike screen shot.JPG

when I click on either one of them, it takes me to the adobe site to download the flash player and I am not getting any sort of message to allow or deny as you have shown.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Nov 09, 2017

Copy link to clipboard

Copied

I'm having the same problem. I too updated to Opera 49 and can't get flash to work after following all the steps mentioned here. I also notified Opera about the situation. It definitely is a problem on their end since many other users have been complaining about the sudden inability to use flash with the latest version of Opera.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Nov 10, 2017

Copy link to clipboard

Copied

when I click on either one of them, it takes me to the adobe site to download the flash player and I am not getting any sort of message to allow or deny as you have shown.

I'm not sure why it's taking you to the Adobe download site instead of displaying the info bar at the top with the option to enable Flash.  Since this is browser behaviour, and not Flash Player, I recommend contacting Opera for assistance.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Nov 10, 2017

Copy link to clipboard

Copied

So sorry to hear that you are also having the same issues, but at the same time, I am glad to hear that it isn't just me having this issue.  I was actually hoping that after having shut down the computer for the evening and not booting back up until about 12 hours later that perhaps the issue would have been resolved.  But no such luck.

I did contact Opera about the issue as well yesterday - but they have not been able to give me any real help either.  

At least we know that it is an issue with Opera and not Flash Player and hopefully they will have some sort of fix for the problem.  If not, I am going to start looking for another browser to use.  I might try uninstalling Opera 49.0 and then installing version 48.0 again but I hate to have to go through all the steps to load all my bookmarks and settings again.   

Thanks Again for all of your assistance.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Nov 18, 2017

Copy link to clipboard

Copied

Respectfully, I have the same above problem, I carried out all your above instructions but the problem still exists, I uninstalled and re-installed for several times either the flash player or the Opera browser, on one hand adobe Player help tells that I have not installed or not enabled the flash player, meanwhile I have installed it, on the other hand when I go to the Adobe Flash player page when I click(or right click) on the image/picture of the flash player, it is not enabled or it does not work, please what I must do to fix the above problem.

http://http://get.adobe.com/flashplayer/about/

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Nov 18, 2017

Copy link to clipboard

Copied

I have some screenshots, but I do not know how I must attach them here, I did not find any option.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Nov 18, 2017

Copy link to clipboard

Copied

Opera Flash Player 1.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Nov 18, 2017

Copy link to clipboard

Copied

Opera Flash Player 2.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Nov 18, 2017

Copy link to clipboard

Copied

Opera Problem Adobe Flash Layer Help Page.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Nov 18, 2017

Copy link to clipboard

Copied

Opera Flash Player Problem Opera Sitting.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Nov 18, 2017

Copy link to clipboard

Copied

Opera Flash Player Problem Window 10 Flash Player Sitting.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Dec 10, 2017

Copy link to clipboard

Copied

Hello there.

Can you please help me with this?

I have install flash player but now it is now working with Facebook videos.

I have follow the instructions of this link but it is still the same.

Enable Flash Player for Opera

Screenshot_2.png

Screenshot_3.png

Screenshot_4.pngScreenshot_5.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Dec 10, 2017

Copy link to clipboard

Copied

I was never able to find a permanent fix for the issue when using the Opera version 49 so I uninstalled it.  I did find steps on how to download and install an older version of Opera - but you must not be connected to the internet when installing it.  The reason being, it will automatically update to the current version if you are connected to the internet when doing the install.  You need to disable or block the auto-update feature after installing an older version and then allow your computer to connect to the internet again. 

https://www.askvg.com/tip-how-to-disable-or-block-auto-update-feature-in-opera-web-browser/

these posts are regarding version 40 but it will work for version 48 - you just need to find the offline installer.  
Rollback to previous version - where are old versions | Opera forums        Rollback to previous version - where are old versions | Opera forums       Frequently Asked Questions (Opera for Windows) Updated: Apr. 30 2017 | Opera forums

Unfortunately, it does not seem like Opera is doing anything to resolve this issue

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Dec 27, 2017

Copy link to clipboard

Copied

Thank you so much for the help.

Now it is fixed.

I really am appreciated the help.

Thank you again.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Nov 20, 2017

Copy link to clipboard

Copied

Wow, original poster did a great job documenting. I did all those similar things and am having same issue, but I am running Windows 7 Professional. I couldn't see that anyone in this thread found a solution that actually worked to figure out why Opera isn't seeing Flash. As a side note, I tried Firefox, exact same issue as Opera. Only browser I can run my Flash based FB game on right now appears to be Chrome that has built in Flash. I want my Opera back

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Nov 20, 2017

Copy link to clipboard

Copied

A commenter in Opera forum found and suggested a solution(as following) that fixed the above flash player problem for me and some other Opera user, I hope it help you:

"I've been playing with chrome://site-engagement more. Setting a site to 0, pressing enter and refreshing that page does indeed remove the site from the list.

Also, setting a site to 100 (and pressing ENTER to apply it) and refreshing the site's page often allows flash to work without even adding an exception to the list. I say "often" as it doesn't work all the time. Sometimes I have to close out of the tab for the site and open it up again. Other times I have to repeat that stuff a lot of times or refresh the site page a bunch of times. Then it works, again without adding an exception.

So, maybe try going to chrome://site-engagement and setting all the sites to 100 (making sure to press ENTER each time). Then, for sites where that still doesn't help, keep reloading the site for a while just to see if you can get it to work.

If a site isn't in the list, go to the site first and then it'll show up. If it still doesn't though, you'll have to try the exceptions list. Then it should show up in the site-engagement list where you can then set it to 100.

Not a solution. Just something to mess around with. Also, once it works for a page, I'm not sure if it keeps working (after a restart for example) yet. But, it looks like it persists."

In my case, I set each website to 100, pressing Enter, I repeated the above process for a few time because in the first time was not successful,and refreshing website was not enough but also the website should be closed and then be opened(in my case).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Nov 20, 2017

Copy link to clipboard

Copied

I discovered that the problem come back again after using Ccleaner in order to clean the PC and the browsers and again the above process over  "chrome: // site-engagement"must be repeated.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Nov 22, 2017

Copy link to clipboard

Copied

I have installed the new firefox browser - Quantum and the flashplayer works fine with that as well as with chrome and the vivaldi browser too!   The only browser I am having an issue with is the Opera browser.  I do believe that the folks here at Adobe are correct when they stated that it has to be related to the browser itself - yet Opera is of no help at all with the issue which is sad.  I have no problems at all running Google Chrome, or any other browser --- just Opera.

I may try the work around that shahram-b suggested but if I am going to have to jump through those hoops every time I run ccleaner then it simply is not worth it.  I wish that Opera would acknowledge that there is an issue and address that issue.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Nov 22, 2017

Copy link to clipboard

Copied

it took me a little while to find the site-engagement link that was suggested.  Typing opera://site-engagement  actually got me to that site and I changed anything related to adobe and facebook to 100 and now the games on facebook will load.   I actually typed chrome://site-engagement which I ended up doing a copy and paste of from https://www.ghacks.net/2016/12/11/google-chrome-html5-roll-out-plan/  in order to get there.   I must have been doing the copy and paste incorrectly or I did it from the one where there were spaces and then did not belong.   I will have to see if there is some way to change a setting in ccleaner so that when it runs it does not remove the setting changes so that opera will work.   Thanks for the suggestion

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Jan 12, 2018

Copy link to clipboard

Copied

OMG!!!  I have been working with the staff at Adobe for 2 days.  Nothing worked.  Went to the opera://site-engagement site and changed everything to 100....BAM!!!  Working again.   *bowing down* Thank you, thank you!!!!!!!!!!!!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Nov 20, 2017

Copy link to clipboard

Copied

In connection with Firefox I had the same problem that fixed easily in this sent going to Menu Ba>Tools>Add-ons and then in front of  shockwave Flash, the option of" Always Activate " must be chosen, and then the flash player will start working.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jan 30, 2018

Copy link to clipboard

Copied

Thank you !

[moderator: links to self-promoted and offensive content removed]

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...