Locked

Possible Solution to Firefox Hangs or Crashes.

Explorer ,
Dec 01, 2014 Dec 01, 2014

Copy link to clipboard

Copied

I've been going over this problem for months now and I think I may have at least solved my problem and I'm hoping it works for others. This is not a solution to all and some of you should be able to solve problems with an add-on update or reset. All through out the day my browser would just crash and become unresponsive. Usually due to Flash issues and unresponsive script. I have tried uninstalling Firefox and also resetting,  and even kept Adobe flash up to date all to no avail. Finally I ended up disabling my Hardware Accelerator and Smooth Scroll and so far I haven't crashed today. I am keeping my fingers crossed but so far it has been a good sign. I usually crash at least 20 times a day. I am hoping that it works for others as well. Here is a picture of the settings for people having a hard time finding it.

firefox options.JPG

Two more things that I've done which has drastically improved my internet browsing were two ad-ons for Firefox. First one which a lot of people are familiar with is Adblock Plus - Surf the web without annoying ads! Which stopped a lot of those annoying Flash ads that freeze up your browser. And also https://noscript.net/. That will stop pages from automatically running scripts. Some pages will look weird at first, but bottom right corner of your browser you will see an options button. Click it and you will see a list of scripts being run. just click on the scripts you want to allow and the page should appear normal without the other unnecessary scripts running. It should remember it so you will only have to do it the first time for a webpage. Good luck to you all and Hope that this helps at least a couple people having similar problems as mine.

Views

15.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Explorer , Dec 02, 2014 Dec 02, 2014
Verified that disabling the smooth scrolling worked for me. Its been three days without a crash. In my case the hardware accelerator didn't do anything. I still crashed. I don't understand why smooth scrolling would cause my browser to become unresponsive like that.

Likes

Translate

Translate
Explorer ,
Dec 02, 2014 Dec 02, 2014

Copy link to clipboard

Copied

Verified that disabling the smooth scrolling worked for me. Its been three days without a crash. In my case the hardware accelerator didn't do anything. I still crashed. I don't understand why smooth scrolling would cause my browser to become unresponsive like that.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 15, 2014 Dec 15, 2014

Copy link to clipboard

Copied

LATEST

I just disabled smooth scrolling. Even disabling hardware acceleration didn't help prevent this.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines