Locked

Process gets stuck while running Install Adobe Flash Player.app silently

New Here ,
Dec 06, 2017 Dec 06, 2017

Copy link to clipboard

Copied

I tried to run Adobe Flash Player.app silently using this command from a process launched from a LaunchDaemon

"/Volumes/Flash Player/Install Adobe Flash Player.app/Contents/MacOS/Adobe Flash Player Install Manager" -install"

Process gets stuck with this message

"_RegisterApplication(), FAILED TO establish the default connection to the WindowServer, _CGSDefaultConnection() is NULL."

This problem occurs only when I try to run this command with No Users Logged in. At other times, it works perfectly.

Any Suggestions? Root Cause?

Views

110

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Dec 06, 2017 Dec 06, 2017

Copy link to clipboard

Copied

I'm confirming if the use-case you are attempting is valid for the APP installer.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Dec 07, 2017 Dec 07, 2017

Copy link to clipboard

Copied

LATEST

Hi,

The scenario you are attempting isn't possible with the APP bundle installer, however, is possible with the PKG installer.  Please use the PKG installer to install Flash Player when no users's are logged on.

--

Maria

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines