Locked

Still Cannot Get Flash to Work in Opera for FB Games

Community Beginner ,
Jan 11, 2018 Jan 11, 2018

Copy link to clipboard

Copied

I can get flash to work on both Chrome and Firefox, but not Opera for FB games.  I have tried all the suggestions that I have read so far.  Adding exception of [*.]com to websites.  Changing the numeric value to 100.  Making sure to download the appropriate flash players for both FF and Opera and Chrome.  Uninstalling the old Adobe and reinstalling the new ones.  Games worked up until recently (maybe the last week or so).  Tried everything here: flash player on opera does not work  and here: Opera browser updated and now I can't get flash player to install 

I am running Windows Home Version 10.0.16299 Build 16299  Opera version 50.0.2762.58, Flash Player 28PP-HC and 28HC

This link says "Your Flash Player is Out of Date Please Update it to Play the Game." Christmas Dreams 2017 on Facebook | Facebook

Opera Snapshot_2018-01-11_220315_apps.facebook.com.png

TOPICS
Download install

Views

4.4K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Community Beginner , Jan 12, 2018 Jan 12, 2018
Ok, so I found this suggestion in another thread on here.  Go to opera://site-engagement and set all sites to 100.  I did that and BAM, everything works again and game will load.  So, this issue is resolved (at least until the next Opera update).  LOL  Thank you so much for being so helpful in trying to get this resolved.  I am very impressed with the Adobe staff.  Many thanks!!!  These forums are great and very helpful. 

Likes

Translate

Translate
Adobe Employee ,
Jan 11, 2018 Jan 11, 2018

Copy link to clipboard

Copied

Hi,

Did you try viewing any other Flash Content in Opera browser? Open Flash Player Help page and click on "Check Now" button to see the version of Flash Player installed. If the version installed is not 28.0.0.137, then you do not have the latest version of Flash Player. You can go Adobe Flash Player Install for all versions page in Opera browser and download the latest version.

If you have latest version then go to Flash Player Help page and refer to "Verify whether Flash Player is installed". If the above mentioned content is working, you need to contact the gaming company.

Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 12, 2018 Jan 12, 2018

Copy link to clipboard

Copied

Yes.  Did all of that and No, Flash player still isn't working by way of the check now website you posted above.  Attached is a screen shot.  Tried installing version from link you sent, still not working.  Tried installing the 28_pp gc and hc versions.  Still nothing working in Opera. Although all other browsers are fine.  I'm just stumped.  It has to be an Opera issue???

Opera Snapshot_2018-01-12_082224_helpx.adobe.com.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 12, 2018 Jan 12, 2018

Copy link to clipboard

Copied

While Opera 50 is based on Chromium 64, it appears to handle Flash requests differently.  For example, on Chrome, when clicking the 'check now' button on the helpx.adobe.com/flash-player.html page, Chrome intercepts the request and prompts the user to allow Flash.  Opera has no such behaviour, forcing users to go to opera://settings to add the domain to the list of exceptions.

I added [*.].com and it did nothing.  Not sure if it's a valid entry or not.

Please try adding https://* and http:// to the list of exceptions instead of [*.].com

Screen Shot 2018-01-12 at 9.25.33 AM.jpg

After adding https://* and http:// reload the browser. Flash Player will be detected on the http://helpx.adobe.com/flash-player.html page:

Screen Shot 2018-01-12 at 9.25.33 AM.jpg

It is also playing on the Christmas Dreams 2017 on Facebook | Facebook game:

Screen Shot 2018-01-12 at 9.30.56 AM.jpg

The black rectangle is not Flash content:

Screen Shot 2018-01-12 at 9.31.05 AM.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 12, 2018 Jan 12, 2018

Copy link to clipboard

Copied

Nope.  That didn't work either.  I added both of those exceptions and still get "Sorry Flash player is either not installed or not enabled."  Game still doesn't play.  Here is a screen shot of exceptions.  Thanks.Opera Snapshot_2018-01-12_124034_settings.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 12, 2018 Jan 12, 2018

Copy link to clipboard

Copied

I reset the flash options on my test machine and went to the game again.  I clicked the green 'Update' button and Opera prompted to enable Flash:

Screen Shot 2018-01-12 at 12.12.22 PM.jpg


I clicked 'Allow' and the browser refreshed, with Flash enabled.   This is essentially correct behaviour, as in this case, Opera intercepted the request to update Flash and prompted the user to enable Flash.

Going to Opera's Flash exception settings, the entry is https://apps.facebook.com:443:

Screen Shot 2018-01-12 at 12.15.42 PM.jpg

I see the entry in your screenshot is just https://apps.facebook.com.  Please add :443 to it and see if that'll work.

If this doesn't work, I would try clearing browser cache/cookies and reboot the machine. This may or may not work.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 12, 2018 Jan 12, 2018

Copy link to clipboard

Copied

I added the exceptions as you said (screen shot attached).  I have cleared all cache, cookies, browsing and download history "from the beginning of time" and rebooted my laptop.  The game still will not play and I'm still getting the message "Sorry flash player is either not installed or not enabled" at the Flash Player Help site.  Do you have any other suggestions?  Or is this just an Opera issue?  Thanks for your help.Opera Snapshot_2018-01-12_154726_settings.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 12, 2018 Jan 12, 2018

Copy link to clipboard

Copied

Ok, so I found this suggestion in another thread on here.  Go to opera://site-engagement and set all sites to 100.  I did that and BAM, everything works again and game will load.  So, this issue is resolved (at least until the next Opera update).  LOL  Thank you so much for being so helpful in trying to get this resolved.  I am very impressed with the Adobe staff.  Many thanks!!!  These forums are great and very helpful. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 12, 2018 Jan 12, 2018

Copy link to clipboard

Copied

Glad it's now working.

I hadn't suggested that because you said "Changing the numeric value to 100." in your first which I assumed to be the Site Engagement Index score.  Of course clearing cache would have reset that back to 0.  I'm assuming something else happened when you cleared the cache that enabled Flash to display again after you set it to 100 again.  Either way, I'm glad it's working now.

Theoretically, having just http://* and https://* in the Flash Exception list should work.  But now that it's working, I wouldn't mess with it.


To give you a heads up, Opera is changing these options again in Opera 51, which is currently in beta.  They're going to add the option 'Allow sites to run Flash'.  More info, including screenshot, at Opera 51 adds option to run Flash on All sites | Techdows

I don't think Opera has a set release cadence like Chrome, Firefox, and Flash Player etc.  There releases seem to happen anywhere from 40 - 60+ days apart, so no idea when Opera 51 will land in the stable channel.  They do post new releases to The Opera blog

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 12, 2018 Jan 12, 2018

Copy link to clipboard

Copied

Sorry.  Yes, I had changed the values to 100 at the Chrome engagement site because several people said that Opera pulls from Chrome.  I didn't know to go to the Opera engagement site.  Once I went to the Opera engagement site, that worked.  Thank you again for your help. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 12, 2018 Jan 12, 2018

Copy link to clipboard

Copied

Oh, I see.  While Opera is based on Chromium (what Chrome is based on), they don't communicate with each other.  And Opera may implement some of Chromium's behaviour differently.


You're very welcome.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 16, 2018 Jan 16, 2018

Copy link to clipboard

Copied

I usually play games FB on Chrome. I support flash better

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jan 17, 2018 Jan 17, 2018

Copy link to clipboard

Copied

It has been resolved.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 12, 2020 Jun 12, 2020

Copy link to clipboard

Copied

LATEST

flash player keeps shutting down on facebook game room and its very frustrating what can i do?

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines