• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

An error message that the API client cannot be initialized is displayed when starting FramaMaker.

New Here ,
Mar 14, 2024 Mar 14, 2024

Copy link to clipboard

Copied

I am writing code in C++ on Visual Studio (hereinafter referred to as VS) to create a plug-in (dll) to add a menu using FDK.

I created a simple sample using VS2022 (FDK2022 specification) to display "Hello World" when FramaMaker2022 starts.

"Hello World" is displayed when common language runtime support is set to "Do not use common language runtime support"

But,If I select "Common Language Runtime Support (/clr)", an error message will be displayed indicating that the API client cannot be initialized.

Do you know if it is possible to specify "Common Language Runtime Support (/clr)" as the common language runtime support when creating a FramaMaker2022 plug-in (dll)?

If it is possible to specify this, I would appreciate it if you could give me advice on setting other items.

TOPICS
FAQ , Technical Communication Suite

Views

62

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
no replies

Have something to add?

Join the conversation