Can't update templates from edd without loosing content

New Here ,
Apr 30, 2020 Apr 30, 2020

Copy link to clipboard

Copied

This is the first time that I have tried t update my templates with changes made to the EDD since upgrading to FM 2017, and I am not having much luck. When I start a new topic using the concept template, it looks like this:

Capture a.png

But after I import the EDD, that has new component items added, to the template and create a new topic, I get this:

Capture b.png

I have done this in previous versions of FM without any hitch. What is going on this time?

TOPICS
XML author

Views

367

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
May 04, 2020 May 04, 2020

Copy link to clipboard

Copied

Since your first example is a Concept and your second example is a Topic, wrapped in a top-level "dita" element, it's hard to say what the problem is.

 

Also, are you saying that you made changes to the EDD? Which one? Concept or Topic? DITA Version #?

 

Without any other info, I'd say that the context in your second example isn't recognized by the template file. The problem could be in the DITA version specified, in the template file applied, or in the rules you may have modified in the EDD.

 

Have you tried using the unmodified structapp files that shipped with your installed version?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
May 08, 2020 May 08, 2020

Copy link to clipboard

Copied

LATEST

See, that is the funny part. Both of those were started by selecting New > Dita > Concept. But if I do select a new Topic, where I haven't attaced the EDD to it, it opens similar to the first image.

The EDD I am using is one that was in place for quite a while now. It is simply labelled AwsomeEDD and that is the only one that has ever been changed to the best of my knowledge.

And I am still in Dita 1.2 as the one time I tried to move to Dita 1.3, only my new topics got exported to the help. Anthing that still said Dita 1.2 wasn't.

The only change that I made was to add a new choice to the component element.

And to your last question, if I use the unmodified structapp files, won't I be where I am with a new file being opened without any of the details that are shown in my first picture?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines