Changes made with "track text" in an inset do not appear in master document

New Here ,
Oct 23, 2017 Oct 23, 2017

Copy link to clipboard

Copied

Hello everyone,

I am using Framemaker 12 unstructured with text insets. I am currently making a review of the insets using the track text edits function. This works fine and the changes appear in the inset according to my settings. The problem however is that these changes do not appear correctly in the master document into which I import my insets.

Here a couple of example pictures to show the problem:

Sample 01.jpgSample 02.jpg

The picture on the left is my original inset with text edit corrections. The picture on the right is the same inset imported into the master document. As you can see, the colour settings etc. for the changes made only remain visible within the table. The other changes are visible but the coloured marking is gone. If I use the preview buttons (in the track text pod) in the master, the appearance of the inset changes to match the appearance of the original inset. However when I update the text inset properties in the master, the appearance "resets" back to what you see on the right.

I have now come to the conclusion that only changes made to text within tables will appear correctly in the master.

For your information, both inset and master have identical formatting, master pages and reference pages etc.

Can anyone help with this problem?

Thanks in advance

Grant Sinclair

Views

277

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 24, 2017 Oct 24, 2017

Copy link to clipboard

Copied

For clarification, you've set the Condition Indicators to show with both the inset and the destination document?

It seems you've stumbled across a screen refresh issue you should report at adobe.com/go/wish.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 25, 2017 Oct 25, 2017

Copy link to clipboard

Copied

Hi Matt. Thanks very much for your reply. When you mention "Condition Indicators", I assume you mean the colour settings for the added text and deleted text? In this case, yes they are the same. If it was a screen refresh issue, would this not mean that the changes in the destination document would still appear in the pdf print? (which is not the case). Inbetween times I have made a few experiments with vary simple inset and destination documents and it is always the case that only changes to text in a table will appear correctly in the destination document. As mentioned I can temporarily change the appearance of the the destination document with the preview final/Original/off buttons to match the appearance of the inset, but as always, as soon as I update the text inset properties, the coloured indicators disappear again. This issue makes reviewing the destination document very difficult and means I can only see the changes properly by opening each individual inset.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 26, 2021 Feb 26, 2021

Copy link to clipboard

Copied

I realize this is a pretty old posting, but did you ever find a solution for this? I'm using FrameMaker 2020 and have this exact same problem (i.e., changes in nested documents are visible in the parent document if they are in a table, but otherwise, the added and deleted text appears without marking of any kind). If you or anyone has found a fix, I would be extremely appreciative. I depend on our review process heavily, and so need these change indicators.

FWIW, this has been working for about six months just fine, and then stopped working a couple days ago. In fact, my changes from more than a couple days ago show correctly, but any new changes--even in same nested documents--don't distinguish between added, deleted, and old text.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 28, 2021 Feb 28, 2021

Copy link to clipboard

Copied

Rick

Have you updated the inset in the parent document? Right click on the inset and you should get this option.

Klaus

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 28, 2021 Feb 28, 2021

Copy link to clipboard

Copied

Thanks for the suggestion, but yes, I've updated it many times. I've been using this feature for six months with no problem, and it suddenly started doing this. If this forum allows it, I'll update my post with more details about what happens and when.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Feb 28, 2021 Feb 28, 2021

Copy link to clipboard

Copied

There are several things that happen:

  • Changes to the text do appear (after updating, of course), but not marked. Deleted text does not show in red and crossed out and new text does not appear in green.
  • Even if Preview Final or Preview Original is enabled, all text--deleted and inserted--shows for the nested documents (when looking at the parent document).
  • Everything looks correct when looking at the child FM file. These issues only manifest at the parent level.
  • Changes to the child documents that were made before this started (a few days ago) still appear correctly (green or red), even in the same child documents that are seeing this problem.
  • At least one child document is still showing changes correctly, so it would seem the problem is in the child documents.
  • I installed FM on a new machine, and when I loaded this document, the same thing happens, so again, it seems the issue (corruption?) is in the (child?) documents themselves.

This problem also manifested shortly after I discovered that Change Tracking can be set per file as well as per book. I have a feeling something about using those settings confused things. I've tried setting everything to be consistent, but no luck. Any other ideas? I'm happy to reinstall, but as I mentioned, it appears the problem is in the documents, not the settings (since the problem carried over to another machine).

Thanks in advance!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Feb 28, 2021 Feb 28, 2021

Copy link to clipboard

Copied

Could it be that text has a condition applied which is hidden?

I do very rarely use Track Text Edits in text insets, but I noticed a similar issue:

https://tracker.adobe.com/#/view/FRMAKER-9468

(You could search for "track" and find other reports. And you can vote, so that an issue gets more attention.)

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 01, 2021 Mar 01, 2021

Copy link to clipboard

Copied

LATEST

Thanks Winfried,

I voted for the bug you mentioned and I'll search for others like it. At the least, maybe one of their workarounds will help. 

It also got me to look at my issue in more detail, and I realized the changes that are still visible are within tables. Any text not within a table shows black text, whether inserted or deleted. But changes within a table shows correctly. Maybe I can find a workaround using that.

Thanks again. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines