DITA X-ref links breaking when re-loading/publishing

Community Beginner ,
Sep 06, 2021 Sep 06, 2021

Copy link to clipboard

Copied

Hi guys, 

 

I'm creating X-ref's to other HTML5 files in DITA (structured FM),

These are files that are stored locally on a drive and the documents ofter refer to other documents that have been converted to HTML5. 

 

The HREF target that I have been using has either been aquired from the 'Index' properies>security link, or from loading the index in chrome etc, and copying the link from the URL. 

 

When I set the X-ref initially and test it using CTRL + ALT + Left Mouse Button, it works just fine. 

 

However, when I reload the topic, the link breaks completely and upon inspecting the Href panel, the format appears to have changed. 

 

The inital Href format looks like this and works (you won't be able to open it)

Upon reloading it looks like this and does not work... 

  • ../ATP-85800141/Responsive%20HTML5/index.html#t=ATP-85800141%2FAll_Departments_(Company_Wide)%2FTP%2FATP-85800141%2FEquipment.htmlnts_(Company_Wide)_TP_ATP-85800141_Equipment.html

 

My question is, why??? 

 

I've had some working before, and they just seem to be okay, but more often than not they just don't work. 

 

TOPICS
Error , Responsive HTML5 , Structured , XML author

Views

31

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
no replies

Have something to add?

Join the conversation