• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

old framescript scripts and new version of framemaker

Participant ,
Feb 23, 2022 Feb 23, 2022

Copy link to clipboard

Copied

At work we currently are using Framemaker 11 (I know) and Framescript 6. We have been talking about finally upgrading to the newest version of both programs, but we have some concerns. We have several framescripts that we use daily when we make our manuals and they have been working perfectly for years. We are concerned that the switch will cause issues with the functionality of our scripts. Has anyone experienced issues with older framescripts no longer working correctly when upgrading? 

TOPICS
Content migration , Scripting , Technical Communication Suite

Views

145

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 23, 2022 Feb 23, 2022

Copy link to clipboard

Copied

The latest versions of FrameMaker are 64-bit (FrameMaker 11 is 32-bit) so you will need to upgrade any plugins, including FrameScript. FrameScript 7 is available and is for 64-bit versions of FrameMaker. See https://framescr.com/wb/

 

As far as the scripts themselves, they should work fine with FrameScript 7.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 23, 2022 Feb 23, 2022

Copy link to clipboard

Copied

But will the scripts still work with the newest Framemaker? When I talked with Frank at Elmsoft (Framescript) he was confident that the scripts would work with Framescript 7 but he couldn't verify that we'd have no issues with the new version of Framemaker. 

 

"There should be no substantial difference in scripts running on FrameScript 6 and FrameScript 7. However, it is a big jump from FM 11 to FM 2020. The scripts running might depend on the differences in FM more than any differences in FrameScript versions."

 

This was the reply I received from Elmsoft. 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 23, 2022 Feb 23, 2022

Copy link to clipboard

Copied

It depends on what the scripts do, but since higher versions of FrameMaker add features, so anything that worked in an older version should work in the new version. I have scripts that I wrote for clients when they were using FrameMaker 7 and they are still using them with FrameMaker 2020.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Feb 23, 2022 Feb 23, 2022

Copy link to clipboard

Copied

Thank you! This is comforting to hear. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 27, 2022 Feb 27, 2022

Copy link to clipboard

Copied

LATEST

I have also some FrameScript scripts which I had developed for older FM versions (OK, not FM 11).

Now I have FM 2020 and FrameScript 7, and everything works very well.

You should just test it. Download a FrameMaker trial version and a FrameScript trial version.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines