The Step Result element in the DITA tasks

Community Beginner ,
May 18, 2015 May 18, 2015

Copy link to clipboard

Copied

While creating a task in DITA, the Steps element contains Step > Step Result element. If I insert the Step Result element, the text "Step Result:" is also displayed in my published output. I would like to use the Step Result tag, but I do not want to see the Step Result text being displayed in my output. I have gone through the style guides, edds, dtds, but don't know where the text is coming from. Please help.

TOPICS
Structured

Views

448

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
May 18, 2015 May 18, 2015

Copy link to clipboard

Copied

I believe that you'll find this being applied by the associated paragraph tag as a referenced frame. Locate the template for this structured application, and modify the para tag to change the referenced frame to "None". The easiest way to determine the right tag to edit is by checking the paragraph definition in the task topic you're editing.

Good luck,

...scott

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 18, 2015 May 18, 2015

Copy link to clipboard

Copied

Hi ScottPrentice,

Thanks very much for the response. I followed your instructions, but no luck so far. Here's what I did:

1. Opened my task document > View > Reference pages. I could not locate Step Result referenced frame there.

2. Locate the template for this structured application - The template is Task.template. The template file is blank, so I opened the corresponding edd file: Task.edd

3. The First Format Rules and Text format Rules for the Step Result element are as follows:

First Paragraph Rules:

If Context is Step, use Step.result.begin

else use substep.result.begin

Text Format Rules:

If Context is Step, use paragraph format Step.result.begin

4. The Step.paragraph.begin paragraph style is being used here. You asked me to change the referenced file to none, but I did not find such syntax where I can make it none.

The easiest way to determine the right tag to edit is by checking the paragraph definition in the task topic you're editing.


The paragraph definition is step.result.begin. Could you please help me edit and remove the step result text from it?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
May 18, 2015 May 18, 2015

Copy link to clipboard

Copied

In the task topic, click in the paragraph with this text (the "step.result.begin" para), then open the Paragraph Designer (CTRL+m). On the Advanced "tab" (5th button from the left), you should see the "Frame Above Pgf" and "Frame Below Pgf" options .. one of them will probably have a frame referenced .. change that to "None" and click Update All. The "Step Result" text should disappear.

If that works .. then open the template file, and edit the "step.result.begin" para in the same way, then save the template and try opening your task topic again.

In theory, this should work.

...scott

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 18, 2015 May 18, 2015

Copy link to clipboard

Copied

ScottPrentice‌,

I followed those instructions, but for step.result.begin (or any other para) the Frame Above Pgf and Frame Below Pgf are None by default.

I removed step.result.begin style and applied Body style and generated webhelp. The Step Result text doesn't appear. Now I know for sure that the step.result.begin style is causing the issue, but still wondering where the text is displayed from. Please help

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advisor ,
May 18, 2015 May 18, 2015

Copy link to clipboard

Copied

The only other place to check would be a prefix provided by the "Autonumber format" (4th button on the Paragraph Designer). This extra text can only be coming from the paragraph style which points to a reference frame or sets an autonumber format. If it's not either of those it's hard-coded in the EDD to set one of those properties.

The other issue is that it's possible you're not looking at the right EDD or template. You can use Structure Tools > Set Structured Application to see what the structured application is currently applied (don't actually set it there, just use it to see what's currently set).

Keep digging!

...scott

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 18, 2015 May 18, 2015

Copy link to clipboard

Copied

ScottPrentice‌,

Neither the reference frame nor the Auto Number format has the default text. The Prefix tag is not added to the Step Result element either. However, I will dig my way deep in to it. If I ever got there, I will post it here. Thanks very much, Scott.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 25, 2021 Oct 25, 2021

Copy link to clipboard

Copied

LATEST

The paragraph designer / Autonumber format is actually correct. There's a text field containing "Step result:\sn".

This change has to be made in an ChapterOutputTpl.fm that has been exported and has to be imported again afterwards.

Imposting this here 6 years after the original post because this is literally the only useful ressource about this I could find after searching for a long time.

 

Adobe using 3 different ways to insert prefixes into a document and not documenting a single one of them is the perfect portrayal of the state of FrameMaker nowadays...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines