• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
1

Uninvited full stops in footnotes

Explorer ,
May 16, 2024 May 16, 2024

Copy link to clipboard

Copied

FM inserts full stops after note numbers 2 and 3 in the last two columns and after the numbers in all three notes beneath the table. Why?

The table is placed in a separate file. When I open that file, there are no full stops.

The paragraph style has the format Numeric (14) as numbering properties in the file with the table and in the file in which it is embedded.

TOPICS
Formatting and numbering

Views

136

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 3 Correct answers

Community Expert , May 16, 2024 May 16, 2024

If you want the formatting of the text inset doc to be reflected in the main doc, you can always open them both up and import the formats from the inset doc to the main one.

Votes

Translate

Translate
Community Expert , May 16, 2024 May 16, 2024

Hi Peter,

Is in your target document also the same cross-reference format as in your source document? If the text inset is set to Retain ..., then this should not matter. If you use Reformat Using Current Document's Catalog, you have to compare everything.

Which of the numbers in your table header are the table footnotes and which are the cross-references?

Are those with the numbers the table footnotes or the cross-references?

Can you check the footnote properties? You find them in Format | Docu

...

Votes

Translate

Translate
Community Expert , May 20, 2024 May 20, 2024

Hi Peter:

 

The root of this question (and the two you asked in your email to me) comes down to formatting inconsistencies between the .fm chapter file and .fm inset file being pulled in. You will want to standardize all of the formatting between the two files to be able to move forward confidently, as per @Winfried Reng and @Jeff_Coatsworth.

 

I think they set you on the right track, and importing the x-ref definition solved the full stop issue.   😊

 

To address the additional questions from y

...

Votes

Translate

Translate
Community Expert ,
May 16, 2024 May 16, 2024

Copy link to clipboard

Copied

Hi Peter,

When the table is in a separate file, this means that you import it as a text inset.

When you double-click this text inset (i.e. your table), then you get a dialog with some icons at the bottom.

The left icon is a gear wheel. When you click it, it shows the settings of the text inset.

I suspect that the formatting in the target document and in the source document are different.

What are the settings? What happens, when you change this to Retain Source's Formatting?

What are these numbers? These are table footnotes, aren't they?

When you have the same numbers, this means that the same number must be a cross-reference to the original cross-reference. Possibly the cross-reference format in the target document is different than the format in the source document.

You can see this all, when you double-click the numbers.

It's very good, when you add screenshots. However, best is to use the small icon (for me the 5th from the right) to insert a screenshot and not use the file dialog below the box to enter your text. Then the screenshot will be embedded in the text.

Best regards, Winfried

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 16, 2024 May 16, 2024

Copy link to clipboard

Copied

Hi Winfried and thank you for your answer!

Retaining the source document's settings solves the problem until I update the book. I don't know how to prevent this from happening.

The numbers have the format TableFootnote as you presumed.

Yes, the footnote numbers are references. I haven't been able to figure out exactly where the difference in numbering style is between the target and source documents. I use my own format for cross-references with the definition: <$paranum> (no full stop).

Best regards, Peter

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 16, 2024 May 16, 2024

Copy link to clipboard

Copied

If you want the formatting of the text inset doc to be reflected in the main doc, you can always open them both up and import the formats from the inset doc to the main one.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 16, 2024 May 16, 2024

Copy link to clipboard

Copied

Hi Peter,

Is in your target document also the same cross-reference format as in your source document? If the text inset is set to Retain ..., then this should not matter. If you use Reformat Using Current Document's Catalog, you have to compare everything.

Which of the numbers in your table header are the table footnotes and which are the cross-references?

Are those with the numbers the table footnotes or the cross-references?

Can you check the footnote properties? You find them in Format | Document | Footnote Properties.

How do you create the numbers with the cross-references? Do you add a character format with superscript to the cross-reference format?

Best regards, Winfried

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 19, 2024 May 19, 2024

Copy link to clipboard

Copied

Did you get this figured out, @Peter32610444u0rc? If not, I'm happy to take a look at the files. You can put the .fm file and the .fm text inset file on a file sharing server like dropbox and post the link here (public) or click my avatar above this reply and message it to me (private). (Or just google my email.)

 

~Barb

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 20, 2024 May 20, 2024

Copy link to clipboard

Copied

Hi Peter:

 

The root of this question (and the two you asked in your email to me) comes down to formatting inconsistencies between the .fm chapter file and .fm inset file being pulled in. You will want to standardize all of the formatting between the two files to be able to move forward confidently, as per @Winfried Reng and @Jeff_Coatsworth.

 

I think they set you on the right track, and importing the x-ref definition solved the full stop issue.   😊

 

To address the additional questions from your email:

Both files are set up in Format > Document > Footnote Properties to assign a style called TableFootnote to all new footnotes. However, in the inset file, the existing footnotes have been assigned Table Footnote and have overrides and character styles. FrameMaker is carrying in the duplicate style name and the overrides from the inset to the the chapter file, so that even though new notes will be Times New Roman 10 in both files, the existing notes are Arial 8. 

 

  • In the inset file, remove the overrides and assign all the notes TableFootnote. Remove Table Footnote from the file. Then remove and re-add the x-ref to table footnote 2 (it's holding on to the old formatting).
  • In the chapter file, remove Table Footnote. 
  • Update the inset. 

 

You should be good to go.

 

~Barb

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
May 21, 2024 May 21, 2024

Copy link to clipboard

Copied

Hi Barb,

The problematic format is no longer with us. Neither are the full stops. I want to thank you for taking the time to look at my files and helping me solve the problem! Thank you also to @Winfried Reng and @Jeff_Coatsworth!

Best regards, Peter

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 22, 2024 May 22, 2024

Copy link to clipboard

Copied

LATEST

We are always happy to help, Peter. 

~Barb 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines