Weird spacing in TOC after conversion to PDF

Adobe Community Professional ,
Sep 11, 2020 Sep 11, 2020

Copy link to clipboard

Copied

I have a chapter heading that is converting to PDF weirdly, but only for one file. The tags used for the headings are identical in both files. The tag used in the generated TOC is identical for both entries.

 

This is what it looks like in the generated TOC:

 

TOC in FrameMaker 2020.png

This is what it looks like after the PDF output is created. 

 

TOC after conversion to PDF.png

Why is the word Software so oddly spaced in both entries after conversion to PDF? It's only those two headings that convert so oddly. All the others are spaced correctly.

TOPICS
Formatting and numbering , Publishing

Views

666

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Oct 04, 2021 Oct 04, 2021
The issue reported was occuring due to following facts : "Asian Composer " was checked in for English content , FrameMaker expects this setting to be checked in case of CJK language only. "Language " selected was Chinese for English content . Issue will not occur once proper setting is followed  for english content . Thanks  Pulkit Nagpal FM & FMS Engg.

Likes

Translate

Translate
Adobe Community Professional ,
Jun 17, 2021 Jun 17, 2021

Copy link to clipboard

Copied

Unfortunate...

I did just vote for your Tracker item. It'd be nice to get it resolved!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 27, 2021 Jul 27, 2021

Copy link to clipboard

Copied

HI, I'm experiencing the same exact problem as Lin. 

I use the Segoe UI /Source Sans Pro/Kelson fonts - and they sometimes, only in specific places or specific word combinations come out exactly as Lin shows above (weird spacing and letters sticking together). 

I would love a solution to this problem. Using Save as PDF does help, but then I have problems with the graphics. I haven't tried the File>Print option - but I imagine that will not support the transparencies for the graphics I need. 

I must say - this is very frustrating!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 27, 2021 Jul 27, 2021

Copy link to clipboard

Copied

While I'm sorry you're experiencing the same issue, it's so nice to hear from someone else it happened to. Sometimes I feel like a real edge case, you know?

 

If it weren't that the TOC needs to link to locations in the PDF, I'd be tempted to PDF the TOC separate from the rest of it and then insert it later on.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 27, 2021 Jul 27, 2021

Copy link to clipboard

Copied

You mentioned "Save as PDF does help, but then I have problems with the graphics"...

What are your graphics issues?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 27, 2021 Jul 27, 2021

Copy link to clipboard

Copied

Hi Matt, 

The transparencies don't go through.  I retried the SaveAsPDF and that apparently uses the last joboption used by the Publish option - so sometimes it works and sometimes not. However, as Lin described, the Print option (File>Print) to PS and then distilling does give me the fonts ok - just my graphic transparencies don't work then. I found a solution online (search online: Framemaker Transparencies in PDF) from "GeoF/X" from years back on how to write the PS code on the file so that transparencies do work - and that did help, but it's complicated when I have more than one graphic transparency. You can see the problem in the pic I attached. This graphic problem, the Adobe guys fixed in the FM 2020 version, via the Publish pod apparently. Which is great. But now we have to work on these font problems.

-OZ

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 27, 2021 Jul 27, 2021

Copy link to clipboard

Copied

Taking a step back, have you compared the settings used for the Print method to the ones used for the Publish method? 

When I've run into this issue, I've always been able to get past it by rechecking/changing the conversion settings.

I have a post that is basically my troubleshooting notes on using the Distiller method at 

https://techcommtools.com/framemaker-pdf-tips-and-tricks/

 

You may have already addressed the things I mention, but it might be worth checking each of the settings described there.

 

-Matt

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 27, 2021 Jul 27, 2021

Copy link to clipboard

Copied

PDFX/4 should be the joboptions used for supporting transparency.

If you don't see PDFX/4 in your settings, see https://techcommtools.com/perfect-pdf/ for an explanation, and a video showing info about installing the latest PDF-A and PDF-X options. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Oct 04, 2021 Oct 04, 2021

Copy link to clipboard

Copied

LATEST

The issue reported was occuring due to following facts :

  • "Asian Composer " was checked in for English content , FrameMaker expects this setting to be checked in case of CJK language only.
  • "Language " selected was Chinese for English content .

 

Issue will not occur once proper setting is followed  for english content .

Thanks 
Pulkit Nagpal
FM & FMS Engg.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines